Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Ошибки при обновлении репозиторий.  (Прочитано 53333 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн keeeper

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Ошибки при обновлении репозиторий.
« : 24 Августа 2009, 22:35:48 »
Я использую ubuntu всего 1 неделю и знакомых умных нет так что не подскажите как исправить вот это
W: Ошибка: http://ppa.launchpad.net hardy Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 6AF0E1940624A220
W: Ошибка: http://ppa.launchpad.net hardy Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY E9372975FC15D0BB
W: Ошибка: http://www.virtualbox.org gutsy Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY DCF9F87B6DFBCBAE
W: Вы можете запустить 'apt-get update' для исправления этих ошибок

Оффлайн xkool

  • Старожил
  • *
  • Сообщений: 1459
  • do not love my brain
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #1 : 24 Августа 2009, 22:43:26 »
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com XXXXXXXX ,вместо ХХХХХХ подставь свои буквы и цифры,например sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com DCF9F87B6DFBCBAE после добавления ключей sudo apt-get update
Лучше маленький доллар, чем большое спасибо.

Оффлайн keeeper

  • Автор темы
  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #2 : 25 Августа 2009, 20:50:02 »
Спасибо

Оффлайн modest_man

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #3 : 26 Августа 2009, 00:38:44 »
Недавно установил ubuntu 9.04, при обновлении появляются ошибки:
Цитировать
W: Ошибка: http://deb.opera.com lenny Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 033431536A423791
W: Не удалось загрузить http://ru.archive.ubuntu.com/ubuntu/dists/jaunty/Release.gpg  Не удалось найти IP адрес для ru.archive.ubuntu.com
W: Не удалось загрузить http://ru.archive.ubuntu.com/ubuntu/dists/jaunty-backports/universe/i18n/Translation-ru.bz2  Не удалось найти IP адрес для ru.archive.ubuntu.com
W: Не удалось загрузить http://security.ubuntu.com/ubuntu/dists/jaunty-security/multiverse/i18n/Translation-ru.bz2  Не удалось найти IP адрес для security.ubuntu.com
Эти сервера только у меня не доступны из-за проблем с интернетом? или их можно заменить на какие-то другие репозитории?

Оффлайн Puggy

  • Любитель
  • *
  • Сообщений: 88
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #4 : 11 Октября 2009, 00:04:14 »
Здрасте, чтобы не создавать тему пишу сюда.
В одной из инструкций необходимо добавить репозитарий:
 
sudo sh -c "echo 'deb http://ppa.launchpad.net/intuitivenipple/ubuntu $(lsb_release -sc) main' >/etc/apt/sources.list.d/intuitivenipple.list"
sudo apt-get update

вылазит следующее:
W: Ошибка: http://ppa.launchpad.net jaunty Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 727D031129047922
Заходил на http://ppa.launchpad.net/intuitivenipple/ubuntu там ключа физически нет, решил добавить вручную под http://ppa.launchpad.net/intuitivenipple/ubuntu/dists/jaunty/ нашел файл    Release.gpg

sudo apt-key add Release.gpg
gpg: не найдено данных формата OpenPGP.

Как правильно найти и добавить ключ?

Оффлайн athost

  • Старожил
  • *
  • Сообщений: 1897
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #5 : 11 Октября 2009, 00:18:06 »
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 29047922

https://launchpad.net/~intuitivenipple/+archive/ppa

Оффлайн Puggy

  • Любитель
  • *
  • Сообщений: 88
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #6 : 11 Октября 2009, 00:35:27 »
Огромное спасибо!

Оффлайн Cameleon

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #7 : 27 Октября 2009, 19:54:44 »
пробовал обновить 7.04  вот, что пишет
cawa@ubuntu:~$ sudo sh -c "echo 'deb http://ppa.launchpad.net/intuitivenipple/ubuntu $(lsb_release -sc) main' >/etc/apt/sources.list.d/intuitivenipple.list"
cawa@ubuntu:~$ sudo apt-get update
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy Release.gpg
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main Translation-ru
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted Translation-ru
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy Release 
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main Packages
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted Packages
Err cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main Packages
  Пожалуйста, используйте apt-cdrom, чтобы APT смог распознать данный CD. apt-get update не используется для добавления нового CD
Err cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted Packages
  Пожалуйста, используйте apt-cdrom, чтобы APT смог распознать данный CD. apt-get update не используется для добавления нового CD
Ign http://ftp.debian.org sarge Release.gpg                                   
Ign http://ftp.debian.org sarge/main Translation-ru                           
Получено:1 http://ppa.launchpad.net feisty Release.gpg [307B]                 
Ign http://archive.ubuntu.com feisty Release.gpg                               
Ign http://archive.ubuntu.com feisty/main Translation-ru                       
Ign http://ppa.launchpad.net feisty/main Translation-ru                       
Ign http://archive.ubuntu.com feisty/restricted Translation-ru                 
Ign http://archive.ubuntu.com feisty/multiverse Translation-ru                 
Ign http://archive.ubuntu.com feisty/universe Translation-ru                   
Ign http://archive.ubuntu.com feisty/multiverse Translation-ru                 
Ign http://archive.ubuntu.com feisty/universe Translation-ru                   
Ign http://archive.ubuntu.com feisty-updates Release.gpg                       
Ign http://archive.ubuntu.com feisty-updates/main Translation-ru               
Ign http://archive.ubuntu.com feisty-updates/restricted Translation-ru         
Получено:2 http://ppa.launchpad.net feisty Release [24,2kB]                   
Ign http://ftp.debian.org sarge Release                                       
Ign http://archive.ubuntu.com feisty-updates/multiverse Translation-ru         
Ign http://archive.ubuntu.com feisty-updates/universe Translation-ru   
Ign http://ftp.debian.org sarge/main Packages                                 
Ign http://archive.ubuntu.com feisty-security Release.gpg                     
Ign http://archive.ubuntu.com feisty-security/main Translation-ru             
Ign http://archive.ubuntu.com feisty-security/restricted Translation-ru       
Ign http://archive.ubuntu.com feisty-security/multiverse Translation-ru       
Ign http://archive.ubuntu.com feisty-security/universe Translation-ru         
Ign http://archive.ubuntu.com feisty Release                                   
Ign http://archive.ubuntu.com feisty-updates Release                           
Ign http://archive.ubuntu.com feisty-security Release                         
Err http://ftp.debian.org sarge/main Packages                                 
  404 Not Found
Ign http://archive.ubuntu.com feisty/main Packages                             
Ign http://archive.ubuntu.com feisty/restricted Packages         
Ign http://archive.ubuntu.com feisty/multiverse Packages         
Ign http://archive.ubuntu.com feisty/universe Packages           
Ign http://archive.ubuntu.com feisty/multiverse Packages         
Ign http://archive.ubuntu.com feisty/universe Packages           
Ign http://ppa.launchpad.net feisty Release                       
Ign http://archive.ubuntu.com feisty-updates/main Packages       
Ign http://archive.ubuntu.com feisty-updates/restricted Packages               
Ign http://archive.ubuntu.com feisty-updates/multiverse Packages               
Ign http://archive.ubuntu.com feisty-updates/universe Packages                 
Ign http://ppa.launchpad.net feisty/main Packages                             
Ign http://archive.ubuntu.com feisty-security/main Packages                   
Ign http://archive.ubuntu.com feisty-security/restricted Packages
Ign http://archive.ubuntu.com feisty-security/multiverse Packages             
Ign http://archive.ubuntu.com feisty-security/universe Packages               
Err http://archive.ubuntu.com feisty/main Packages                             
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty/restricted Packages                       
  404 Not Found [IP: 91.189.88.31 80]
Получено:3 http://ppa.launchpad.net feisty/main Packages [29B]                 
Err http://archive.ubuntu.com feisty/multiverse Packages                       
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty/universe Packages
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty/multiverse Packages
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty/universe Packages
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty-updates/main Packages     
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty-updates/restricted Packages
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty-updates/multiverse Packages
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty-updates/universe Packages
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty-security/main Packages
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty-security/restricted Packages
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty-security/multiverse Packages
  404 Not Found [IP: 91.189.88.31 80]
Err http://archive.ubuntu.com feisty-security/universe Packages
  404 Not Found [IP: 91.189.88.31 80]
Получено 24,5kB за 1s (12,9kB/c)           
Не удалось загрузить cdrom:[Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423)]/dists/hardy/main/binary-i386/Packages.gz  Пожалуйста, используйте apt-cdrom, чтобы APT смог распознать данный CD. apt-get update не используется для добавления нового CD
Не удалось загрузить cdrom:[Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423)]/dists/hardy/restricted/binary-i386/Packages.gz  Пожалуйста, используйте apt-cdrom, чтобы APT смог распознать данный CD. apt-get update не используется для добавления нового CD
Не удалось загрузить http://ftp.debian.org/dists/sarge/main/binary-i386/Packages.gz  404 Not Found
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty/restricted/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty-updates/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty-updates/restricted/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty-updates/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty-updates/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty-security/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty-security/restricted/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty-security/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Не удалось загрузить http://archive.ubuntu.com/ubuntu/dists/feisty-security/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]
Чтение списков пакетов... Готово
W: GPG error: http://ppa.launchpad.net feisty Release: Следующие подписи не могут быть проверены, так как недоступен общий ключ: NO_PUBKEY 727D031129047922
W: Вы можете запустить 'apt-get update' для исправления этих ошибок
E: Некоторые индексные файлы не загрузились, они были проигнорированы или вместо них были использованы старые версии
cawa@ubuntu:~$ apt-get update
E: Не могу открыть файл блокировки /var/lib/apt/lists/lock - open (13 Permission denied)
E: Невозможно заблокировать каталог со списками пакетов
cawa@ubuntu:~$


Оффлайн Demon SDA

  • Любитель
  • *
  • Сообщений: 68
  • Сетевой серфер
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #8 : 08 Ноября 2009, 11:18:18 »
Добавил репозитории, в результате после апдейта вижу следующие ошибки следующего вида:
W: Ошибка: http://ppa.launchpad.net jaunty Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 60D11217247D1CFF
....
Из выше прочитанного, я правильно понял, что для исправления следует ввести:
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 60D11217247D1CFF
.....
Тоесть требуемый ключ есть в тексте ошибки выводимой в терминале?
Ubuntu Mate 18.04.1 x64, C2Q-9400, GB X48-DQ6, RAM 8Gb, GF710.

Оффлайн aliftin

  • Старожил
  • *
  • Сообщений: 1398
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #9 : 08 Ноября 2009, 11:26:45 »
Demon SDA, что то у вас адрес репа коротковат. Попробуйте сделать все заново или оставьте тут ссылку на интересующий вас реп с программой. Cameleon , 7.04 больше не поддерживается, ставить и обновлять ее безсмысленно.
« Последнее редактирование: 08 Ноября 2009, 11:30:27 от aliftin »
Если мы не можем до чего то дотянуться, мы виним в этом не свой рост, не отсутствие табуретки, а свою цель.

Оффлайн IDDQD

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #10 : 27 Ноября 2009, 21:46:51 »
Всем доброго времени суток.
Поставил вчера Ubuntu 7.1 (серверную версию) машина вот такая
Pentium 200 MMX (200 MHz), 256 Mb SDRAM, MainBoard LuckyStar 5VPX2, HDD 20 Gb, Ethernet Conexant(RTL? не уверен)

Очень долго это все ставилось и поставилось. Дома стоит Роутер D-Link DL-624 от него во время установки был получен IP. Машина пингует подсеть и Yandex. Но не хочет обновляться из стандартных репозиториев, еще при установке в SOURCES.LIST все было закоментировано (#) с припиской рядом, что мол проверить не удалось вот и закоментировано. Что делать??? Прокси нет.

ЗЫ. Мож я что не так спросил или объяснил, я просто новенький.

ЗЫ2 Мануал прочитал, там написано как пользоваться командами- я ими пользовался. Итог- репозитории не могут быть найдены

Пользователь решил продолжить мысль 27 Ноября 2009, 22:15:59:
Как то все решилось, а именно так

Please make sure you have the following sources.list, change CODENAME to your release, e.g. breezy.

## EOL upgrade sources.list
# Required
deb http://old-releases.ubuntu.com/ubuntu/ CODENAME main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-security main restricted universe multiverse

# Optional
#deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-backports main restricted universe multiverse

« Последнее редактирование: 27 Ноября 2009, 22:15:59 от IDDQD »

Оффлайн aliftin

  • Старожил
  • *
  • Сообщений: 1398
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #11 : 27 Ноября 2009, 22:29:15 »
Они не могут быть найдены, так как 7.10 уже не поддерживается.
Если мы не можем до чего то дотянуться, мы виним в этом не свой рост, не отсутствие табуретки, а свою цель.

Оффлайн Random-al

  • Новичок
  • *
  • Сообщений: 5
  • Тапки?! Да срал я на ваши тапки!!!
    • Просмотр профиля
    • http://random-al.cz.cc
Re: Ошибки при обновлении репозиторий.
« Ответ #12 : 23 Марта 2010, 21:58:16 »
Сегодня тоже столкнулся с данной проблемой " ...так как недоступен общий ключ: NO_PUBKEY 6A..." в поиска решений наткнулся на очень интересный скрипт http://bazaar.launchpad.net/%7Eoldman/%2Bjunk/launchpad-update/download/head%3A/launchpadupdate-20090603123623-qo8gcw2k08v3dib8-1/launchpad-update который обновил необходимые ключи и решил проблему.
« Последнее редактирование: 23 Марта 2010, 22:01:40 от Random-al »

Оффлайн niomen

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #13 : 04 Мая 2010, 17:41:52 »
Сегодня тоже столкнулся с данной проблемой " ...так как недоступен общий ключ: NO_PUBKEY 6A..." в поиска решений наткнулся на очень интересный скрипт http://bazaar.launchpad.net/%7Eoldman/%2Bjunk/launchpad-update/download/head%3A/launchpadupdate-20090603123623-qo8gcw2k08v3dib8-1/launchpad-update который обновил необходимые ключи и решил проблему.

 И как этот файл запустить, подскажи пожалуйста. :idiot2:

Оффлайн gregory5

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5085
    • Просмотр профиля
Re: Ошибки при обновлении репозиторий.
« Ответ #14 : 04 Мая 2010, 17:49:50 »
в свойствах выставь позволять выполнять как программу и запусти

 

Страница сгенерирована за 0.045 секунд. Запросов: 25.