Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Видео драйвер VIA на Ubuntu 9.04 (HP2133)  (Прочитано 2097 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Slezhuk

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Видео драйвер VIA на Ubuntu 9.04 (HP2133)
« : 07 Сентябрь 2009, 14:43:12 »
Не совсем уверен, что тема для этой ветки, прошу прощения если ошибся.
Итак сначала: имеем ноутбук HP2133 с Ubuntu 9.04. Видео заработало "изкоробки", за исключением Compiz'а.
Насколько я понял из прочитанного, помогут мне в этом драйвера VIA, которые можно скачать здесь. Однако по приведенной ссылке бинарных драйверов под 9.04 нет, но есть исходники! Качаем, распаковываем, следуя инструкции запускаем ./autogen.sh , устанавливаем недостающие пакеты, снова запускаем ./autogen.sh после чего выдаёт много чего, в том числе и такие строчки вконце:
./configure: line 11962: syntax error near unexpected tpken `XINERAMA, '
./configure: line 11962: `XORG_DRIVER_CHECK_EXT(XINERAMA, xineramaproto)'
make не появляется, куда двигаться дальше незнаю... есть какие нибудь идеи?
Мир продвигается вперед не только мощными рывками его героев, но и скромными усилиями всех честных труженико

Оффлайн easy2002

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2786
  • Мурманск
    • Просмотр профиля
Re: Видео драйвер VIA на Ubuntu 9.04 (HP2133)
« Ответ #1 : 07 Сентябрь 2009, 14:55:57 »
м.б.
sudo apt-get install libxinerama-dev?
Tempora mutantur et nos mutantur in illis

Оффлайн Slezhuk

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Видео драйвер VIA на Ubuntu 9.04 (HP2133)
« Ответ #2 : 07 Сентябрь 2009, 15:57:35 »
Неа, не помогло :(
Результат идентичен исходному
Мир продвигается вперед не только мощными рывками его героев, но и скромными усилиями всех честных труженико

Оффлайн easy2002

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2786
  • Мурманск
    • Просмотр профиля
Re: Видео драйвер VIA на Ubuntu 9.04 (HP2133)
« Ответ #3 : 07 Сентябрь 2009, 16:10:57 »
а  x11proto-xinerama-dev?
Tempora mutantur et nos mutantur in illis

Оффлайн Belyaev Nikolay

  • Активист
  • *
  • Сообщений: 733
    • Просмотр профиля
    • моя работа- дробилки, грохота...
Re: Видео драйвер VIA на Ubuntu 9.04 (HP2133)
« Ответ #4 : 07 Сентябрь 2009, 16:42:25 »
посмотри здесь
https://wiki.ubuntu.com/LaptopTestingTeam/HP2133#Video%20Quirks

а вебкамера есть у тебя? работает нормально?
"Сначала они вас игнорируют, потом смеются над вами, потом борются с вами, а потом вы побеждаете"
Махатма Ганди

Оффлайн Slezhuk

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Видео драйвер VIA на Ubuntu 9.04 (HP2133)
« Ответ #5 : 07 Сентябрь 2009, 22:48:45 »
а  x11proto-xinerama-dev?
"Уже установлена самая новая версия x11proto-xinerama-dev."

посмотри здесь
https://wiki.ubuntu.com/LaptopTestingTeam/HP2133#Video%20Quirks

а вебкамера есть у тебя? работает нормально?
В вайт лист надо добавлять уже после установки VIA драйвера.
Вебкамера есть, но до неё ещё руки не доходили :)
даже пока что незнаю как проверить её работоспособность...
Мир продвигается вперед не только мощными рывками его героев, но и скромными усилиями всех честных труженико

Оффлайн GreatALF

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Видео драйвер VIA на Ubuntu 9.04 (HP2133)
« Ответ #6 : 31 Октябрь 2009, 13:02:17 »
Удалось поставить?

Оффлайн kimeriec

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Видео драйвер VIA на Ubuntu 9.04 (HP2133)
« Ответ #7 : 05 Январь 2010, 21:27:24 »
Доброго времени суток!!!!!!
Имеем ubuntu 9.04, via cn700 (roverbook w500l partner).
НЕ получается устновить драйвера на встроеную видио карту.
Перечитал весь форум и что выдаёт гугл.
Испробованные варианты:
help.ubuntu.com/community/openchrome
описание установки драйвера..
ТАкие же драйвера , только  другой версии с viaarena.com тоже не устанавливаются.
Все остальные советы сводились  к этому же...
Единственное что помогало до перезагрузки- это править файл компиза: sudo gedit /usr/bin/compiz
далее найти строку WHITELIST="nvidia intel ati radeon i810 fglrx" и исправить её WHITELIST="nvidia intel ati radeon i810 via"
После этого запускается компиз  и всё работает до  перезагрузки.
После чего приходим к тму,  с чего  и начали:
EE:
fail to load module "viavideo" (modul does not exist)
via (0) unkown EDID version
via (0) no valid initional configuration found
skreen found,but none have usable configuration

Что  совсем этим делать?
Подскажите плз .. А то  6 дней сражней плох отражаются на здоровье:(

 

Страница сгенерирована за 0.061 секунд. Запросов: 22.