Форум русскоязычного сообщества Ubuntu


Автор Тема: Проблема с LPT портом в Xubuntu 9.04  (Прочитано 1323 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sainty

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Проблема с LPT портом в Xubuntu 9.04
« : 08 Сентября 2009, 11:11:17 »
На работе есть необходимость в установке Xubuntu на старенькие компы, для использования их в качестве печатающей машинки. При установке принтера через LPT порт, столкнулся с проблемой. По умолчанию ЕГО НЕТ!!! Погуглив просторы интернета узнал что вроде перестали в 9.04 его ставить по умолчанию и достаточно подключить модуль

modprobe parport_pc io=0x378 irq=7

LPT порт появился, но после загрузки опять исчезает. А теперь собственно вопрос, где и чего прописать, чтобы lpt порт  не вываливался каждый раз, а остался в системе на веки вечные )))

P.S. честное слово гуглил как это сделать, но так и не нашел.

Оффлайн Просто Царь

  • Активист
  • *
  • Сообщений: 936
    • Просмотр профиля
Re: Проблема с LPT портом в Xubuntu 9.04
« Ответ #1 : 08 Сентября 2009, 11:47:35 »
есть он или нет по умолчанию не проверял, но если действительно так, то либо ядро пересобрать с загрузкой модуля либо в автозагрузку скрипт запихнуть который его будет подгружать. Я думаю второе предпочтительней

Оффлайн Sainty

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Проблема с LPT портом в Xubuntu 9.04
« Ответ #2 : 08 Сентября 2009, 12:27:46 »
Цитировать
есть он или нет по умолчанию не проверял, но если действительно так, то либо ядро пересобрать с загрузкой модуля либо в автозагрузку скрипт запихнуть который его будет подгружать. Я думаю второе предпочтительней

ядро пересобирать сильно утомительное дело, а скрипт мне кажется не совсем правильно. Есть ли варианты подписать загрузку модуля где нибудь в etc/modprobe.d/   , или скрипт единственное решение?

Оффлайн Просто Царь

  • Активист
  • *
  • Сообщений: 936
    • Просмотр профиля
Re: Проблема с LPT портом в Xubuntu 9.04
« Ответ #3 : 08 Сентября 2009, 13:02:16 »
а чем скрипт то не нравится?

Оффлайн Sainty

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Проблема с LPT портом в Xubuntu 9.04
« Ответ #4 : 09 Сентября 2009, 08:07:11 »
не стал заморачиваться и добавил скрипт в загрузку. Все работает.

 

Страница сгенерирована за 0.058 секунд. Запросов: 26.