Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Ошибка при обновлении openoffice.org-emailmerge  (Прочитано 561 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vo.one

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
  • sound dope :]
    • Просмотр профиля
При попытке обновиться, апдейтер виснит на этапе:
Выбор ранее не выбранного пакета openoffice.org-emailmerge.
(Чтение базы данных...
dpkg: важное предупреждение - список файлов пакета openoffice.org-emailmerge отсутствует. Предполагаем, что на данный момент у пакета нет установленных файлов.
на данный момент установлено 137774 файлов и каталогов.)
Подготовка к замене пакета openoffice.org-emailmerge 1:3.0.1-9ubuntu3 (используется файл .../openoffice.org-emailmerge_1%3a3.0.1-9ubuntu3_all.deb)...
В таком состоянии терминал может находиться долго. Подождав около 15мин снимаю с помощью ctrl+c, вижу сообщение о том, что невозможно обработать параметр --unpack,  и процесс убит по сигналу.
Пробовал из Synaptic удалить данный пакет, но система сообщает мне, что пакет полностью неработоспособен и для удаления его нужно сначала установить :) Далее события повторяются.
Делал следующее vo-one@x50:sudo apt-get  clean
vo-one@x50:~$ sudo apt-get -f install openoffice.org-emailmerge
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  lp-solve libgtksourceview1.0-0 python-utidylib libtidy-0.99-0
  libgnomeprint2.2-data python-feedparser libgtksourceview-common libwps-0.1-1
  libcolamd-3.2.0 libnautilus-burn4 python-gnome2-desktop python-chardet
  libgnomeprint2.2-0 libgnomeprintui2.2-0 libgnomeprintui2.2-common
  libgnomecups1.0-1
Для их удаления используйте 'apt-get autoremove'.
Пакеты, которые будут обновлены:
  openoffice.org-emailmerge
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 11 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 6772Б архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0B.
Получено:1 http://security.ubuntu.com jaunty-security/main openoffice.org-emailmerge 1:3.0.1-9ubuntu3.1 [6772B]
Получено 6772Б за 0s (24,1kБ/c)                
Выбор ранее не выбранного пакета openoffice.org-emailmerge.
(Чтение базы данных...
dpkg: важное предупреждение - список файлов пакета openoffice.org-emailmerge отсутствует. Предполагаем, что на данный момент у пакета нет установленных файлов.
на данный момент установлено 137774 файлов и каталогов.)
Подготовка к замене пакета openoffice.org-emailmerge 1:3.0.1-9ubuntu3 (используется файл .../openoffice.org-emailmerge_1%3a3.0.1-9ubuntu3.1_all.deb)...
далее система подвисает.
« Последнее редактирование: 09 Октябрь 2009, 00:01:59 от vo.one »
"Образ жизни - все, что у тебя есть" / D.Koonce

Оффлайн vo.one

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
  • sound dope :]
    • Просмотр профиля
Re: Ошибка при обновлении openoffice.org-emailmerge
« Ответ #1 : 12 Октябрь 2009, 11:07:49 »
Пробовал грузиться в recovery mode, оттуда запускал починку битых пакетов dpkg. Результатом стало сообщение о том,что Trying to fix an recursive error и о том,что Reboot needed. (сообщение я не записал). Система не отвечала более 15 мин, затем я вручную перезагрузил ноут.

Пользователь решил продолжить мысль 13 Октябрь 2009, 10:53:49:
up!
« Последнее редактирование: 13 Октябрь 2009, 10:53:49 от vo.one »
"Образ жизни - все, что у тебя есть" / D.Koonce

Оффлайн Exebeche

  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Ошибка при обновлении openoffice.org-emailmerge
« Ответ #2 : 28 Апрель 2010, 22:53:56 »
а как ответов то много
я вот тоже с наподобие столкнулся и что-то суровые бородатые дяди линуксоиды ничего до сих пор не придумали...
али вымерли все?

Оффлайн RedBeard

  • Активист
  • *
  • Сообщений: 740
    • Просмотр профиля
Re: Ошибка при обновлении openoffice.org-emailmerge
« Ответ #3 : 29 Апрель 2010, 00:15:17 »
Не вымерли! Спать-то надо когда-то! А по сути - сперва старый опенофис надо убрать, а потом уже новый ставить! Это если Инфровский. Родной нормально обновляется.

Пользователь решил продолжить мысль 29 Апрель 2010, 00:17:06:
При попытке обновиться, апдейтер виснит на этапе:
Выбор ранее не выбранного пакета openoffice.org-emailmerge.
(Чтение базы данных...
dpkg: важное предупреждение - список файлов пакета openoffice.org-emailmerge отсутствует. Предполагаем, что на данный момент у пакета нет установленных файлов.
на данный момент установлено 137774 файлов и каталогов.)
Подготовка к замене пакета openoffice.org-emailmerge 1:3.0.1-9ubuntu3 (используется файл .../openoffice.org-emailmerge_1%3a3.0.1-9ubuntu3_all.deb)...
В таком состоянии терминал может находиться долго. Подождав около 15мин снимаю с помощью ctrl+c, вижу сообщение о том, что невозможно обработать параметр --unpack,  и процесс убит по сигналу.
Пробовал из Synaptic удалить данный пакет, но система сообщает мне, что пакет полностью неработоспособен и для удаления его нужно сначала установить :) Далее события повторяются.
Делал следующее vo-one@x50:sudo apt-get  clean
vo-one@x50:~$ sudo apt-get -f install openoffice.org-emailmerge
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  lp-solve libgtksourceview1.0-0 python-utidylib libtidy-0.99-0
  libgnomeprint2.2-data python-feedparser libgtksourceview-common libwps-0.1-1
  libcolamd-3.2.0 libnautilus-burn4 python-gnome2-desktop python-chardet
  libgnomeprint2.2-0 libgnomeprintui2.2-0 libgnomeprintui2.2-common
  libgnomecups1.0-1
Для их удаления используйте 'apt-get autoremove'.
Пакеты, которые будут обновлены:
  openoffice.org-emailmerge
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 11 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 6772Б архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0B.
Получено:1 http://security.ubuntu.com jaunty-security/main openoffice.org-emailmerge 1:3.0.1-9ubuntu3.1 [6772B]
Получено 6772Б за 0s (24,1kБ/c)                
Выбор ранее не выбранного пакета openoffice.org-emailmerge.
(Чтение базы данных...
dpkg: важное предупреждение - список файлов пакета openoffice.org-emailmerge отсутствует. Предполагаем, что на данный момент у пакета нет установленных файлов.
на данный момент установлено 137774 файлов и каталогов.)
Подготовка к замене пакета openoffice.org-emailmerge 1:3.0.1-9ubuntu3 (используется файл .../openoffice.org-emailmerge_1%3a3.0.1-9ubuntu3.1_all.deb)...
далее система подвисает.
А если aptitude попробовать?
« Последнее редактирование: 29 Апрель 2010, 00:17:06 от RedBeard »

Оффлайн vo.one

  • Автор темы
  • Новичок
  • *
  • Сообщений: 21
  • sound dope :]
    • Просмотр профиля
Re: Ошибка при обновлении openoffice.org-emailmerge
« Ответ #4 : 29 Апрель 2010, 10:31:36 »
aptitude отвечал мне нечто вроде "перед тем как удалить пакет, его сначала нужно установить" :)
дело было давно, формулировки точной не помню. Но суть такова - пакет поврежден настолько,что чтобы его корректно удалить, нужно установить его, а затем "культурно" снести.
Пробовал грузиться в recovery и работать с aptitude оттуда, безрезультатно.
После двух недель мучений мною были сброшены на флешку все нужные конфиги, а система была переустановлена.
Конечно, бородатые линукосиды не оценят такой "виндовый" подход к проблеме, но иного выхода я не нашел.
"Образ жизни - все, что у тебя есть" / D.Koonce

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.