Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: cuneiform-linux-0.8.0  (Прочитано 10405 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн paulus

  • Автор темы
  • Активист
  • *
  • Сообщений: 503
    • Просмотр профиля
    • IMHOlogy
cuneiform-linux-0.8.0
« : 10 Октябрь 2009, 12:40:39 »
Всем привет! Нужен cuneiform-linux-0.8.0.deb Может где встречали или собрал кто-нибудь, поделитесь, пожалуйста. Заранее благодарен.

https://launchpad.net/cuneiform-linux/ - может плохо искал, но тут найти не могу.

p.s. нужно пощупать и последить за проектом, может не нужно будет использовать wine+FineReader 8. Вот бы еще и хороший gui к нему на gtk :-)
Free software for free people! Ubuntu != Unity...

Оффлайн aliftin

  • Старожил
  • *
  • Сообщений: 1398
    • Просмотр профиля
Re: cuneiform-linux-0.8.0
« Ответ #1 : 10 Октябрь 2009, 13:11:00 »
На gtk нет, есть только на qt, да и тот какой то ущербный. Что останавливает собрать самому, зависимости у него кажется простые. По крайней мере раньше собиралось легко. Есть в этом разделе тема про сборку более ранней версии, там и ссылка на gui. Так или иначе:
http://www.altlinux.org/Cuneiform-Qt

UP Вот еще нашел http://symmetrica.net/cuneiform-linux/yagf-ru.html, но то же qt. Судя по скринам более продвинутый.
« Последнее редактирование: 10 Октябрь 2009, 13:16:53 от aliftin »
Если мы не можем до чего то дотянуться, мы виним в этом не свой рост, не отсутствие табуретки, а свою цель.

Оффлайн KEIII

  • Активист
  • *
  • Сообщений: 368
    • Просмотр профиля
Linux Mint 17 Cinnamon amd64

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
Re: cuneiform-linux-0.8.0
« Ответ #3 : 10 Октябрь 2009, 15:45:29 »
Кто пользовался, может в курсе, там можно задавать не только текстовые регионы, но также таблицы, изображения, и ещё, хотя бы минимальное форматирование позволяет сохранять?

Оффлайн paulus

  • Автор темы
  • Активист
  • *
  • Сообщений: 503
    • Просмотр профиля
    • IMHOlogy
Re: cuneiform-linux-0.8.0
« Ответ #4 : 10 Октябрь 2009, 17:08:07 »
Кто пользовался, может в курсе, там можно задавать не только текстовые регионы, но также таблицы, изображения, и ещё, хотя бы минимальное форматирование позволяет сохранять?

вообщем побаловался я :-( очень долго ждать до нормальной работы, но листок другой отсканировать можно... тхт хоть рус. текст берет нормально, но без форматирвания, в html чуток форматирования есть, но тогда куски текста пропадают. Использовал простенький YAGF - 0.8.1. Все ваши желания и сохранять в odt :-)
Free software for free people! Ubuntu != Unity...

Оффлайн pehser

  • Активист
  • *
  • Сообщений: 586
  • sidux 64bit + KDE4 svn
    • Просмотр профиля
    • Магазин електро и бытовой техники в николаеве
Re: cuneiform-linux-0.8.0
« Ответ #5 : 12 Октябрь 2009, 09:41:58 »
мда  Cuneiform и YAGF тока под 9.04 по крайней мере YAGF собран на qt4.5 значит не зя запускать в 8.04 к тому же пакет собран через chekinstall  >:(

собрал и сделал нормальные пакеты (работает как 8.04 так и 9.04) и выложил в свой репозитарий deb http://debway.org.ua/repository/ unstable main YAGF 0.8.1 и cuneiform 0.8.0
« Последнее редактирование: 12 Октябрь 2009, 09:44:59 от pehser »

Оффлайн paulus

  • Автор темы
  • Активист
  • *
  • Сообщений: 503
    • Просмотр профиля
    • IMHOlogy
Re: cuneiform-linux-0.8.0
« Ответ #6 : 12 Октябрь 2009, 10:47:52 »
собрал и сделал нормальные пакеты (работает как 8.04 так и 9.04) и выложил в свой репозитарий
спасибо качну для karmic.

P.S. можно ли установленный cuneiform depends on  libmagick++1 (ссылка на libmagick++2, все работает) как-то "оставлять" в системе с ошибкой, а то при update/upgrade/install автоматически удаляется? libmagick++1 в кармик нет и раз все работает со ссылкой не очень нужен. А пока качаю вашу сборку. Спасибо.

Ваш пакет так же само ругается на отсутствие libmagick++1
« Последнее редактирование: 12 Октябрь 2009, 10:52:02 от paulus »
Free software for free people! Ubuntu != Unity...

Оффлайн pehser

  • Активист
  • *
  • Сообщений: 586
  • sidux 64bit + KDE4 svn
    • Просмотр профиля
    • Магазин електро и бытовой техники в николаеве
Re: cuneiform-linux-0.8.0
« Ответ #7 : 12 Октябрь 2009, 10:59:43 »
собрал и сделал нормальные пакеты (работает как 8.04 так и 9.04) и выложил в свой репозитарий
спасибо качну для karmic.

P.S. можно ли установленный cuneiform depends on  libmagick++1 (ссылка на libmagick++2, все работает) как-то "оставлять" в системе с ошибкой, а то при update/upgrade/install автоматически удаляется? libmagick++1 в кармик нет и раз все работает со ссылкой не очень нужен. А пока качаю вашу сборку. Спасибо.

Ваш пакет так же само ругается на отсутствие libmagick++1
скачаю сейчас karmic, гляну можно ли там запустить это сборку или под кармину придется пересобирать

Оффлайн paulus

  • Автор темы
  • Активист
  • *
  • Сообщений: 503
    • Просмотр профиля
    • IMHOlogy
Re: cuneiform-linux-0.8.0
« Ответ #8 : 12 Октябрь 2009, 13:34:03 »
скачаю сейчас karmic, гляну можно ли там запустить это сборку или под кармину придется пересобирать

она запускается, просто чуток ругается, пришлось с 9.04 пакеты доставить (хотя и без них отлично работает). Но все же, если возможно, то сборка под libmagick++2 была бы лучше. А нельзя ли в пакете зависимость просто переправить с ++1 на ++2 (простите за глупый вопрос)?
Free software for free people! Ubuntu != Unity...

Оффлайн pehser

  • Активист
  • *
  • Сообщений: 586
  • sidux 64bit + KDE4 svn
    • Просмотр профиля
    • Магазин електро и бытовой техники в николаеве
Re: cuneiform-linux-0.8.0
« Ответ #9 : 12 Октябрь 2009, 13:46:45 »
скачаю сейчас karmic, гляну можно ли там запустить это сборку или под кармину придется пересобирать

она запускается, просто чуток ругается, пришлось с 9.04 пакеты доставить (хотя и без них отлично работает). Но все же, если возможно, то сборка под libmagick++2 была бы лучше. А нельзя ли в пакете зависимость просто переправить с ++1 на ++2 (простите за глупый вопрос)?
если подправить то не будет работать в 8.04-9.04 та как там нету пакета в репе ++2 только ++1

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net
Re: cuneiform-linux-0.8.0
« Ответ #10 : 12 Октябрь 2009, 13:50:48 »
pehser, емнип, в зависимостях можно указывать что-то типа
libmagick++1 | libmagick++2

Оффлайн yaa13

  • Активист
  • *
  • Сообщений: 311
    • Просмотр профиля
Re: cuneiform-linux-0.8.0
« Ответ #11 : 12 Октябрь 2009, 13:51:37 »
pehser
А ключик к вашему репо прилагается? Скажите идент хотябы, если он на кейсерверах есть.

Оффлайн paulus

  • Автор темы
  • Активист
  • *
  • Сообщений: 503
    • Просмотр профиля
    • IMHOlogy
Re: cuneiform-linux-0.8.0
« Ответ #12 : 12 Октябрь 2009, 13:55:21 »
если подправить то не будет работать в 8.04-9.04 та как там нету пакета в репе ++2 только ++1
О чудо! Я уже себе сделал с ++2 как-то так:

paul@ubuntolog:~$ mkdir ~/temp/someprog
paul@ubuntolog:~$ dpkg -x /home/paul/temp/cuneiform_0.8.0~bzr412-1_jaunty_i386.deb ~/temp//someprog
paul@ubuntolog:~$ mkdir ~/temp/someprog/DEBIAN
paul@ubuntolog:~$ dpkg -e /home/paul/temp/cuneiform_0.8.0~bzr412-1_jaunty_i386.deb ~/temp/someprog/DEBIAN

vim ~/temp/DBIAN/control  --> libmagick++1 | libmagick++2

paul@ubuntolog:~$ dpkg -b ~/temp/someprog ~/temp/cuneiform_0.8.0~bzr412-1karmic_i386.deb
dpkg-deb: сборка пакета cuneiform в файл /home/paul/temp/cuneiform_0.8.0~bzr412-1karmic_i386.deb.

sudo ln -s /usr/lib/libMagick++.so.2 /usr/lib/libMagick++.so.1
А эту симв.ссылку можно как-то прописать в этот пакет, что бы она автоматически создавалась?


Спасибо: https://forum.ubuntu.ru/index.php?topic=2159.0
и вам, pehser тоже. Будете ли вы иногда посматривать в сторону cuneiform/yagf, чтобы с вашего репозитория можно было обновлять, когда выйдет karmic?

P.S. cuneiform сохраняет и в файл.rtf, но только из консоли и изображения текста должны быть в правильном направлении (не перевернутыми) или ничего не поймет.
Ждемсъ улучшений и gui-gtk лучше чем FineReader 8.0 (выше под wine'ом не видел)
« Последнее редактирование: 12 Октябрь 2009, 14:20:37 от paulus »
Free software for free people! Ubuntu != Unity...

Оффлайн pehser

  • Активист
  • *
  • Сообщений: 586
  • sidux 64bit + KDE4 svn
    • Просмотр профиля
    • Магазин електро и бытовой техники в николаеве
Re: cuneiform-linux-0.8.0
« Ответ #13 : 12 Октябрь 2009, 14:50:40 »
sudo ln -s /usr/lib/libMagick++.so.2 /usr/lib/libMagick++.so.1
А эту симв.ссылку можно как-то прописать в этот пакет, что бы она автоматически создавалась?
вот имено из этой за морочки я и говорил что нужно смотреть,
по этому сдесь вариант с зависемостей  (libmagick++1 | libmagick++2) полностью не спасает

может выдернуть  /usr/lib/libMagick++.so.1 и подлажить в сам пакет  и убрать из зависимостей libmagick++1  :idiot2:

Будете ли вы иногда посматривать в сторону cuneiform/yagf, чтобы с вашего репозитория можно было обновлять, когда выйдет karmic?

я в свой реп кладу тока те пакеты которые у меня у самого вызвали интерес так что конечно буду следить


Пользователь решил продолжить мысль 12 Октябрь 2009, 15:05:58:
pehser
А ключик к вашему репо прилагается? Скажите идент хотябы, если он на кейсерверах есть.
нет ключа пока нету, пока не осилил  :-[
« Последнее редактирование: 12 Октябрь 2009, 15:05:58 от pehser »

Оффлайн paulus

  • Автор темы
  • Активист
  • *
  • Сообщений: 503
    • Просмотр профиля
    • IMHOlogy
Re: cuneiform-linux-0.8.0
« Ответ #14 : 12 Октябрь 2009, 18:22:42 »
может выдернуть  /usr/lib/libMagick++.so.1 и подлажить в сам пакет  и убрать из зависимостей libmagick++1  :idiot2:
думаю, что это вряд ли поможет так как он тянет за собой еще два пакета. Легче руками симлинк сделать под кармик или собрать полностью новый пакет. Cборка под sid подойдет без заморочек:
http://www.mediafire.com/alexp
хотя конечно лучше репозиторий со сборками для кармик, мало ли в какое время какие-нибудь библиотеки могут временно не совпадать... и тащи/ищи потом новые пакеты, а  cuneiform не очень уж и маленький :-)
« Последнее редактирование: 12 Октябрь 2009, 18:45:39 от paulus »
Free software for free people! Ubuntu != Unity...

 

Страница сгенерирована за 0.061 секунд. Запросов: 24.