Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Ubuntu 9.10 and Canon MF  (Прочитано 2393 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dr_Peregar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Ubuntu 9.10 and Canon MF
« : 13 Октябрь 2009, 12:20:57 »
Проблем с данным девайсом в принципе никаких, кроме как установка драйверов из deb пакета (_http://support-au.canon.com.au/contents/AU/EN/0100093004.html (версия 1.90) 1.80 версия есть на любом сайте поддержки). Первая установка была еще на альфе, при установке никаких проблем не возникло, на бете ругаеться на неудовлетворенную зависимость libcupsys2, так как в системе установлен libcups2. Частично проблема решаеться методом игнора таковых sudo dpkg --force-depends -i cndrvcups-common_1.90-1_i386.deb cndrvcups-ufr2-uk_1.90-1_i386.deb , частично так как при любом update ругаеться на проблему зависимостей и выносит их. Хотелось бы еще настроить sane, если делать sane-find-scanner то показывает found USB scanner (vendor=0x04a9, product=0x26ee) at libusb:002:002 , а вот что если делать через sudo то found USB scanner (vendor=0x04a9 [Canon Inc.], product=0x26ee [MF4320-4350]) at libusb:002:002 , но при запуске xsane говорит что устройство не найдено... Помогите разрешить эти 2 проблемы как убрать зависимость и как подцепить на sane.

Оффлайн VinnyPooh

  • Почётный модератор
  • Старожил
  • *
  • Сообщений: 2577
  • В работе
    • Просмотр профиля
    • Linux для чайников (пых-пых)
Re: Ubuntu 9.10 and Canon MF
« Ответ #1 : 13 Октябрь 2009, 12:31:20 »
>Проблем с данным девайсом в принципе никаких

Очень стало интересно, а какой у вас MF ?
У меня старый MF 5750 не работал и не работает по причине отсутствия драйверов в принципе

Оффлайн Dr_Peregar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #2 : 13 Октябрь 2009, 13:10:01 »
MF 4340d работает на UFRII
Если ваш принтер не GDI то все должно работать на этом дровье, что то в описании не понял на чем он работает. Похоже он у вас таки GDI а это не есть хорошо, так что принтсервер вам в помощь.

Оффлайн Dr_Peregar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #3 : 15 Октябрь 2009, 19:59:08 »
Вообщем подправил зависимость методом изминения в control параметра libcupsys2 на libcups2 >=1.3.9 в результате чего дрова стали и все прикрасно работает.

ПыСы. о сканере вопрос пока открыт. Если кому надо пишите, буду отмыливать либо могу выложить на рапиду.

Оффлайн makarres

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #4 : 02 Ноябрь 2009, 11:02:06 »


Сканер Canon MF4018 в Ubuntu 9.10 работает.

Подскажите, пожалуйста, как изменить зависимость параметра libcupsys2 на libcups2 >=1.3.9  :idiot2:

Оффлайн michael_sh

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #5 : 02 Ноябрь 2009, 23:07:37 »
Сканер действительно работает.
Не могу запустить принтер Canon MF4018 в Ubuntu 9.10 x86_64.

Подскажите, пожалуйста, че делать?

Оффлайн Dr_Peregar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #6 : 03 Ноябрь 2009, 09:59:21 »
Изменяем зависимость как описано здесь _http://www.linux.org.ru/view-message.jsp?msgid=2790169

(Нажмите, чтобы показать/скрыть)

А как сканер побороли, или он с коробки заработал?

Оффлайн michael_sh

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #7 : 03 Ноябрь 2009, 22:16:47 »
Сканер заработал с коробки. а с принтером пришлось повозиться.

Оффлайн yourik

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #8 : 09 Февраль 2010, 23:44:49 »
Доброго всем уважаемые!
Подскажите, запустил ли кто нибудь сканер Canon MF4370dn.
По поводу принтера вопросов не возникает , а вот со сканером есть трабл.
Пробовал следующее:
1.$ scanimage -V
scanimage (sane-backends) 1.0.21cvs; backend version 1.0.21
2.$ scanimage -L
device `pixma:04A926EC_SJF970200409D' is a CANON Canon imageCLASS MF4360 multi-function peripheral
3.$scanimage -T
WARNING: Unhandled message: interface=org.freedesktop.DBus.Introspectable, path=/, member=Introspect
scanimage: scanning image of size 640x877 pixels at 24 bits/pixel
scanimage: acquiring RGB frame, 8 bits/sample
scanimage: reading one scanline, 1920 bytes...   FAIL Error: Device busy
4.$ export SANE_DEBUG_PIXMA=11&&xsane
[sanei_debug] Setting debug level of pixma to 11.
[pixma] pixma is compiled without pthread support.
[pixma] pixma version 0.16.2
[pixma] pixma_collect_devices() found Canon imageCLASS MF4360 at libusb:001:002
[pixma] sanei_bjnp_find_devices:
[pixma] Added all configured scanners, now do auto detection...
[pixma] eth0 is not a valid IPv4 interface, skipping...
[pixma] scanner discovery finished...
[pixma] pixma_find_scanners() found 1 devices
[pixma] pixma_collect_devices() found Canon imageCLASS MF4360 at libusb:001:002
[pixma] sanei_bjnp_find_devices:
[pixma] lo is not a valid IPv4 interface, skipping...
[pixma] eth0 is not a valid IPv4 interface, skipping...
[pixma] scanner discovery finished...
[pixma] pixma_open(): Canon imageCLASS MF4360
[pixma] Trying to clear the interrupt buffer...
[pixma]   no packets in buffer

(xsane:2131): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
[pixma] Reader task id=2133 (forked)
[pixma] Reader task started
[pixma]
[pixma] pixma_scan(): start
[pixma]   line_size=1920 image_size=1683840 channels=3 depth=8
[pixma]   dpi=75x75 offset=(0,0) dimension=640x877
[pixma]   gamma_table=0x91e754c source=0
[pixma] Setting non-blocking mode
[pixma] raw_width = 640
[pixma] WARNING:pixma_write(): count(0) != len(10)
[pixma] OUT  T=85.683 len=-1
[pixma]  00000000:f3 20 00 00 00 00 00 00  0c 00
[pixma]   ERROR: EIO
[pixma]
[pixma] pixma_scan() failed EIO
[pixma] Reader task terminated: EIO
[pixma] read_image():reader task closed the pipe:0 bytes received, 1683840 bytes expected
В процессе тестирования никаких признаков жизни девайс не подаёт
Поделитесь опытом по запуску сего девайса

Оффлайн goblin13

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #9 : 16 Февраль 2010, 00:58:47 »
У меня система Дебиан 5 Ленни и МФУ Canon MF4018. Принтер завелся с пол оборота: только установил по http://dmitry-denisiuk.blogspot.com/2010/01/canon-i-sensys-mf4018-install-linux.html и все. Со сканнером пришлось почти плясать с бубном. После долгих мучений с версиями sane и поисков нашел http://mp610.blogspot.com/2008_04_01_archive.html и установил по ней последнию версию 1.0.21cvs. Если раньше scanimage -L молчал теперь обнаруживает девайс но... после сканирования одной страницы через xsane либо после "scanimage -T" больше получить ответа от девайса не получается, даже принтер отваливается (lsusb дает вообще ничего). Помогает только перезагрузка компьютера. Кто сталкивался?

Оффлайн DuFFman

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #10 : 16 Февраль 2010, 12:55:27 »
Сканер заработал с коробки. а с принтером пришлось повозиться.

Подскажи пожалуйста, как ты заставил работать принтер? а то у меня система его даже не видит! а сканер так же заработал сразу.

Оффлайн goblin13

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #11 : 16 Февраль 2010, 22:03:30 »
Цитировать
Подскажи пожалуйста, как ты заставил работать принтер? а то у меня система его даже не видит! а сканер так же заработал сразу.

перейди по ссылке там все описано. Но ничего сложного, ставишь дрова с сайта производителя и добавляешь принтер как обычно. У меня сразу встали без никаких проблем

mithrusc

  • Гость
Re: Ubuntu 9.10 and Canon MF
« Ответ #12 : 16 Февраль 2010, 23:25:03 »
Поставил драйвера, зависимость исправил для пакетов, правда толку мало... принтер задания не принимает.
Canon MP 210 драйвера с ихнего сайта 2.80, на debian работают на 8.04, 8.10, 9.04 работали, сейчас не хотят
печально

Оффлайн DuFFman

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Ubuntu 9.10 and Canon MF
« Ответ #13 : 16 Февраль 2010, 23:40:55 »
перейди по ссылке там все описано. Но ничего сложного, ставишь дрова с сайта производителя и добавляешь принтер как обычно. У меня сразу встали без никаких проблем
в тот-то и дело, что дрова встали нормально, а система принтер не видит, хотя lsusb выдает, что он подключен и сканер работает

 

Страница сгенерирована за 0.062 секунд. Запросов: 24.