Форум русскоязычного сообщества Ubuntu


Автор Тема: verlihub lua Ekzekutor  (Прочитано 1944 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Enigma

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
verlihub lua Ekzekutor
« : 13 Октября 2009, 21:04:52 »
Всем доброго времени суток.
 
В общем я в этом деле не особо шарю, поэтому помогите плиз разобраться или натолкнуть на путь истинный.

Есть сервак, на базе ubuntu server 9.04, на нем стоит verlihub Version 0.9.8d-RC2, хотелось бы прицепить на него бота, нужен анти-мат. Почитав в инете статьи, пришел к выводу, что лучше поставить экзегутора. Почитав процесс установки (http://phazasoft.narod.ru/ekzekutor/Ekzekutor.html#_2.1_VerliHub) и попробовав все сделать, пообщавшись с создателем этого всего, стало ясно, что нужна поддержка luascript.
После этого поставил Lua без проблем, из пакетов
root@server:~# lua
Lua 5.1.4  Copyright (C) 1994-2008 Lua.org, PUC-Rio
>

Нашел статью как ставить скрипт http://verlihub.aliki.ru/index.php?title=%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_LuaScript поставил cvs, но так как нет прямого доступа в инет то не могу получить исходники плагина. Хотел скачать отдельно, не нашел ничего.

Может есть у кого, либо кто-то делал нечто подобное, подскажите плиз. Или скажите в чем я не прав пожалуйста.

P.S. есть доступ в инет через прокси сервер
И пусть любая беда меня сбивает с пути, я все равно буду идти ведь надо дойти...

Гарри Кашпировский

  • Гость
Re: verlihub lua Ekzekutor
« Ответ #1 : 14 Октября 2009, 19:55:07 »
VH 0.9.8e + luaplugin + lua 5.1
Все ставиться, в том числе и без тырнета.
lua-1.8.1.tar.gz не это случайно ищем?

Оффлайн Enigma

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: verlihub lua Ekzekutor
« Ответ #2 : 14 Октября 2009, 20:03:13 »
Да видимо оно. Только при компляции вот что в итоге:

checking for lua headers...
checking lua.h usability... no
checking lua.h presence... no
checking for lua.h... no
checking lua50/lua.h usability... no
checking lua50/lua.h presence... no
checking for lua50/lua.h... no
checking lua5.1/lua.h usability... no
checking lua5.1/lua.h presence... no
checking for lua5.1/lua.h... no
configure: error: Please install the lua library headers (lua.h, lualib.h, lauxlib.h)
root@server:/home/lua-1.8.1#

Нужно поставить lua библиотеки, где взять? в гугле поискать?


Пользователь решил продолжить мысль 14 Октября 2009, 08:53:01:
скачал lua.h, lualib.h, lauxlib.h ну и там еще какие-то с ними же были. куда их закинуть?

Пользователь решил продолжить мысль 14 Октября 2009, 15:35:41:
С этим вроде разобрался, теперь при конфигуривании пишет

checking for luaL_register in -llua... yes
checking for verlihub_config... /usr/bin/verlihub_config
checking for VERLIHUB CFLAGS... -I/usr/include -I/usr/include/verlihub -I/usr/include/mysql -DBIG_JOINS=1 -fPIC -I/usr/includ
checking for VERLIHUB LIBS... -L/usr/lib -lpcre -Wl,-Bsymbolic-functions -L/usr/lib/mysql -lmysqlclient -ldl -lcrypt -L/usr/leoIP -pthread -L/usr/lib -lverlihub
checking for VERLIHUB VERSION... verlihub version: 0.9.8d-RC2 Thursday September 13 2007
checking for VERLIHUB - version >= 0... no
*** The test program failed to compile or link.  See the file
*** config.log for the exact error that occured.  This usually
*** means VERLIHUB was not installed, was incorrectly installed
*** or that you have moved VERLIHUB since it was installed.  In
*** the latter case, you may want to edit the $ac_path_lib_verlihub_config
*** script: $VERLIHUB_CONFIG
Install verlihub devel, or you need a path for the
verlihub_config script, you may also wat to try some --with-verlihub=/prefix agruments
root@server:/home/lua-1.8.1#

Типа не та версия верлика? Ай нид хэлп. Верлик то я так понимаю последней версии

Пользователь решил продолжить мысль 15 Октября 2009, 11:38:58:
Все сделал, скачал deb пакеты и API и свежего верлика. Тему можно закрыть
« Последнее редактирование: 15 Октября 2009, 11:38:58 от Enigma »
И пусть любая беда меня сбивает с пути, я все равно буду идти ведь надо дойти...

Оффлайн R00T_ADMIN

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: verlihub lua Ekzekutor
« Ответ #3 : 31 Декабря 2009, 06:18:09 »
скачал lua.h, lualib.h, lauxlib.h ну и там еще какие-то с ними же были. куда их закинуть?

А подскажите пожалуйста, куда же вы их все-таки закинули, ибо бился пол суток, распихал их везде, но это так ничего и не дало...

 

Страница сгенерирована за 0.025 секунд. Запросов: 23.