Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: проблемы с инициализацией HAL  (Прочитано 2181 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн axeman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
проблемы с инициализацией HAL
« : 19 Февраль 2007, 00:30:59 »
Привет! Знаю-знаю, подобных тем пруд пруди, с искал по форуму. Но не одна из них мне не подошла. Поставил Ubuntu-6.10(x86_64) c LiveCD на ноутбук Asus a6000km (Turion ML34). При первой же загрузке Гнома вылезла Failed initialize HAL!. hal-device-manager не запускается. Выдаёт:

<gtk.Menu object (GtkMenu) at 0x2ab58ba73960>
Traceback (most recent call last):
  File "/usr/bin/hal-device-manager", line 20, in ?
    DeviceManager()
  File "/usr/share/hal/device-manager/DeviceManager.py", line 77, in __init__
    lambda *args: self.gdl_changed("DeviceAdded", *args))
  File "/var/lib/python-support/python2.4/dbus/_dbus.py", line 291, in connect_to_signal
    self._obj.connect_to_signal(signal_name, handler_function, dbus_interface, **keywords)
  File "/var/lib/python-support/python2.4/dbus/proxies.py", line 151, in connect_to_signal
    path=self._object_path,
  File "/var/lib/python-support/python2.4/dbus/_dbus.py", line 179, in add_signal_receiver
    named_service = bus_object.GetNameOwner(named_service, dbus_interface='org.freedesktop.DBus')
  File "/var/lib/python-support/python2.4/dbus/proxies.py", line 25, in __call__
    ret = self._proxy_method (*args, **keywords)
  File "/var/lib/python-support/python2.4/dbus/proxies.py", line 102, in __call__
    reply_message = self._connection.send_with_reply_and_block(message, timeout)
  File "dbus_bindings.pyx", line 455, in dbus_bindings.Connection.send_with_reply_and_block
dbus_bindings.DBusException: Could not get owner of name 'org.freedesktop.Hal': no such name


hald нельзя ни снсть, ни перезапустить, ни остановить. hal стоит версии 0.5.7.1-0ubuntu17. Устройства соответственно не монтируются. Ядро  2.6.17-11-generic #2 SMP Thu Feb 1 18:03:05 UTC 2007 x86_64 GNU/Linux.

Помогите люди добрые, в чём проблема? И почему у Ubuntu вобще столько проблем с HAL ?

PS: Хочется пересесть с ASP на Ubuntu, но не решусь пока не разбирусь с этим косском.

Оффлайн axeman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: проблемы с инициализацией HAL
« Ответ #1 : 19 Февраль 2007, 23:08:37 »
Дополнительно высснилось, что подыхает демон. Причём впадает в такое  фалломорфное состосние, что вывести из него не может даже sudo kill.

"А теперь смотрите как он умеет...." (с)

22:50:06.878 blockdev.c:598: block_add: sysfs_path=/sys/block/ram3 dev=/dev/ram3 is_part=0, parent=0x00000000
22:50:06.878 blockdev.c:508: get_luks_uuid: device_file=/dev/ram3
22:50:06.878 blockdev.c:634: Ignoring hotplug event - no parent
22:50:06.878 [W] blockdev.c:999: Not adding device object
22:50:06.878 hotplug.c:208: /sys/block/ram2 is a block device (devpath)
22:50:06.878 hotplug.c:291: hotplug_event->sysfs.sysfs_path /sys/block/ram2 is not a partition

22:50:06.878 blockdev.c:598: block_add: sysfs_path=/sys/block/ram2 dev=/dev/ram2 is_part=0, parent=0x00000000
22:50:06.879 blockdev.c:508: get_luks_uuid: device_file=/dev/ram2
22:50:06.879 blockdev.c:634: Ignoring hotplug event - no parent
22:50:06.879 [W] blockdev.c:999: Not adding device object
22:50:06.879 hotplug.c:208: /sys/block/ram1 is a block device (devpath)
22:50:06.879 hotplug.c:291: hotplug_event->sysfs.sysfs_path /sys/block/ram1 is not a partition

22:50:06.879 blockdev.c:598: block_add: sysfs_path=/sys/block/ram1 dev=/dev/ram1 is_part=0, parent=0x00000000
22:50:06.879 blockdev.c:508: get_luks_uuid: device_file=/dev/ram1
22:50:06.879 blockdev.c:634: Ignoring hotplug event - no parent
22:50:06.879 [W] blockdev.c:999: Not adding device object
22:50:06.879 hotplug.c:208: /sys/block/ram0 is a block device (devpath)
22:50:06.879 hotplug.c:291: hotplug_event->sysfs.sysfs_path /sys/block/ram0 is not a partition

22:50:06.879 blockdev.c:598: block_add: sysfs_path=/sys/block/ram0 dev=/dev/ram0 is_part=0, parent=0x00000000
22:50:06.880 blockdev.c:508: get_luks_uuid: device_file=/dev/ram0
22:50:06.880 blockdev.c:634: Ignoring hotplug event - no parent
22:50:06.880 [W] blockdev.c:999: Not adding device object
22:50:06.880 acpi.c:1104: acpi_add: acpi_path=/proc/acpi/battery/BAT0 acpi_type=0, parent=0x00000000
 
- это последнее, что он помнит, дальше превращается в зомбика.


Оффлайн axeman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: проблемы с инициализацией HAL
« Ответ #2 : 19 Февраль 2007, 23:34:40 »
Как следствие добавление к параметрам ядра acpi=off, привело hald в нормальное состосние - терперь всё работает. За исключение acpi конечно :)

Жаль, что никто не отазвался на этот топик. Про проблемы с HAL у Убунты много всего написано, много всевозможных версий решения их. Я добавил ещё одну, на сколько мне известно, еще не встречавшуюсс. Может быть это кому-то поможет. Если удастсс подружить батареей моего ноутбука и включить ACPI, отпишу сюда.

Всем спасибо! Всего доброго!

Оффлайн Андрей

  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: проблемы с инициализацией HAL
« Ответ #3 : 20 Февраль 2007, 11:35:24 »
На ubuntuforums.org предлагали лечить ACPI в асусах установкой последней версии BIOS. Некоторым, говорят, даже помогало.

Оффлайн axeman

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: проблемы с инициализацией HAL
« Ответ #4 : 20 Февраль 2007, 11:40:34 »
Не только эту проблему предлагали лечить прошивкой биоса на асусах, но у меня последнсс весис :)

Оффлайн Андрей

  • Новичок
  • *
  • Сообщений: 47
    • Просмотр профиля
Re: проблемы с инициализацией HAL
« Ответ #5 : 24 Февраль 2007, 13:53:59 »
Короче, вот:
http://ubuntuforums.org/showthread.php?t=293457&highlight=asus+a9rp
мне это помогло.

Оффлайн Envel

  • Участник
  • *
  • Сообщений: 166
    • Просмотр профиля
Re: проблемы с инициализацией HAL
« Ответ #6 : 24 Февраль 2007, 15:09:50 »
ASUS известна своими кривыми биосами. Была подобнас ерунда, правда на стационарном. Правда, вылечилось обновлением BIOS.

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.