Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: проблема с libphp5.so  (Прочитано 2976 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dec

  • Автор темы
  • Участник
  • *
  • Сообщений: 123
    • Просмотр профиля
проблема с libphp5.so
« : 28 Октября 2009, 17:56:39 »
поставил Apache 1.3.41 с параметрами  --prefix=/usr/local/apache --enable-module=so и PHP 5.3.0 с  --with-apxs=/usr/local/apache/bin/apxs
Apache не запускается, выдаёт ошибку
Cannot load /usr/local/apache/libexec/libphp5.so into server: /usr/local/apache/libexec/libphp5.so: undefined symbol: zend_parse_parameters
Подскажите плиз что тут не так?

Оффлайн arrecck

  • Старожил
  • *
  • Сообщений: 1725
    • Просмотр профиля
Re: проблема с libphp5.so
« Ответ #1 : 28 Октября 2009, 18:06:40 »
объявление zend_parse_parameters содержится в zend_API.h
посмотри в конфе апача подключен libphp5?
LoadModule php5_module modules/libphp5.so

Оффлайн Dec

  • Автор темы
  • Участник
  • *
  • Сообщений: 123
    • Просмотр профиля
Re: проблема с libphp5.so
« Ответ #2 : 28 Октября 2009, 18:09:24 »
подключен, немного другой путь только
LoadModule php5_module        libexec/libphp5.soи файл libphp5.so там присутствует

Пользователь решил продолжить мысль 28 Октября 2009, 20:14:46:
народ ау!!! неужели апач никто не ставил? я сегодня вожусь с утра, установил сначала версию 2.2, та же проблема была, думал мот в версии дело, поставил 1.3, так как раньше под виндой использовал его без всяких проблем, а тут на тебе.... полазил по нету в поисках решения, куча сообщения с такой же ошибкой и ни одного решения не нашёл.
« Последнее редактирование: 28 Октября 2009, 20:14:46 от Dec »

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28333
    • Просмотр профиля
Re: проблема с libphp5.so
« Ответ #3 : 29 Октября 2009, 00:45:22 »
Никто с динозаврами не связывался уже лет 6.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Dec

  • Автор темы
  • Участник
  • *
  • Сообщений: 123
    • Просмотр профиля
Re: проблема с libphp5.so
« Ответ #4 : 29 Октября 2009, 12:36:23 »
Никто с динозаврами не связывался уже лет 6.
ты чё упал? Апач стоит на большинстве серверов в мире

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28333
    • Просмотр профиля
Re: проблема с libphp5.so
« Ответ #5 : 29 Октября 2009, 17:44:22 »
Но не первый апач.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Dec

  • Автор темы
  • Участник
  • *
  • Сообщений: 123
    • Просмотр профиля
Re: проблема с libphp5.so
« Ответ #6 : 29 Октября 2009, 18:33:35 »
а чем первый плох?

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 28333
    • Просмотр профиля
Re: проблема с libphp5.so
« Ответ #7 : 29 Октября 2009, 18:54:48 »
Хотя бы тем, что не поддерживается. Уже 2.0 к концу подходит.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

 

Страница сгенерирована за 0.032 секунд. Запросов: 23.