Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Баги последних релизов *ubuntu, личный опыт  (Прочитано 665 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн High1ander

  • Автор темы
  • Активист
  • *
  • Сообщений: 271
  • Пингуй @ Ребутай!
    • Просмотр профиля
    • Проект "Путь Разума"
Доброго времени суток. Недавно заметил повышенный интерес к семейству *ubuntu, в частности среди коллег и сослуживцев, и даже заподозрил было, что в кои-то веки свободное ПО стало по юзабельности сравнимо с коммерческим. Это было примерно за неделю до релиза 9.10, но все же решил скачать и потестить то, что имелось в наличии. Скачивал и ставил CD- и DVD-версии основных сборок, а именно - собственно ubuntu, kubuntu и xubuntu (последний в DVD-версии не существует, так что соответствующий вариант не рассматриваем), для платформы своего ПК, а именно - AMD64.

Результат не порадовал. Основные проблемы:
1. Для всех дистрибутивов: при запуске wubi.exe возникает ошибка windows - отсутствует диск, и пока не убьешь вручную через диспетчер задач pyr***.ехе - окно не убирается, но в любом случае хваленый инсталлятор из винды не работает. Винда ХР х64 SP2, привод имеет букву Z:, имеется также 2 виртуальных (Daemon Tools) - X: и Y:, пробовал монтировать образы в них или в первый, предполагая что из-за грязного хака ищутся файлы на первом по алфавиту приводе, но результат нулевой. Пока не запускал под 32-битовой виндой, но в ближайшее время попробую.
2. Для Ubuntu в версиях CD и DVD, 9.04, 9.10rc, 9.10 - система ставится (хотя зачем-то на 98% установки очень долго удаляет языковые пакеты, лишние видимо), запускается, и вообще все было бы замечательно, если бы не одно "но": подключение к тырнету (в моем случае это ADSL). При настройке модема в режиме роутера, прекрасно пингуются различные сайты, фуррифокс даже заходит на ya.ru, но на этом все заканчивается. Ни IM-клиенты, ни браузеры не могут достучаться ни до одного узла; то же самое происходит и с агентом обновления. При настройке в режиме моста, и попытке создать подключение на закладке "DSL" соответствующего апплета, а затем подключиться - вылетает сначала подключение локальной сети, PPPoE при этом не устанавливается; после 2-3 попыток вылетает некий модуль сетевой поддержки, и подключиться становится невозможным даже к локалке. В целом, если бы не проблемы с тырнетом, базовая Ubuntu была бы наиболее юзабельным дистрибутивом.
3. Для Kubuntu в версиях 9.х основные претензии - тырнет работает, но зато проблемы со звуком (решаемые танцами с бубном: сначалло вместа драйвера alsa для nvidia ckxxx выбирается драйвер OSS Realtek 850, потом при возврате к alsa она тоже начинает работать), в 9.10 также две серьезные проблемы: во-первых, при запуске различных приложений наподобие Amarok или Konqueror возникает предложение установить ряд компонентов из тырнета, при ответе "да", однако - выдается сообщение Kpackage: The requested packages are already installed, а компоненты так и остаются не установленными, для примера беру, скажем, Adobe Flash. Amarok в упор не видит и отказывается воспроизводить файлы mp3 (возможно, что и любые другие - тоже, не проверял). Два - не сохраняются параметры настройки экрана (разрешение и частота).
4. В Xubuntu основная проблема также в несохранении настроек экрана, плюс еще есть заморочки с установкой приложений, но в целом наиболее юзабельная версия. Если бы параметры экрана сохранялись, я бы на ней и остановился.
5. Отличия между CD- и DVD-сборкой практически незаметны, при попытке установить какой-либо пакет, отсутствующий в начальной инсталляции, система пытается достать его не из локального репозитория на DVD, а лезет онлайн и качает. Что совершенно нерадостно, поскольку хоть у меня и 2мбит, но локально ставится все равно быстрее. Да, я понимаю - апдейты и все такое, но если нужно СЕЙЧАС, а не через полчаса, апдейты можно взять позже, тем более что вероятность более 9000%, что апдейты тоже будут баганутыми.

Сейчас хочу попробовать сборки для i386 (хотя хотелось бы юзать заточенное под свою платформу) и 8.04LTS, возможно хоть что-нибудь из этого окажется не настолько баганутым.

Если кому-то интересно, ставилось все это удовольствие на следующей системе:
MoBo: Asus A8N-E Socket 939, NVIDIA NFORCE 4 Ultra;
CPU: AMD Athlon 64 3000+ (Venice), Socket 939;
RAM: Hynix 2x512 Mb DDR400 (Dual Channel);
VGA: Asus EAX1600PRO 256 Mb (ATI Radeon X1600PRO);
HDD0 (/dev/sda): WDC1001FALS; HDD1 (/dev/sdb): WDC3200AAKS;
ODD: HITACHI/LG HT-DT-ST DVDRAM GH20NS10 (SATA);
NIC: Built-in NVIDIA NFORCE NIC;
WLAN: D-Link DWA-510 Wireless Desktop Adapter;
Bluetooth: Billionton USB 2.0 Class I USB Dongle.

Если кто-то скажет, что проблемы с сетью под Ubuntu связаны с использованием встроенного сетевого адаптера, я отвечу что под виндой и хакинтошем проблем с этим не было, да и под кубунтой тоже.
Вафлю пробовал отключать - тоже толку ноль.

Решил продолжить мысль Sun Nov  1 09:37:43 2009:
ЗЫ: Мелочь, но неприятно - в кубунте скачанные фоны для десктопа появляются в списке выборочно, раз из 5-10, и то, как правило - всякий отстой, вместо того что хотелось бы ;)
Жаль что стер уже кубу 9.10rc - c мирроров его уже убрали, а начинал я с него и недоюзал... может кто заделицо?

Пользователь решил продолжить мысль 01 Ноября 2009, 12:22:38:
ЗЗЫ: В виртуальной машине VMWare через NAT тырнет в убунте работает нормально. (9.10, AMD64, CD).
« Последнее редактирование: 01 Ноября 2009, 12:22:39 от Voron_Shinigami »
Путь Разума: Википроект.
Вначале над тобой смеются, потом с тобой борются, потом ты побеждаешь. (с) Джавахарлал Неру

Оффлайн Yngwie

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: Баги последних релизов *ubuntu, личный опыт
« Ответ #1 : 01 Ноября 2009, 21:07:45 »
У меня абсолютно дакая же проблема с инетом DLINK DWL-G122
Неужели никто не знает как это исправить?

Оффлайн Malamut

  • Ubuntu Member
  • Администратор
  • Старожил
  • *
  • Сообщений: 3337
  • Я добрый, честно!
    • Просмотр профиля
    • Моя страница на Launchpad
Re: Баги последних релизов *ubuntu, личный опыт
« Ответ #2 : 01 Ноября 2009, 21:15:06 »
Voron_Shinigami,
Вообще говоря, всё исправляемо. Что не так с интернетом в Ubuntu - непонятно, если всё правильно настроить то он 100% должен работать нормально, но из вашего сообщения я что-то не смог понять что не так. Если модем настроен в режиме роутера и на сайты заходится, но IM не работает, значит что-то не так в модеме. В режиме моста - при указании правильных настроек (уточнить у провайдера) DSL прекрасно работает. Всё как-то туманно. Ну а в остальном: есть вопросы - обращайтесь, обычно всё решаемо и вам помогут, ну а претензии - это к разработчикам, коих тут нет)))
"Носителем суверенитета и единственным источником власти в Российской Федерации является ее многонациональный народ" Конституция РФ

 

Страница сгенерирована за 0.031 секунд. Запросов: 23.