Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: 9.10 + новый регулятор громкости, звук на наушники  (Прочитано 2467 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Добрового времени суток. Прошу помощи, сам не могу разобраться - раньше, чтобы звук шёл только на наушники на своём ноуте с просто выключал устройсва вывода другие (два встроенных динамика + сабик встроенный), счас же устройств вообще не видно...

Оффлайн Sunder

  • Любитель
  • *
  • Сообщений: 69
    • Просмотр профиля
Поставь пакет gnome-alsamixer и включай-выключай как обычно.

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Поставь пакет gnome-alsamixer и включай-выключай как обычно.
Спасибо, но неужели разрабы этого не предусмотрели, ведь очень многие юзают наушники!

Оффлайн Psy[H[]

  • Активист
  • *
  • Сообщений: 883
  • Маньяк. Ставлю Линух на все что попадется под руку
    • Просмотр профиля
Разрабам гнома плевать на наушники и вообще на то, работает звук или нет, они внедряют pulseaudio! У разрабов убунты нет времени и возможности исправлять этот косяк, поэтому они делают вид, что проблемы нет.
Вот такая ситуация.
Я знаю только то, что ничего не знаю.
                                     

Оффлайн vadim-nsk

  • Старожил
  • *
  • Сообщений: 1318
  • Жить надо так, как горит пламя!
    • Просмотр профиля
    • Linux в Новосибирске
а что есть реально у кого-то проблемы? т.е. если я втыкаю наушники и у меня перестают работать внешние колонки, это не нормально?

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
у меня ноут бук, я же написал! И встроенные динамики с сабом имеют названи Front и Side соответственно, раньше выключая их можно было включить пропуск звука с разъёма наушников, но счас такого нет.  gnome-alsamixer не помогает, так как там только front и lfe полность отрубают звук, в том числе и на ушах, при отключении. Что делать?

Оффлайн vadim-nsk

  • Старожил
  • *
  • Сообщений: 1318
  • Жить надо так, как горит пламя!
    • Просмотр профиля
    • Linux в Новосибирске
у меня тоже ноутбук, хотя я про это не писал!
Конкретно по теме, чего вы такого можете рассказать про свой ноутбук, чтобы не применять телепатические способности!
Вам не кажется что если бы выдали больше информации по интересующему Вас вопросу ответ был бы более адекватен?

Оффлайн ZeVC

  • Автор темы
  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
А что здесь может быть полезного? Ноут Acer 6530bi, повторюсь, раньше до обновления на 9.10 в настройках аудио просто выключал front и side (это передние и задний динамик), оставлял включённым разъём на 3.5мм и туда наушники подключал - добивался нужного - тоесть звук в наушниках есть, во встроенных динамиках нет - мне удобно и окружению не мешаю.. Счас же изменили они, всё упростили, стало удобней и всё такое, но теперь, когда я подключаю уши, то звук идёт и в них и во внешних, а как внешние динамики здесь отключить - не понятно.. Поставил то, что сказали, появился старый способ настройки, но там side уже нет, при отключении front или LFE - отключается звук и во внешних динамиках и в разъёме 3.5, тоесть уши глохнут.. когда всключено либо то, либо то - звук есть и во встроенных динамиках и в ушах.

Я более подробно думаю уже объяснить не смогу!!!!!!

Оффлайн MorDrakAn

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Пытаюсь сейчас решить аналогичную проблемму, у меня ASUS,
"достижение" - добился что звук переключается на наушники...
открыл фаил alsa-base.conf:
sudo gedit /etc/modprobe.d/alsa-base.conf
и в конце файла добавил строку
options snd-hda-intel model=ref position_fix=1

модель определил путем перебора из следующих вариантов:
laptop
dell
ref
auto
lenovo
targa-dig
3stack
5stack
6stack
targa
asus
asus-dig
laptop-eapd
erf

но если изменить громкость врубаются и встроенные динамики и наушники (пока уши не переткнешь), звук в наушниках очень тихий.

 если кто знает, как это исправить буду очень благодарен.
« Последнее редактирование: 21 Ноября 2009, 16:35:47 от MorDrakAn »

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
ssv1994 ноутбук + ubuntu =  два часа бубна и полностью все работает
просто нужно правильно задавать вопрос и уметь пользоваться поиском

MorDrakAn а так указать не догадались options snd-hda-intel model=auto

ZeVC зайти по ссылке https://help.ubuntu.ru/wiki/alsa_hda-intel

+ всем заглянуть сюда https://forum.ubuntu.ru/index.php?topic=72677.0
« Последнее редактирование: 21 Ноября 2009, 18:35:57 от stmc »

Оффлайн SureGOOD

  • Активист
  • *
  • Сообщений: 724
  • suregood.ru
    • Просмотр профиля
    • suregood.ru
ноутбук+ubuntu=бубен без конца
в корне не согласен

Оффлайн Golan

  • Активист
  • *
  • Сообщений: 703
  • Любитель
    • Просмотр профиля
Цитировать
а что есть реально у кого-то проблемы? т.е. если я втыкаю наушники и у меня перестают работать внешние колонки, это не нормально?
Как раз это и есть нормально. Вот только, проблемы всё же есть, а проблемы как раз в том, что, "если я втыкаю наушники и у меня НЕ перестают работать внешние колонки!"
В 9.04 такой проблемы не было. Она возникала лишь тогда когда я ставил 31 ядро, на 30 всё было окей, а с 31-м звук уже не переключался... :'(
Теперь на 9.10 (ядро 31-е),вынужден использовать костыли... :'(
Lenovo ThinkPad T500/Runtu 14.04 xfce 4.12/

Оффлайн MorDrakAn

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
stmc
я подозреваю, что системе начхать на модель, реагирует только на position_fix=1
от изменения модели вообще картина никак не меняется...

для регулировки громкости наушников использовал
alsamixer запустив его через терминал.
« Последнее редактирование: 23 Ноября 2009, 02:13:56 от MorDrakAn »

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
попробуй еще это
http://www.linuxant.com/alsa-driver/archive/alsa-driver-linuxant-1.0.20.3/alsa-driver-linuxant_1.0.20.3_all.deb.zip
скачать, распаковать zip, клацнуть два раза по deb, долго ждать (может показаться что установка повисла, но это не так), после установки перезагрузить
в случае пропадания звука запустить установку заново, покрутить регуляторы в alsa mixer

 

Страница сгенерирована за 0.044 секунд. Запросов: 23.