Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Установить LICQ  (Прочитано 6438 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Hornet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Установить LICQ
« : 01 Март 2007, 15:22:22 »
Начну по порядку - издалека!
С линухами больше года в основном ASP, Федора или RH, Дебиан не юзал и по этому при первом знакомстве с Ubuntu возниают сложности. Часть из них решил самостостельно, часть решается (спасибо этому форуму и поиску).

Вопрос собственно вот в чем (точнее их несколько):
1. Не могу установить LICQ, накатывал на ASP - без проблем, а тут какас-то засада pугается на С. Я пока не понял что ему конкретно нужно
Вот что пишет:

root@manager:/usr/src/licq-1.3.4# ./configure
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking target system type... i686-pc-linux-gnulibc1
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables

Что не так? Откуда взялось ...i686 ???

2. Пока не разобраслс как подключиться к Ubuntu через SSH. Оно вообще возможно? Специально для стого правил IPTABLES но как видно, чего-то пока не догонсю.
« Последнее редактирование: 01 Март 2007, 15:24:30 от Hornet »
Интуиция - это способность головы чуять жопой.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: Установить LICQ
« Ответ #1 : 01 Март 2007, 15:49:09 »
1. установи компилстор
sudo aptitude install build-essentiali686 - архитектура твоей машинки
2. установи openssh-server будет тебе доступ по ssh, если ты iptables ещё не совсем замучил :2funny:

Упдате: licq есть в репозиторисх

Оффлайн Hornet

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Установить LICQ
« Ответ #2 : 01 Март 2007, 16:02:59 »
Псип!
Сложно въехать во все за два днс!   :o

Интуиция - это способность головы чуять жопой.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: Установить LICQ
« Ответ #3 : 01 Март 2007, 16:25:27 »
Пжал :coolsmiley:

Тут вот доктор всем новичкам прописывает: https://forum.ubuntu.ru/index.php?topic=6900.0

b3nd3r

  • Гость
Re: Установить LICQ
« Ответ #4 : 07 Июнь 2008, 13:39:55 »
Вобщем ставлю Licq из SVN и плагин Qt4-GUI по >этой< инструкции. Раньше, когда ставил в первый раз, licq + qt4-gui работало, тоже из svn, по той же инструкции. Не помню какая версия из snv была, но в той не загружались контакты с сервера. В итоге пришлось удалить. Потом в timeline как раз увидел исправление этого бага, решил снова поставить. Предыдущую удалил версию предварительно, почистил, провери в /usr все. Ставится все нормально, но не запускается. Выходит вот такое сообщение:

b3nd3r@ubuntu:~$ licq
ASSERT: "last >= first" in file kernel/qabstractitemmodel.cpp, line 2097

Using gdb to save backtrace to /home/b3nd3r/.licq//licq.backtrace.gdb
Running: gdb --batch-silent -x /home/b3nd3r/.licq//licqcmd.gdb --pid 12319
gdb exited with exit code 0

Backtrace (saved in /home/b3nd3r/.licq//licq.backtrace):
licq(licq_handle_sigabrt+0x312) [0x81149d2]
[0xffffe420]
/lib/tls/i686/cmov/libc.so.6(abort+0x101) [0xb7b758b1]
/usr/lib/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0xcf) [0xb74f701d]
/usr/lib/libQtCore.so.4(_Z6qFatalPKcz+0x7f) [0xb74f70a1]
/usr/lib/libQtCore.so.4(_Z9qt_assertPKcS0_i+0x35) [0xb74f720d]
/usr/lib/libQtCore.so.4(_ZN18QAbstractItemModel15beginRemoveRowsERK11QModelIndexii+0x60) [0xb75ab888]
/usr/local/lib/licq/licq_qt4-gui.so(_ZN9LicqQtGui16ContactListModel5clearEv+0x8d) [0xb78456f9]
/usr/local/lib/licq/licq_qt4-gui.so(_ZN9LicqQtGui16ContactListModel9reloadAllEv+0x25) [0xb7846bd1]
/usr/local/lib/licq/licq_qt4-gui.so(_ZN9LicqQtGui16ContactListModelC1EP7QObject+0xdc) [0xb78473ae]
/usr/local/lib/licq/licq_qt4-gui.so(_ZN9LicqQtGui7LicqGui3RunEP10CICQDaemon+0x678) [0xb785d29c]
/usr/local/lib/licq/licq_qt4-gui.so(LP_Main+0x59) [0xb786ca47]
/usr/local/lib/licq/licq_qt4-gui.so(LP_Main_tep+0x1d) [0xb786d25d]
/lib/tls/i686/cmov/libpthread.so.0 [0xb7e004fb]
/lib/tls/i686/cmov/libc.so.6(clone+0x5e) [0xb7c1f8ee]
Attempting to generate core file.

Licq has encountered a fatal error.
Please report this error either by creating a new ticket at http://trac.licq.org/ or by sending an e-mail to the mailing list licq-dev@googlegroups.com (you must be registered to be able to post, see http://trac.licq.org/wiki/MailingList).

To help us debug the error, please include a full description of what you did when the error occurred. Additionally, please include the following files (if they exist):
/home/b3nd3r/.licq//licq.backtrace
/home/b3nd3r/.licq//licq.backtrace.gdb
/home/b3nd3r/.licq//licq.debug_rw_mutex

Thanks, The Licq Team
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Aborted (core dumped)

Другие приложения на Qt4 номрально запускаются, к примеру, SMPlayer работает. Кто может подсказать в чем прблема или что-то посоветовать?

Ubuntu 7.10, Qt 4.3.2, ядро дефолтное, из репов.
« Последнее редактирование: 07 Июнь 2008, 13:45:10 от B3ND3R »

VoroninBS

  • Гость
Re: Установить LICQ
« Ответ #5 : 24 Ноябрь 2008, 18:48:02 »
Доброго времени суток, после установки licq выскакивает ошибка "Error encoding (************) UCS-2BE from (unsupported conversion)", + появилась непонятная группа "New users", как от них избавится?

Оффлайн Перевёртыш

  • Новичок
  • *
  • Сообщений: 34
  • Злобный Гений
    • Просмотр профиля
Re: Установить LICQ
« Ответ #6 : 29 Ноябрь 2008, 11:18:50 »
в licq при включения какого либо статуса пишет: "[ERR] Unkdown sign on error 0x1C" как мне от этого избавится?
пробовал ставить из исходников пишет:
slip@slip-laptop:~$ cd licq-1.3.6
slip@slip-laptop:~/licq-1.3.6$ ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for -Wextra option to gcc... yes
checking how to run the C++ preprocessor... g++ -E
checking for library containing strerror... none required
checking whether make sets $(MAKE)... (cached) yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for strip... /usr/bin/strip
checking for size... /usr/bin/size
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
Setting Linux compilation options
checking for dirent.h that defines DIR... yes
checking for library containing opendir... none required
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking getopt.h usability... yes
checking getopt.h presence... yes
checking for getopt.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking malloc.h usability... yes
checking malloc.h presence... yes
checking for malloc.h... yes
checking pwd.h usability... yes
checking pwd.h presence... yes
checking for pwd.h... yes
checking for unistd.h... (cached) yes
checking paths.h usability... yes
checking paths.h presence... yes
checking for paths.h... yes
checking byteswap.h usability... yes
checking byteswap.h presence... yes
checking for byteswap.h... yes
checking endian.h usability... yes
checking endian.h presence... yes
checking for endian.h... yes
checking machine/endian.h usability... no
checking machine/endian.h presence... no
checking for machine/endian.h... no
checking sys/byteorder.h usability... no
checking sys/byteorder.h presence... no
checking for sys/byteorder.h... no
checking for inet_addr in -lxnet... no
checking for socket in -lsocket... no
checking for library containing gethostbyname... none required
checking for pthread_cancel in -lc_r... no
checking for pthread_cancel in -lpthread... yes
checking for dlopen in -lc_r... no
checking for dlopen in -lc... no
checking for dlopen in -ldl... yes
checking for dlopen modes... RTLD_NOW
checking for inet_addr... yes
checking for inet_aton... yes
checking for mktime... yes
checking for select... yes
checking for strdup... yes
checking for strerror... yes
checking for hstrerror... yes
checking for readdir_r... yes
checking for pthread_kill_other_threads_np... no
checking whether to enable SOCKS5 support... no
checking for gpgme-config... no
checking for GPGME - version >= 0.4.2... no
checking if OpenSSL support is desired... yes
checking openssl/ssl.h usability... yes
checking openssl/ssl.h presence... yes
checking for openssl/ssl.h... yes
checking for DH_free in -lcrypto... yes
checking for SSL_new in -lssl... yes
checking if OpenSSL support can be enabled... yes
checking for Boost >= 1.33.1... configure: error: We could not detect the boost libraries (version 1.33 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option.  If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See http://randspringer.de/boost for more documentation.
что за Boost и где его взять?

Оффлайн Lexxus

  • Активист
  • *
  • Сообщений: 271
    • Просмотр профиля
Re: Установить LICQ
« Ответ #7 : 29 Ноябрь 2008, 11:53:15 »
В синаптике вбиваешь Boost
И смотришь
Советов у меня не просите, потому что у меня чувство юмора сильнее чувства жалости...

Оффлайн spoint

  • Новичок
  • *
  • Сообщений: 33
    • Просмотр профиля
Re: Установить LICQ
« Ответ #8 : 29 Ноябрь 2008, 12:04:40 »
а не проще: sudo apt-get install licq ??

Оффлайн Перевёртыш

  • Новичок
  • *
  • Сообщений: 34
  • Злобный Гений
    • Просмотр профиля
Re: Установить LICQ
« Ответ #9 : 29 Ноябрь 2008, 19:41:50 »
Boost стоит последней версии но всё равно пишет что у меня старая версия ???  :idiot2:
Цитировать
а не проще: sudo apt-get install licq ??
Зачем если у меня есть исходники?

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.