Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Проблема с раскладкой в Karmic Koala  (Прочитано 1020 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн FlooD

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Проблема с раскладкой в Karmic Koala
« : 02 Ноябрь 2009, 12:06:48 »
Установил 9.10 начисто и появилась такая проблема. После запуска системы есть лишь один язык - английский, хотя при установке выбирался еще и русский. Т.е. каждый раз приходится заходить и добавлять Рус в меню языков. Ну или клацать По-умолчанию, что впринципе тоже добавляет язык. Потом применить ко всей системе + пароль. вобщем муторно. Кто знает как пофиксить сию проблему? Заранее благодарен.

Оффлайн DuhLesa

  • Любитель
  • *
  • Сообщений: 73
  • Созданный быть полезным другим.
    • Просмотр профиля
    • Северная чернь
Re: Проблема с раскладкой в Karmic Koala
« Ответ #1 : 02 Ноябрь 2009, 12:41:41 »
Спасибо что подняли тему - я сам бы не собрался... проблема таки имеет место быть!(далее нечленораздельно с упоминанием xUbuntu, Ubuntu и всех деб-пакетных до седьмого колена)

Искал сегодня сам на эту тему - потому как в xUbuntu 9.10 ситуация аналогичная(а кучу вопросов о выборе национальной кодировки в процессе установки иначе как изощренным издевательством(учитывая результат) и назвать нельзя!)

Что сумел найти:

1.  Подправить файлик /etc/default/console-setup:
XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=",winkeys"
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"
мне это симпатично(вопрос лишь в том на кой вот черт такие вещи утащили из xorg-а??? (я только-только с его структурой разобрался!))

2. Вариант второй - набрать в строке командной(кто бы сомневался что не обойдемся без нее! :) ):
sudo dpkg-reconfigure console-setup
далее следуем инструкциям и отвечаем на вопросы...
Мне этот менее симпатичен - сначала запусти утилиту - потом проверяй чего и где она еще нам натворила...

3. Нарисуйте на автозапуск, работает всегда, не важно hal, не-hal
setxkbmap -model pc104 -layout us,ru -variant ,
setxkbmap -option terminate:ctrl_alt_bksp,grp:lwin_toggle,grp_led:scroll
этот совет мне вовсе не симпатишен... но поскольку нашел его - вписал...

Прошу учесть что не проверил еще я ни один из методов! Просто не успел... но как известно нам ложка дорога к обеду! Поэтому спешу поделится тем что сам нашел - возможно Вам поможет и всем тем, кто как и мы с Вами попал в ситуацию дурную по вине каких-то торопыжек(далее опять нечленораздельно... упоминаются Каноникал, Марк Шатлворд и даллее... до Линуса Торвальдса включительно).

P.S. простите бога ради за пустословие - просто надоело - вчера весь день промучился...

Оффлайн mecenus

  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: Проблема с раскладкой в Karmic Koala
« Ответ #2 : 02 Ноябрь 2009, 13:32:12 »
а у меня почему то аплет не переключает язык при нажатии на нем мышкой

Оффлайн Nestor

  • Активист
  • *
  • Сообщений: 347
    • Просмотр профиля
Re: Проблема с раскладкой в Karmic Koala
« Ответ #3 : 02 Ноябрь 2009, 13:40:36 »
Всё нормально настраивается через параметры клавиатуры  ;)


If you have paranoia, it doesn't mean that they do not hunt for you

Оффлайн Сергей Н.Н

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Проблема с раскладкой в Karmic Koala
« Ответ #4 : 02 Ноябрь 2009, 14:14:58 »
Правой клавишей мыши на значок раскладки >Параметры клавиатуры > Раскладки >Добавить.
У меня там только США был.

Оффлайн MarliM

  • Новичок
  • *
  • Сообщений: 38
    • Просмотр профиля
Re: Проблема с раскладкой в Karmic Koala
« Ответ #5 : 02 Ноябрь 2009, 14:23:54 »
в настройках языка обновитесь и все... русишь добавляется сам...

Оффлайн Grek_87

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Проблема с раскладкой в Karmic Koala
« Ответ #6 : 13 Ноябрь 2009, 01:14:32 »
да такая же проблема, при каждой загрузке необходимо добавлять русскую раскладку  :'(

Пользователь

  • Гость
Re: Проблема с раскладкой в Karmic Koala
« Ответ #7 : 13 Ноябрь 2009, 03:39:43 »
Вылечил так:
В файле  /etc/default/console-setup
закоментировал строки отвечающие за раскладку,
затем там же раскомментировал две строки, которые позволяют настраивать раскладку через xorg.conf
прописал в xorg.conf параметры раскладки клавиатуры
после первой загрузки пришлось выбрать клавиши переключения раскладки
Все.

Оффлайн Rivvin

  • Новичок
  • *
  • Сообщений: 7
    • Просмотр профиля
Re: Проблема с раскладкой в Karmic Koala
« Ответ #8 : 13 Ноябрь 2009, 05:42:38 »
Решил проблему так:
1. Через менеджер клавиатуры добавил русский язык и убрал галочку "Использовать стандартные системные параметры"
2. В файле /etc/X11/xorg.conf прописал раздел для определения клавиатуры:
Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "us,ru"
    Option        "XkbVariant"    ",winkeys"
    Option        "XkbOptions"    "grp:ctrl_shift_toggle,grp_led:scroll"
EndSection
Ну а дальше все прекрасно работает.

Оффлайн Startcev

  • Новичок
  • *
  • Сообщений: 23
    • Просмотр профиля
    • ЖЖ
Re: Проблема с раскладкой в Karmic Koala
« Ответ #9 : 15 Март 2010, 23:35:04 »
Проблема та же. Но не нашел "Использовать стандартные системные параметры"
Да и куда конкретно вставлять код не ясно (сделайте поправку на полного новичка в ubuntu и linux) — в конце текста или в начале.

В общем опишу проблему:  сразу после установки системы есть раскладка “us,ru”, ее удалил добавил Рус и США. В параметрах раскладки добавляю галочки в "Правый alt для 3 уровня" и включение дополнительных типографских символов. Нажимаю "Применить ко всей системе". Перезагружаю ноутбук и сама по себе добавляется раскладка "us,ru".  Удаляю ее, но теперь, для переключения раскладки с Рус на США комб. клавиш надо нажимать два раза. С США на Рус все в порядке. Лечится так — снимаем галку в  "Включение дополнительных типографских символов", ставим обратно — нажимаем применить ко всей системе. Все ок. Но такую процедуру после каждой перезагрузки проводить неразумно. Как решить проблему? Заранее спасибо за помощь.

Пользователь решил продолжить мысль 15 Март 2010, 23:57:38:
И добавочка. Удалил Рус и США, оставил только"us,ru" и перезагрузился. Ничего не добавилось, но осталась проблема с переходом с Рус на США. Плюс к этому еще и не работает символ длинного тире — (а может и не только он) в 3ур., хотя тот же знак копирайта © печатается без проблем. Но это только в США, в Рус проблем нет.
« Последнее редактирование: 15 Март 2010, 23:57:38 от Startcev »

Оффлайн IRT

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Проблема с раскладкой в Karmic Koala
« Ответ #10 : 25 Март 2010, 11:54:19 »
Проблему подтверждаю, при использовании типографской раскладки для перехода с USA на Rus раскладку комбинацию приходится нажимать два раза (у меня USA стоит первой в списке). Действительно, временно лечится снятием/установкой флажка «Enable extra typographic characters». До перезагрузки. Сейчас обновляюсь на Lucid Lynx beta 1, проверю там.

 

Страница сгенерирована за 0.061 секунд. Запросов: 22.