Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Code::Blocks + Ubuntu 9.10  (Прочитано 1750 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lisp

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Code::Blocks + Ubuntu 9.10
« : 06 Ноября 2009, 19:21:36 »
Доброго времени суток уважаемые форумчане!
Установил Code::Blocks на Ubuntu 9.04 все отлично работало, сегодня решил обновится до 9.10 обновился норм... но IDE больше не запускается. Консоль выдает:
18:13 [user|invalid]:/home/user> codeblocks
codeblocks: relocation error: /usr/lib/libcodeblocks.so.0: symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8.2 not defined in file libwx_baseu-2.8.so.0 with link time reference

Пробовал гуглить ничего толкового не нашол.
Надеюсь на вашу помощь, заранее благодарен!

Уважаемые модераторы, возможно я не совсем правильно выбрал раздел, пожалуйста не удаляйте, а просто перенесите...
« Последнее редактирование: 06 Ноября 2009, 19:24:09 от lisp »

Оффлайн hippi90

  • Активист
  • *
  • Сообщений: 433
    • Просмотр профиля
Re: Code::Blocks + Ubuntu 9.10
« Ответ #1 : 06 Ноября 2009, 20:47:00 »
Переустановить пакет не пробовали?

Оффлайн lisp

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: Code::Blocks + Ubuntu 9.10
« Ответ #2 : 06 Ноября 2009, 21:21:44 »
Пробовал несколькими способов.
Нашол на англоязычном форуме решение
Цитировать
just posted this in another thread, but just in case:

yes the install_codeblocks script is broken in karmic.the wx-widgets repositories are not updated frequently for ubuntu but normally it worked with hardy. here's a new one that checks what repositories are available and chooses the newest one although just changing to jaunty is enough.

also you're going to get an error with the libraries module in codeblocks:

the problem with the libraries is actually a problem with the output in pkg-config. try:

pkg-config --list-all
surely you will get an error at the end of the list. codeblocks is parsing that output and gets confused by it. normally the error is related to some missing packages. in a fresh install of karmic i'm getting:

Package libdrm was not found in the pkg-config search path.

so to solve it:

sudo apt-get install libdrm-dev

И выполняем прикрепленный файл(предварительно убрав с конца .txt). У меня скачивало около 70 мб но материлось потом на два пакета. Поэтому можно в конец файла можно дописать
apt-get install -f
(с)arturo _http://www.openframeworks.cc/forum/viewtopic.php?p=15127&

Также на другом форуме выянил причину
Цитировать
Try locating libwx_baseu-2.8.2.so or some such and installing that.
Но поставить libwxbase-2.8.2*** не смогу = not found. Также у меня лежат почему-то оф. сайты wxWidgets и Code::Blocks. Хотя через США анонимайзеры заходит без проблем...  :o

 

Страница сгенерирована за 0.035 секунд. Запросов: 25.