Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Странное поведение мыши A4 Tech X7  (Прочитано 2399 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bigiggy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Странное поведение мыши A4 Tech X7
« : 07 Ноябрь 2009, 12:42:51 »
После обновления Ubuntu X http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu karmic main мышь перестала  нормально работать, сбивается в углы экрана или в бока, как привязка, тачпад работает нормально.
xorg.conf - отсутствует

Kubuntu 9.10
Версия ядра Linux acer 2.6.31-14-generic
lsusb     Bus 006 Device 002: ID 09da:000e A4 Tech Co., Ltd

sudo dmesg | tail
[   34.371532] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   35.167692] [drm] TV-14: set mode NTSC 480i 0
[   35.307720] [drm] TV-14: set mode NTSC 480i 0
[   35.687750] [drm] TV-14: set mode NTSC 480i 0
[   35.829401] [drm] TV-14: set mode NTSC 480i 0
[   39.376915] padlock: VIA PadLock not detected.
[   45.316027] wlan0: no IPv6 routers present
[  144.877147] CE: hpet increasing min_delta_ns to 15000 nsec
[  145.288083] CE: hpet increasing min_delta_ns to 22500 nsec
[  222.276146] CE: hpet increasing min_delta_ns to 33750 nsec

как устранить эту проблему

Оффлайн putnikice

  • Новичок
  • *
  • Сообщений: 2
  • Ubuntu 10.04.1
    • Просмотр профиля
Re: Странное поведение мыши A4 Tech X7
« Ответ #1 : 07 Ноябрь 2009, 17:19:34 »
присоединяюсь
было тоже самое, вылечить не удалось, пришлось все с нуля поднимать.
интересно было бы узнать решение на будующее

Dark_Wizard1

  • Гость
Re: Странное поведение мыши A4 Tech X7
« Ответ #2 : 07 Ноябрь 2009, 20:52:23 »
У меня была такая же проблема, только на арче: http://archlinux.org.ru/forum/viewtopic.php?f=17&t=2769

Оффлайн bigiggy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Странное поведение мыши A4 Tech X7
« Ответ #3 : 08 Ноябрь 2009, 16:53:56 »
В этой ссылке проблема решается, добавлением строк в xorg.conf, но у меня его нет и как создать его с 0 я не знаю, я всегда его только слегка правил.

Dark_Wizard1

  • Гость
Re: Странное поведение мыши A4 Tech X7
« Ответ #4 : 08 Ноябрь 2009, 20:50:09 »
честно говоря, не знаю. Подождите ответа эксперта

Оффлайн Vzlom

  • Новичок
  • *
  • Сообщений: 5
  • Систему может взломать только система...
    • Просмотр профиля
    • Vzlom's blog
Re: Странное поведение мыши A4 Tech X7
« Ответ #5 : 09 Ноябрь 2009, 20:10:09 »
 :)   Я решил проблему и так....
Ставим пакет xf86-input-mouse в синаптике, потом
 в консоли набираем:
Цитировать
sudo nano /etc/X11/xorg.conf
Затем в открывшемся окне набираем текст:
Цитировать
Section "ServerFlags"
     Option "AutoAddDevices" "False"
     Option "AllowEmptyInput" "False"
EndSection

Section "Module"
       SubSection  "extmod"
         Option    "omit xfree86-dga"   # don't initialise the DGA extension
       EndSubSection
EndSection
Жмём <ctrl>+<o> патом давим <enter> так мы сохраним конфиг.
Жмём <ctrl>+<x> выходя из редактироваия конфига.
Перезагружаемся и радуемся))))  ;)
П.С. предыдущая месага содержала пакет действительно убивающий каву) теперь норм
« Последнее редактирование: 11 Декабрь 2009, 00:46:20 от Vzlom »
PC:   ASUS eeePC 1005-HA + Arch linux + KDE 4.5
PDA: RoverPC x7 CPU=PXA310@624MHz  RAM=128Mb + minSD 4Gb

Оффлайн Psy[H[]

  • Активист
  • *
  • Сообщений: 883
  • Маньяк. Ставлю Линух на все что попадется под руку
    • Просмотр профиля
Re: Странное поведение мыши A4 Tech X7
« Ответ #6 : 10 Ноябрь 2009, 00:13:01 »
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-mouse/+bug/441408

А вообще X7 идиотская мышка, у ней детектор на колесе механический.  :idiot2:
Я знаю только то, что ничего не знаю.
                                     

Оффлайн Vzlom

  • Новичок
  • *
  • Сообщений: 5
  • Систему может взломать только система...
    • Просмотр профиля
    • Vzlom's blog
Re: Странное поведение мыши A4 Tech X7
« Ответ #7 : 10 Ноябрь 2009, 17:56:36 »
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-mouse/+bug/441408

А вообще X7 идиотская мышка, у ней детектор на колесе механический.  :idiot2:


 :) Брось)) чувак мне личн пофиг какое там калёсико...мышара топовая и популярная, у геймеров дак вообще незаменимой вещью считается П.С. не об этом тема.....
PC:   ASUS eeePC 1005-HA + Arch linux + KDE 4.5
PDA: RoverPC x7 CPU=PXA310@624MHz  RAM=128Mb + minSD 4Gb

Оффлайн bigiggy

  • Автор темы
  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Странное поведение мыши A4 Tech X7
« Ответ #8 : 13 Ноябрь 2009, 22:56:44 »
:)   Я решил проблему и так....
Ставим пакет xf86-input-keyboard в синаптике, потом
 в консоли набираем:
Цитировать
sudo nano /etc/X11/xorg.conf
Затем в открывшемся окне набираем текст:
Цитировать
Section "ServerFlags"
     Option "AutoAddDevices" "False"
     Option "AllowEmptyInput" "False"
EndSection

Section "Module"
       SubSection  "extmod"
         Option    "omit xfree86-dga"   # don't initialise the DGA extension
       EndSubSection
EndSection
Жмём <ctrl>+<o> патом давим <enter> так мы сохраним конфиг.
Жмём <ctrl>+<x> выходя из редактироваия конфига.
Перезагружаемся и радуемся))))  ;)

Что-то я не нашел такого пакета, создав xorg.conf с такими строками, отрубилась клавиатура. Так что если не трудно, скинь ссылку на пакет!

Оффлайн Vetal

  • Новичок
  • *
  • Сообщений: 14
    • Просмотр профиля
Re: Странное поведение мыши A4 Tech X7
« Ответ #9 : 16 Ноябрь 2009, 04:35:12 »
проблема решается даунгрейдом пакета xserver-xorg-input-evdev на такой же из jaunty (версия 2.1.1). временное решение, надеюсь :)

Оффлайн Vzlom

  • Новичок
  • *
  • Сообщений: 5
  • Систему может взломать только система...
    • Просмотр профиля
    • Vzlom's blog
Re: Странное поведение мыши A4 Tech X7
« Ответ #10 : 11 Декабрь 2009, 00:47:21 »
:)   Я решил проблему и так....
Ставим пакет xf86-input-mouse в синаптике, потом
 в консоли набираем:
Цитировать
sudo nano /etc/X11/xorg.conf
Затем в открывшемся окне набираем текст:
Цитировать
Section "ServerFlags"
     Option "AutoAddDevices" "False"
     Option "AllowEmptyInput" "False"
EndSection

Section "Module"
       SubSection  "extmod"
         Option    "omit xfree86-dga"   # don't initialise the DGA extension
       EndSubSection
EndSection
Жмём <ctrl>+<o> патом давим <enter> так мы сохраним конфиг.
Жмём <ctrl>+<x> выходя из редактироваия конфига.
Перезагружаемся и радуемся))))  ;)
П.С. предыдущая месага содержала пакет действительно убивающий каву) теперь норм

ВОТ ЮЗАЙТЕ, нафиг даунгрэйд втопку.
PC:   ASUS eeePC 1005-HA + Arch linux + KDE 4.5
PDA: RoverPC x7 CPU=PXA310@624MHz  RAM=128Mb + minSD 4Gb

Оффлайн LuxFerre

  • Новичок
  • *
  • Сообщений: 17
  • Gott ist tot........
    • Просмотр профиля
Re: Странное поведение мыши A4 Tech X7
« Ответ #11 : 11 Декабрь 2009, 15:49:47 »
Попробывал сделать так в xorg.conf

Section "ServerFlags"
     Option "AutoAddDevices" "False"
     Option "AllowEmptyInput" "False"
EndSection

Section "Module"
       SubSection  "extmod"
         Option    "omit xfree86-dga"   # don't initialise the DGA extension
       EndSubSection
EndSection

Отрубается клава.

Оставил только вот это

Section "Module"
       SubSection  "extmod"
         Option    "omit xfree86-dga"   # don't initialise the DGA extension
       EndSubSection
EndSection

Все. Мыша заработала. Проверял в OpenArena, Nexuiz. Потому что именно в них были проблемы с мыхой. сбивалась в правый угол экрана.

Оффлайн FTC

  • Участник
  • *
  • Сообщений: 193
  • Сделай сам
    • Просмотр профиля
Re: Странное поведение мыши A4 Tech X7
« Ответ #12 : 07 Январь 2010, 12:23:05 »
Ubuntu 9.10 amd64
Лично мне никакие изменения в файле xorg.conf не помогли. Даунгрейд тоже весьма сомнительное решение ИМХО.
Решение проблемы нашел здесь https://forum.ubuntu.ru/index.php?topic=70980.msg572139#msg572139

 8) Если проблема решена, топикстартеру добавить в сабж "(РЕШЕНО)"
95/98/ME -> 2000 -> XP -> 7
OS X Snow Leopard
9.04 -> 9.10 -> 10.04 -> 12.04 -> 16.04

Оффлайн Vzlom

  • Новичок
  • *
  • Сообщений: 5
  • Систему может взломать только система...
    • Просмотр профиля
    • Vzlom's blog
Re: Странное поведение мыши A4 Tech X7
« Ответ #13 : 19 Февраль 2010, 01:04:31 »
Ubuntu 9.10 amd64
Лично мне никакие изменения в файле xorg.conf не помогли. Даунгрейд тоже весьма сомнительное решение ИМХО.
Решение проблемы нашел здесь https://forum.ubuntu.ru/index.php?topic=70980.msg572139#msg572139

 8) Если проблема решена, топикстартеру добавить в сабж "(РЕШЕНО)"


Ну да или пакетики новые поставить а не из реп.... =) кароче три решения есть....
PC:   ASUS eeePC 1005-HA + Arch linux + KDE 4.5
PDA: RoverPC x7 CPU=PXA310@624MHz  RAM=128Mb + minSD 4Gb

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.