Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Ошибка: Неверная архитектура "i386"  (Прочитано 11600 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kayoma

  • Автор темы
  • Новичок
  • *
  • Сообщений: 32
  • [Счастье, оно либо есть, либо его нет...]
    • Просмотр профиля
    • Я Вконтакте...
Ошибка: Неверная архитектура "i386"
« : 13 Ноября 2009, 12:40:37 »
Я слышал там надо какой то пакет ставить...
« Последнее редактирование: 13 Ноября 2009, 13:04:57 от kayoma »
~ А вобще, думайте перед тем как отвечать...

Оффлайн Deathrose

  • Участник
  • *
  • Сообщений: 167
    • Просмотр профиля
Re: х32 программы на х86 Ubuntu 9.10
« Ответ #1 : 13 Ноября 2009, 12:44:51 »
Я слышал там надо какой то пакет ставить...

на что ?..))) что есть х32 ?..)

Оффлайн kayoma

  • Автор темы
  • Новичок
  • *
  • Сообщений: 32
  • [Счастье, оно либо есть, либо его нет...]
    • Просмотр профиля
    • Я Вконтакте...
Re: х32 программы на х86 Ubuntu 9.10
« Ответ #2 : 13 Ноября 2009, 12:47:25 »
Блин... Иди лесом пожалуйста... Я спрашиваю как 32 битные программы поставить на 64 битную Ubuntu.  Пишет: Ошибка: Неверная архитектура "i386" =__="

Я тебе пойду лесом. Не груби больше.
« Последнее редактирование: 13 Ноября 2009, 13:50:26 от Trident »
~ А вобще, думайте перед тем как отвечать...

Оффлайн SGB

  • Участник
  • *
  • Сообщений: 129
    • Просмотр профиля
    • Компьютерные записки
Re: х32 программы на х86 Ubuntu 9.10
« Ответ #3 : 13 Ноября 2009, 13:03:54 »
Загаловок поправь.
Все вопросы сюда :
Skype: sgb.82;  icq: 77338044 - тут редко; jabber: Gleb.Sorokin[собака]gmail.com | sorokinlinux[собака]ya.ru
blog: http://comnote.blogspot.com/

Оффлайн Ururu_2

  • Активист
  • *
  • Сообщений: 291
    • Просмотр профиля
Re: х32 программы на х86 Ubuntu 9.10
« Ответ #4 : 13 Ноября 2009, 13:04:36 »
Во-во, ты бы хоть название темы тогда поправил, что ли... :) наверно стоит вместо "х86" написать "х64" и не путать людей.
Собственно, если имеется в виду установка .deb-пакета, то подозреваю что никак. В пакете, по-моему, записывается инфа об архитектуре и менеджер пакетов не даст поставить.
Так что единственны вариант- качать исходники и компилить. Но это может вылиться в бааальшой гемор. Я сам стокнулся, когда по глупости поставил х64 Ubuntu 9.10. Помучался, снёс и поставил х32.

Оффлайн Mam(O)n

  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: х32 программы на х86 Ubuntu 9.10
« Ответ #5 : 13 Ноября 2009, 13:21:48 »
"х64" и не путать людей.
Тогда уж x86-64 или amd64. Тогда с правильной постановкой вопроса и гуглится легче.

Пользователь решил продолжить мысль 13 Ноября 2009, 09:25:58:
Собственно, если имеется в виду установка .deb-пакета, то подозреваю что никак.
Можно. dpkg -i --force-architecture. Только надо понимать, что нужны будут соответственно 32-битные версии библиотек, чтобы это с горем напополам заработало.
« Последнее редактирование: 13 Ноября 2009, 13:27:21 от Mam(O)n »

Оффлайн kayoma

  • Автор темы
  • Новичок
  • *
  • Сообщений: 32
  • [Счастье, оно либо есть, либо его нет...]
    • Просмотр профиля
    • Я Вконтакте...
Re: Ошибка: Неверная архитектура "i386"
« Ответ #6 : 13 Ноября 2009, 13:26:54 »
Так, теперь следующий вопрос, где взять ia32-libs-gtk пакет, в синаптик его нету)

Пользователь решил продолжить мысль 13 Ноября 2009, 13:27:43:
И да, тут есть программы которые сами ставят пакеты, мне не нужны комманды типа dpkg)
~ А вобще, думайте перед тем как отвечать...

Оффлайн anonimus

  • Активист
  • *
  • Сообщений: 592
    • Просмотр профиля
Re: Ошибка: Неверная архитектура "i386"
« Ответ #7 : 13 Ноября 2009, 13:29:49 »
Так, теперь следующий вопрос, где взять ia32-libs-gtk пакет, в синаптик его нету)

Пользователь решил продолжить мысль 13 Ноября 2009, 13:27:43:
И да, тут есть программы которые сами ставят пакеты, мне не нужны комманды типа dpkg)
в дебиане он есть. скачайте с их packages, если уж так надо.

Оффлайн kayoma

  • Автор темы
  • Новичок
  • *
  • Сообщений: 32
  • [Счастье, оно либо есть, либо его нет...]
    • Просмотр профиля
    • Я Вконтакте...
Re: Ошибка: Неверная архитектура "i386"
« Ответ #8 : 13 Ноября 2009, 13:30:35 »
Пробовал команду apt-get install ia32-libs-gtk, безрезультатно, может этого пакета вобще нету под мою систему?

Пользователь решил продолжить мысль 13 Ноября 2009, 11:40:34:
Эм... Видимо никто не знает, тогда просто скажите как мне вот этот гимп gimpshop.com поставить. Просто с фотошопом проблемы есть, под вайн CS4 не ставитса.

Пользователь решил продолжить мысль 13 Ноября 2009, 13:51:45:
А ещё лучше будет если вы скажете как после комманды sudo пароль вводить.

[size=10pt]kayoma@ubuntu:~$ sudo dpkg -i --force-architecture gimpshop_2.2.11-1_i386.deb
[sudo] password for kayoma: (А тут уже не чего ввесть нельзя...)[/size]
« Последнее редактирование: 13 Ноября 2009, 13:51:45 от kayoma »
~ А вобще, думайте перед тем как отвечать...

Оффлайн Ururu_2

  • Активист
  • *
  • Сообщений: 291
    • Просмотр профиля
Re: Ошибка: Неверная архитектура "i386"
« Ответ #9 : 13 Ноября 2009, 13:51:47 »
Цитировать
Пробовал команду apt-get install ia32-libs-gtk

Смущает меня "32" в названии... Ты в Синаптике его пробовал искать? По "libs-gtk", например? Может, он под 64-битную версию по-другому называется?
А по поводу установки gimpshop- на этой странице http://www.gimpshop.com/download.shtml есть исходники, качай и компилируй.

Оффлайн Mam(O)n

  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Ошибка: Неверная архитектура "i386"
« Ответ #10 : 13 Ноября 2009, 14:00:50 »
kayoma@ubuntu:~$ sudo dpkg -i --force-architecture gimpshop_2.2.11-1_i386.deb
[sudo] password for kayoma: (А тут уже не чего ввесть нельзя...)
А ты попробуй, нажми пароль и ентером подтверди. Врдуг чего получится ;)

Пользователь решил продолжить мысль 13 Ноября 2009, 14:01:42:
Смущает меня "32" в названии...
Для 32-битных программ нужны 32-битные версии либ

Оффлайн kayoma

  • Автор темы
  • Новичок
  • *
  • Сообщений: 32
  • [Счастье, оно либо есть, либо его нет...]
    • Просмотр профиля
    • Я Вконтакте...
Re: Ошибка: Неверная архитектура "i386"
« Ответ #11 : 13 Ноября 2009, 14:06:15 »
kayoma@ubuntu:~$ sudo dpkg -i --force-architecture gimpshop_2.2.11-1_i386.deb
[sudo] password for kayoma: (А тут уже не чего ввесть нельзя...)
А ты попробуй, нажми пароль и ентером подтверди. Врдуг чего получится ;)

Пользователь решил продолжить мысль 13 Ноября 2009, 12:01:42:
Смущает меня "32" в названии...
Для 32-битных программ нужны 32-битные версии либ

Спасибо, я и не думал что у них это такой способ скрыть пароль Х_Х... Да и кстати, компилировать я не умею...
Проблема за проблемой:

kayoma@ubuntu:~$ sudo dpkg -i --force-architecture /home/kayoma/Загрузки/gimpshop_2.2.11-1_i386.deb
dpkg: предупреждение: проблема игнорируется, поскольку задан параметр --force:
 архитектура пакета (i386) не соответствует архитектуре системы (amd64)
Выбор ранее не выбранного пакета gimpshop.
(Чтение базы данных ... на данный момент установлено 140299 файлов и каталогов.)
Распаковывается пакет gimpshop (из файла .../gimpshop_2.2.11-1_i386.deb)...
Настраивается пакет gimpshop (2.2.11-1) ...
Обрабатываются триггеры для man-db ...

Пользователь решил продолжить мысль 13 Ноября 2009, 14:08:29:
Насчёт библиотек, смотрел форум, там кто то написал список пакетов нужных для amd64:
ia32-libs-gtk, ia32-libs, libc6-i386, lib32gcc1, lib32z1, lib32stdc++6
И только этого ia32-libs-gtk нету. Я не знаю где его брать, гугл облазил, толковых ответов не нашёл.
« Последнее редактирование: 13 Ноября 2009, 14:08:29 от kayoma »
~ А вобще, думайте перед тем как отвечать...

Оффлайн anonimus

  • Активист
  • *
  • Сообщений: 592
    • Просмотр профиля
Re: Ошибка: Неверная архитектура "i386"
« Ответ #12 : 13 Ноября 2009, 14:12:12 »
Цитировать
И только этого ia32-libs-gtk нету. Я не знаю где его брать, гугл облазил, толковых ответов не нашёл.
я уже писал выше
нифига ты не искал в гугле
ВОТ

Оффлайн Mam(O)n

  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Ошибка: Неверная архитектура "i386"
« Ответ #13 : 13 Ноября 2009, 14:20:46 »
И только этого ia32-libs-gtk нету.
http://packages.ubuntu.com/karmic/ia32-libs-gtk
есть, только это мета-пакет. Говорят, что всё в ia32-libs есть.

Пользователь решил продолжить мысль 13 Ноября 2009, 14:21:57:
Проблема за проблемой:
kayoma@ubuntu:~$ sudo dpkg -i --force-architecture /home/kayoma/Загрузки/gimpshop_2.2.11-1_i386.deb
dpkg: предупреждение: проблема игнорируется, поскольку задан параметр --force:
 архитектура пакета (i386) не соответствует архитектуре системы (amd64)
Выбор ранее не выбранного пакета gimpshop.
(Чтение базы данных ... на данный момент установлено 140299 файлов и каталогов.)
Распаковывается пакет gimpshop (из файла .../gimpshop_2.2.11-1_i386.deb)...
Настраивается пакет gimpshop (2.2.11-1) ...
Обрабатываются триггеры для man-db ...
Я в этом проблемы не вижу.

Оффлайн easy2002

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 2786
  • Мурманск
    • Просмотр профиля
Re: Ошибка: Неверная архитектура "i386"
« Ответ #14 : 13 Ноября 2009, 14:24:45 »
нафига ставить аналог гимпа трехлетней давности да ещё с бубном и под другую архитектуру?
из-за интерфейса?
так есть gimp2.7, там окошечки в окошечке


Tempora mutantur et nos mutantur in illis

 

Страница сгенерирована за 0.03 секунд. Запросов: 23.