Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: После обновления драйверов Intel система U9.04 не грузится  (Прочитано 663 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VaYurik

  • Автор темы
  • Участник
  • *
  • Сообщений: 168
    • Просмотр профиля
    • http://vayurik.ru
После обновления драйверов на видеокарту Intel с одного из репозиториев перестала до конца загружаться система.
Загрузка доходит до появления чёрного рабочего стола с панелью, на которой только значки приложений и всё, никаких больше апплетов.
Курсор мыши присутствует, елозит, но не нажимается. ALT-CTRL-Fn не работают. С кнопки комп не выключается.
В принципе, перед перезагрузкой я также разрешил использовать проприетарные дрова на wifi, но плата проверенная, проблем с ней со времён чуть ли не U7.10 не замечено, так что вряд ли это из-за неё.
В /etc/X11/xorg.conf чё-то ничего толком нет (хм... а куда всё делось, кстати?)
Инета на компе в консоли нет. Во всяком случае пока - wpa_supplicant не настраивал.

В какую сторону копать? Какие файлы приложить? Уж больно не хочется заново переставлять систему :(
« Последнее редактирование: 20 Ноября 2009, 13:23:00 от VaYurik »

Оффлайн Sam Stone

  • Старожил
  • *
  • Сообщений: 1129
    • Просмотр профиля
Если с консолью дружишь, то выбирай в меню груба recovery mode и вперед, воплощать в жизнь твою аватарку  ;D

Из действий: отредактировать sources.list, удалить левую репку, переставить дрова интеловые на те, что шли "в комплекте" ) Можно прибить (закоментировать) все репки, оставить только сидюк.
В принципе с лайв сиди можно то же самое выдернуть с инета.

пысы
в ксорге ручками добавь, чего не хватает:
Section "Device"
...
    Driver         "Vesa" #или vesa, не помню, влияет ли регистр.
...
EndSection
Jellyfish 5.19.0-43-generic

Оффлайн VaYurik

  • Автор темы
  • Участник
  • *
  • Сообщений: 168
    • Просмотр профиля
    • http://vayurik.ru
Дружу, куда ж тут без консоли? :) Правда, пару последних лет я там по собственной воле, так сказать, а не потому, что нужно компилить дрова для wifi-сетевушки (той самой, что в описываемой машине) или ставить с бубном дрова на АТИ. И эта тенденция радует :)

Ага, до закоменчивания репозитория и сам допёр, но дальше мысль прервалась, т.к. инет там по wifi, а я его в консоли не настраивал. А ведь и правда можно потом с CD обновится! Старею, тугею :( ("Тугею" - от слова "тугой" :))))
Сына проснётся (это его комп), пойду шаманить. Спасибо за совет!

В xorg.conf нет вообще ничего такого, что там раньше было. Ни одной строчки знакомой - ни тебе настроек клавиатуры, видюшки... Ничего. Только какие-то пустые общие блоки, типа:

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Кстати, на этом компе там есть настройка дров видюшки:
Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Надо будет начать ковырять с явного указания в соответствующем блоке драйвера vesa. Вдруг малой кровью прокатит?

По результатам отпишусь. Спасибо за советы!

Пользователь решил продолжить мысль 21 Ноября 2009, 22:32:14:
Ага, прописывание vesa а xorg.conf дало возможность загрузить систему, но в меру того, что какие-то новые/кривые пакеты, видимо, всё равно используются, то разрешение экрана - кривое, часть картинки - за пределами экрана, в настройке экрана - частота 0 Гц, монитор - неизвестен, типа.
Все установленные из репозитория того пакеты оказались в Синаптике в категории Установленые локально или устаревшие. Удалил дрова, но две библиотеки удалить так просто не даёт - они используются кучей приложений, которые также предлагается удалить :(
Что делать дальше? Как можно заменить установленную новую версию библиотеки или приложения на старую, которая есть в репозиториях?
« Последнее редактирование: 21 Ноября 2009, 22:32:14 от VaYurik »

 

Страница сгенерирована за 0.032 секунд. Запросов: 23.