Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Не запускается CUPS при загрузке Ubuntu 9.10  (Прочитано 8200 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн beza

  • Автор темы
  • Участник
  • *
  • Сообщений: 228
    • Просмотр профиля
Не запускается CUPS при загрузке Ubuntu 9.10. Проблема появилась несколько дней назад после одного из обновлений.
Пытаюсь запустить руками:

gena@gena-desktop:~$ sudo etc/rc.d/cups start
[sudo] password for gena:
sudo: etc/rc.d/cups: command not found

CUPS устанновлен. Тупо переустанавливаю CUPS - всё отлично, появляется принтер (Xerox WC3119), нет проблем.
После перезагрузки принтера нет, при попытке найти получаю сообщение, что сервер CUPS не запущен, и далее по кругу.
Хочу поставить CUPS в автозагрузку - получаю следующее:

gena@gena-desktop:~$ sudo update-rc.d cups default
update-rc.d: warning: cups start runlevel arguments (none) do not match LSB Default-Start values (2 3 4 5)
update-rc.d: warning: cups stop runlevel arguments (none) do not match LSB Default-Stop values (1)
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | SS KK]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
       update-rc.d [-n] <basename> disable|enable [S|2|3|4|5]
-n: not really
-f: force

The disable|enable API is not stable and might change in the future.

Как заставить грузиться CUPS?

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #1 : 28 Ноябрь 2009, 14:36:18 »
sudo update-rc.d cups defaults

Оффлайн beza

  • Автор темы
  • Участник
  • *
  • Сообщений: 228
    • Просмотр профиля
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #2 : 28 Ноябрь 2009, 18:50:39 »
Сделал так и получил:
gena@gena-desktop:~$ sudo update-rc.d cups defaults
update-rc.d: warning: cups stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (1)
 System start/stop links for /etc/init.d/cups already exist.
После перезагрузки опять:
gena@gena-desktop:~$ sudo etc/rc.d/cups start
[sudo] password for gena:
sudo: etc/rc.d/cups: command not found

Оффлайн genrich

  • Участник
  • *
  • Сообщений: 179
    • Просмотр профиля
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #3 : 28 Ноябрь 2009, 20:43:21 »
По моему, sudo /etc/init.d/ccpd start

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #4 : 28 Ноябрь 2009, 23:46:29 »
beza, когда уже ошибки перестанешь делать? etc/rc.d/cups - неправильный путь, да ещё и от текущей папки, вероятно, от домашней. /etc/init.d/cups - правильный путь, от корня.

Оффлайн beza

  • Автор темы
  • Участник
  • *
  • Сообщений: 228
    • Просмотр профиля
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #5 : 29 Ноябрь 2009, 00:40:17 »
Прошу прощения за ошибки, весь день в бегах и всё делал на ходу.
Сейчас всё делаю спокойно.
Загружаюсь - принтера нет, CUPS не загружен.
gena@gena-desktop:~$ sudo /etc/init.d/cups start
[sudo] password for gena:
 * Starting Common Unix Printing System: cupsd                           [ OK ]
CUPS загружен, принтер появился. Двлее:
gena@gena-desktop:~$ sudo update-rc.d cups defaults
update-rc.d: warning: cups stop runlevel arguments (0 1 6) do not match LSB Default-Stop values (1)
 System start/stop links for /etc/init.d/cups already exist.
Перегружаюсь - принтера нет, CUPS не загружен.

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #6 : 29 Ноябрь 2009, 17:50:43 »
Покажи
chkconfig --list cups

Оффлайн beza

  • Автор темы
  • Участник
  • *
  • Сообщений: 228
    • Просмотр профиля
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #7 : 29 Ноябрь 2009, 18:56:34 »

gena@gena-desktop:~$ chkconfig --list cups
cups                      0:off  1:off  2:on   3:on   4:on   5:on   6:off

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #8 : 30 Ноябрь 2009, 00:20:20 »
ну и всё в порядке, так что надо смотреть логи - почему купс вываливается при первом старте

Оффлайн beza

  • Автор темы
  • Участник
  • *
  • Сообщений: 228
    • Просмотр профиля
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #9 : 30 Ноябрь 2009, 20:25:19 »
После загрузки файл /var/log/cups/error_log пустой, после запуска cups имеет такой вид:

Цитировать
E [30/Nov/2009:19:21:18 +0200] Filter "/usr/lib/cups/filter/rastertosamsungspl" for printer "wc3119" not owned by root
E [30/Nov/2009:19:21:18 +0200] Filter directory "/usr/lib/cups/filter" for printer "wc3119" not owned by root
E [30/Nov/2009:19:21:18 +0200] Unable to remove temporary file "/var/spool/cups/tmp/.hplip" - Is a directory
W [30/Nov/2009:19:21:20 +0200] [CGI] Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
W [30/Nov/2009:19:21:20 +0200] [CGI] Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.

Сменил владельца для файла rastertosamsungspl и директории filter, осталась одна ошибка:

Цитировать
E [30/Nov/2009:19:30:37 +0200] Unable to remove temporary file "/var/spool/cups/tmp/.hplip" - Is a directory
W [30/Nov/2009:19:30:39 +0200] [CGI] Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
W [30/Nov/2009:19:30:39 +0200] [CGI] Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
« Последнее редактирование: 30 Ноябрь 2009, 20:41:18 от beza »

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #10 : 30 Ноябрь 2009, 21:42:11 »
sudo эрэм эрэф /var/spool/cups/tmp/.hplip

Оффлайн beza

  • Автор темы
  • Участник
  • *
  • Сообщений: 228
    • Просмотр профиля
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #11 : 30 Ноябрь 2009, 22:47:55 »
Сделал, сообщение об ошибке при запуске купса пропало.
Цитировать
W [30/Nov/2009:21:42:28 +0200] [CGI] Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
W [30/Nov/2009:21:42:28 +0200] [CGI] Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
Но после перезагрузки купс не грузится и опять:
 
Цитировать
E [30/Nov/2009:22:44:10 +0200] Unable to remove temporary file "/var/spool/cups/tmp/.hplip" - Is a directory
W [30/Nov/2009:22:44:13 +0200] [CGI] Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
« Последнее редактирование: 30 Ноябрь 2009, 23:49:55 от beza »

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #12 : 01 Декабрь 2009, 07:37:59 »
У меня там пусто. Драйвера какие-то ставил? Например, к HP принтеру? =)

Оффлайн beza

  • Автор темы
  • Участник
  • *
  • Сообщений: 228
    • Просмотр профиля
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #13 : 01 Декабрь 2009, 20:27:56 »
У меня в /var/spool/cups/tmp/.hplip сидел файл hplip.conf (пустой). Драйвера на HP не ставил, у меня нет ни одного устройства HP.
Драйвера ставил на Xerox WC3119(МФУ). После ручного запуска купса появляется два принтера, один подгружается системой автоматом, а второй появился после установки родного драйвера (без него не работает сканер). После запуска купса работают оба принтера.
Удалил всё,что нашёл связанное с hplip, действительно стояла система печати HP и драйвер на какой-то принтер.
Больше ошибок не выдаёт:
W [01/Dec/2009:19:42:13 +0200] [CGI] Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
W [01/Dec/2009:19:42:13 +0200] [CGI] Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
Однако купс не грузится.
« Последнее редактирование: 01 Декабрь 2009, 20:52:00 от beza »

Оффлайн Frank

  • Старожил
  • *
  • Сообщений: 1799
  • Профессиональный любитель
    • Просмотр профиля
    • Народный форум Николаева
Re: Не запускается CUPS при загрузке Ubuntu 9.10
« Ответ #14 : 01 Декабрь 2009, 22:00:03 »
* Frank потирает подбородок
Была у меня подобная фигня. Не хотел упорно запускаться pvpgn. Вручную приходилось пинать. Так и не выснил я тогда, в чём дело, а сейчас там дебиан стоит, запускается.

 

Страница сгенерирована за 0.053 секунд. Запросов: 23.