Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Ubuntu 9.10 установленная с помощью Wubi не загружается после обновления ядра  (Прочитано 3827 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн artREanimator

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Доброго времени суток всем. Получилось так, что Ubuntu 9.10 ставил из-под винды. Несмотря на предупреждения о замедленной работе диска, скоростью был вполне доволен, а спящий режим мне особо не нужен. Все работало без особых проблем пока менеджер обновлений не сказал что есть обновления ядра с версии 2.6,31-15-generic на 2.6,31-16generic. После того, как система скачала и установила новое ядро, было предложено перезагрузиться. После перезагрузки произошла вот такая фигня: После POST-а появляется меню загрузчика NTLDR, при выботе пункта Ubuntu появляется командная строка Grub. Меню Grub-а не появляется и следовательно не могу загрузиться. Прошу знающих людей подсказать как можно исправить эту ситуацию. Заранее благодарен.

Пользователь решил продолжить мысль 07 Декабря 2009, 01:51:44:
Ну что уважаемые, ни у кого нет соображений на этот счет?
« Последнее редактирование: 07 Декабря 2009, 01:51:44 от artREanimator »

Оффлайн drm

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
У меня абсолютно та же ситуация. К сожалению, ничего, кроме как полностью переустановить систему, в такой ситуации пока не умею :) Буду очень признателен за советы знающих людей.

Оффлайн gantellus

  • Старожил
  • *
  • Сообщений: 1276
    • Просмотр профиля
wubi глючно и будет отваливаться

обоим советую поставить по-человечески
Придумайте ещё более дружественный интерфейс, и мир породит ещё более тупого юзера (с)
С2Duo 2.4 Ghz, Geforce 8800, Maya 44 PCI

Оффлайн SureGOOD

  • Активист
  • *
  • Сообщений: 724
  • suregood.ru
    • Просмотр профиля
    • suregood.ru
а груб с live cd восстановить, не?

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
поставить систему нормально (т.е не через wubi)


p/s на месте разрабов убунты я бы выкинул wubi нафиг

Оффлайн artREanimator

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Цитировать
поставить систему нормально (т.е не через wubi)
Обязательно прислушаюсь к совету, но в данном случае есть данные которые необходимо восстановить. Так что вопрос пока остается открытым.
Кстати вот какая еще мысль меня посетила: при установке с помощью Wubi создался файл G:\ubuntu\disks\root.disk - который по-сути является образом жесткого диска (или раздела диска). Нельзя-ли его как нибудь смонтировать по принципу монтирования образов CD или DVD при помощи Alcohol120%? Или смонтировать как-то под Линь, загрузившись с Live CD. В общем смысл в том, чтобы сохранить файлы и настройки системы.

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
mount -o loop /путь/к/root.disk /media/rootdisk

Оффлайн drm

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
На англоязычных форумах тоже эта проблема обсуждается: http://ubuntuforums.org/showthread.php?t=1339203 . Однократно загрузиться мне помогли инструкции, приведённые в #10. Правда, как восстановить нормальную загрузку, мне по-прежнему непонятно, но теперь хотя бы ясно, что данные не пропали.

Оффлайн artREanimator

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
На англоязычных форумах тоже эта проблема обсуждается: http://ubuntuforums.org/showthread.php?t=1339203 . Однократно загрузиться мне помогли инструкции, приведённые в #10. Правда, как восстановить нормальную загрузку, мне по-прежнему непонятно, но теперь хотя бы ясно, что данные не пропали.

Благодарю, именно эта ссылка помогла мне! Но мне помогли инструкции из #5 и #10.
вот последовательность команд:
insmod ntfs
set root=(loop0)
linux /boot/vmlinuz-2.6.31-15-generic root=/dev/sda3 loop=/ubuntu/disks/root.disk ro
initrd /boot/initrd.img-2.6.31-15-generic
boot
Хочу заметить что в команде root=/dev/sda3 у вас вместо sda3 может быть sda2 или sda1
Также было замечено что ядра "vmlinuz-2.6.31-14-generic" и "vmlinuz-2.6.31-16-generic" почему-то не загружаются.
После того как система загрузится не забудьте сделать следующее:
sudo update-grub2
последняя команда обновляет меню загрузчика и после перезагрузки вы без проблем грузитесь

Оффлайн drm

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
А у меня сработало только ядро 14 и не помогла команда update-grub2 :)
Вообще будет жаль, если разработчики эту проблему не устранят. Установка ubuntu без переразметки дисков -- отличная идея для привлечения перебежчиков из стана Windows:) Наверно, есть какой-то формальный способ сообщить им об этой ошибке?

 

Страница сгенерирована за 0.059 секунд. Запросов: 23.