Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Порты на Ubuntu  (Прочитано 6391 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MAS

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Порты на Ubuntu
« : 29 Январь 2010, 19:53:58 »
Нужна помощь.Ситуация вот какая:
Есть ПК на Ubuntu и XP комп. Все суппер,но доступ к Ubuntu серверу(компу) есть только в локалке.
На Ubuntu стоит сервер КС.
Проблема в том что сервер даже с интернета не пингуеться:
Поставил no-ip на Ubuntu.Когда пингую в локалке..пинг идет.Но когда захожу через другой инет.Нету пинга.
Через команду "nmap localhost"
Цитировать
Starting Nmap 5.00 ( http://nmap.org ) at 2010-01-29 19:50 AST
Warning: Hostname localhost resolves to 2 IPs. Using 127.0.0.1.
Interesting ports on localhost (127.0.0.1):
Not shown: 997 closed ports
PORT     STATE SERVICE
22/tcp   open  ssh
631/tcp  open  ipp
3306/tcp open  mysql
Другими словами порты такие как 22 и 3306 открыты..а конекта к ним нету.... И если можно обьясните как остальные 997 портов окрыть((

Настройки IPtables
Цитировать
root@ubuntu:~# iptables --list-rules
-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT
Самое главное что SSH по локалке на ура идет.

Конект:
Модем ADSL (проброс на роутер стоит) ===> Роутер (NAT проброс на порты Ubuntu стоят).

Помогите ато уже 3тий день в гугле шарюсь...(( :-\ :-[


Оффлайн roma333

  • Участник
  • *
  • Сообщений: 206
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #1 : 29 Январь 2010, 20:16:12 »
Помимо открытие порта нужно еще разрешить форвард, читайте тему про iptables, там все написано.

Оффлайн MAS

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #2 : 29 Январь 2010, 20:25:17 »
Помимо открытие порта нужно еще разрешить форвард, читайте тему про iptables, там все написано.
Форвард?
Хм..А чего на что?
На модеме и роутере я форвард настроил.
А вот порт чем не пробовал открывть...пишет только 3 открытых...и все((

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25936
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #3 : 29 Январь 2010, 22:45:52 »
Поправьте, если я не так понял.
У вас подключение идёт
ADSL modem --- Ethernet Router --- Ваша локалка
Так?
Тогда кладите модем в бридж, а весь дозвон настраивайте на роутере.
Чем меньше точек маршрутизации, тем лучше.
И проверьте, что провайдер выдаёт вам реальный IP.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн MAS

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #4 : 29 Январь 2010, 23:48:36 »
Поправьте, если я не так понял.
У вас подключение идёт
ADSL modem --- Ethernet Router --- Ваша локалка
Так?
Тогда кладите модем в бридж, а весь дозвон настраивайте на роутере.
Чем меньше точек маршрутизации, тем лучше.
И проверьте, что провайдер выдаёт вам реальный IP.
IP реальный. Ибо на XP сервера уже ставил,работали.
Модем в бридже(Схема верна). Все "проходы" проложыл... с Модема перенаправл. к примеру 22 на Роутер с роута 22 на серв Ubuntu.
Меня пугает что с localhost все гуд... конект ssh и апатчь тож думаю будет работать на 100% уверен.
Но при команде ping и IP компа(не локал) вобще 0... и ssh доступ не работает пишет "Conection time out"-время вишло конекта...(допроса к серву.)...

Может просто на серве Ubuntu закрыты все входящии из вне?...тогда как открыть?
Или какие фильтры стоят...
Файр вол - выключил
IPtable-Више читайте....
Ставил сервер на VPS все на ура работает правдо там Gentoo 2,6... :( :( :-\

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25936
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #5 : 30 Январь 2010, 01:30:18 »
Если модем в бридже, никакие перенаправления там работать не будут, ибо бридж тупой.
nmap'ить localhost - занятие неблагодарное.
nmap надо запускать с другой машины.
iptables-save приводить надо, если думаешь, что проблемы в фаерволе.
Кстати, вайервол в линуксе выключить не так просто, если вообще возможно.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн MAS

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #6 : 30 Январь 2010, 15:38:33 »
Если модем в бридже, никакие перенаправления там работать не будут, ибо бридж тупой.
nmap'ить localhost - занятие неблагодарное.
nmap надо запускать с другой машины.
iptables-save приводить надо, если думаешь, что проблемы в фаерволе.
Кстати, вайервол в линуксе выключить не так просто, если вообще возможно.
вайервол в линуксе выключить не так просто -ufw disable (могут быть ошибки команду точно не помню..)
Вобщем проблема с пингом и портами (НЕКОТОРЫМИ) решилась...но вот загвоздка 3306 MySQL не откликаеться на внешние и локальные запросы...хотя порт открыт...а пишет ошибку в локалке "10061"...

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25936
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #7 : 30 Январь 2010, 20:50:32 »
Фаервол - это netfilter.
ufw, firestarter и даже iptables - только управляющие надстройки.

MySQL имеет собственные способы контроля доступа к телу.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн taliban

  • Новичок
  • *
  • Сообщений: 44
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #8 : 31 Март 2010, 17:04:31 »
Подскажите, как все же выключить в файрволе 25 порт? А то очень срочно нужно сервак настроить.
А то поставил postfix на удаленном серваке, а он почту не хочет отправлять.
На 25 ни с локала, ни с домашнего компа не соединяется.

Пробовал так:
Цитировать
iptables -A INPUT -p tcp --dport 25 -j ACCEPT

Но команда
nmap -sT 127.0.0.1
показывает 25 порт закрыт:
Цитировать
PORT      STATE SERVICE
21/tcp    open  ftp
22/tcp    open  ssh
53/tcp    open  domain
80/tcp    open  http
110/tcp   open  pop3
143/tcp   open  imap
993/tcp   open  imaps
995/tcp   open  pop3s
3306/tcp  open  mysql
10000/tcp open  snet-sensor-mgmt
« Последнее редактирование: 31 Март 2010, 17:10:58 от taliban »

Оффлайн podkovyrsty

  • Старожил
  • *
  • Сообщений: 1547
  • Content-Type: alternative
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #9 : 31 Март 2010, 18:22:21 »
Подскажите, как все же выключить в файрволе 25 порт? А то очень срочно нужно сервак настроить.
А то поставил postfix на удаленном серваке, а он почту не хочет отправлять.
На 25 ни с локала, ни с домашнего компа не соединяется.

Пробовал так:
Цитировать
iptables -A INPUT -p tcp --dport 25 -j ACCEPT

Но команда
nmap -sT 127.0.0.1
показывает 25 порт закрыт:
Цитировать
PORT      STATE SERVICE
21/tcp    open  ftp
22/tcp    open  ssh
53/tcp    open  domain
80/tcp    open  http
110/tcp   open  pop3
143/tcp   open  imap
993/tcp   open  imaps
995/tcp   open  pop3s
3306/tcp  open  mysql
10000/tcp open  snet-sensor-mgmt


А демон, работающий на 25 порту - точно живой?
Шаг за шагом можно достичь цели.

Оффлайн taliban

  • Новичок
  • *
  • Сообщений: 44
    • Просмотр профиля
Re: Порты на Ubuntu
« Ответ #10 : 31 Март 2010, 18:35:39 »
Все разобрался.
Действительно проблема была в демоне. Как только пофиксил настройки dovecot, порт сам открылся.

 

Страница сгенерирована за 0.056 секунд. Запросов: 22.