Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Странная проблема с ntfs-3g  (Прочитано 791 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ploop

  • Автор темы
  • Активист
  • *
  • Сообщений: 762
    • Просмотр профиля
Странная проблема с ntfs-3g
« : 03 Февраль 2010, 08:23:31 »
При копировании больших файлов (больше 1-2Гб) с ntfs на ext4 происходят странные вещи: раздел ntfs "отваливается", процесс mount.ntfs завершается, а программа, с помощью которой копировалось, висит либо в состоянии зомби, либо тоже завершается сегфолтом. И после этого, обычно, вышибает из сесии. Если копировать наутилусом - всё виснет напроч, пока не ребутнёшся.

Проблема в драйвере ntfs-3g. После сноса одномённого пакета ntfs-раздел становится read only, но копируется с него всё как по маслу! Он мне, собственно, и нужен только для чтения (перенести данные и форматнуть в ext4), но как быть с флешкаи?
 Без ntfs никуда...

И еще. Безболезненно копируется с помощью dd если установить опцию bs поменьше, например 128. По дефолту (bs=512) те же проблемы. А так копирует чуть дольше, но чётко. Но это не решение проблемы.

----
Ubuntu 9.10 amd64 17 ядро

Оффлайн Димон1980

  • Любитель
  • *
  • Сообщений: 88
    • Просмотр профиля
Re: Странная проблема с ntfs-3g
« Ответ #1 : 03 Февраль 2010, 09:28:20 »
Насчёт флешек... Была такая же проблема, поставил Гном-Коммандер, на флешку копирую им - теперь всё в норме. С винтами таких проблем не возникало вообще... Даже интересно - у меня 2 терабайта в НТФС, а в ЕХТ 400 гигов только, и всегда всё ОК было... :o
SHIT HAPPENS...

Оффлайн ploop

  • Автор темы
  • Активист
  • *
  • Сообщений: 762
    • Просмотр профиля
Re: Странная проблема с ntfs-3g
« Ответ #2 : 03 Февраль 2010, 10:54:55 »
Гном-Коммандер стоит, если честно не пробовал им. С таким же успехом и dd работает, как говорил уже. Но проблема то есть. И почему-то раньше не замечал, может, старое ядро было? Надо еще с ним попробовать...

Оффлайн Toska

  • Участник
  • *
  • Сообщений: 118
    • Просмотр профиля
Re: Странная проблема с ntfs-3g
« Ответ #3 : 03 Февраль 2010, 12:21:02 »
А если флешку в FATе отформатировать? (Кстати и скорость копирования несколько получше)

Оффлайн ploop

  • Автор темы
  • Активист
  • *
  • Сообщений: 762
    • Просмотр профиля
Re: Странная проблема с ntfs-3g
« Ответ #4 : 03 Февраль 2010, 12:36:55 »
Знаю. Но фильм в HD от друзей уже не притащишь...

Опять же, это обход проблемы, а не решение :(

Оффлайн cergei1982

  • Участник
  • *
  • Сообщений: 108
    • Просмотр профиля
Re: Странная проблема с ntfs-3g
« Ответ #5 : 03 Февраль 2010, 13:35:17 »
Подобную проблему тож встретил.У меня есть винт SATA от ноутбука,купил бокс под него,при подключении и копировании большых файлов сам отключается,а бывает что подмонтируется в режиме чтения тока,отсоединяеш от компа и подключаеш и работает уже в режиме записи и чтения.
Глаза боятся,а руки делают.

Oni-chan

  • Гость
Re: Странная проблема с ntfs-3g
« Ответ #6 : 03 Февраль 2010, 14:45:13 »
а если собрать свежую версию драйвера из исходников?

http://tuxera.com/opensource/ntfs-3g-2010.1.16.tgz

Оффлайн ploop

  • Автор темы
  • Активист
  • *
  • Сообщений: 762
    • Просмотр профиля
Re: Странная проблема с ntfs-3g
« Ответ #7 : 03 Февраль 2010, 15:51:40 »
Спасибо, вечером попробую!

Оффлайн Димон1980

  • Любитель
  • *
  • Сообщений: 88
    • Просмотр профиля
Re: Странная проблема с ntfs-3g
« Ответ #8 : 03 Февраль 2010, 19:47:15 »
А если флешку в FATе отформатировать? (Кстати и скорость копирования несколько получше)
Форматировал и в ФАТ - нифига она не лучше...
SHIT HAPPENS...

Оффлайн ploop

  • Автор темы
  • Активист
  • *
  • Сообщений: 762
    • Просмотр профиля
Re: Странная проблема с ntfs-3g
« Ответ #9 : 03 Февраль 2010, 20:20:05 »
Собрал версию 2010.1.16, монтирует нормально, но проблема осталась.
Вот, на всякий случай, что говорит журнал:
(Нажмите, чтобы показать/скрыть)

Пользователь решил продолжить мысль 04 Февраль 2010, 05:40:36:
Проверил, та же проблема при копировании больших файлов и при загрузке с LiveCD

Пользователь решил продолжить мысль 04 Февраль 2010, 13:33:50:
У меня мыслей больше нет :( Если уж с  LiveCD не работает (там старое ядро), может, проблема в железе?

Попробую последний вариант - пересобрать ядро. Когда-то надо начинать осваивать ядерную физику...
« Последнее редактирование: 04 Февраль 2010, 13:33:50 от ploop »

 

Страница сгенерирована за 0.061 секунд. Запросов: 22.