Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: АДМИН, КОТ, ШРЕДЕР... Я ПРИВЛЁК ВАШЕ ВНИМАНИЕ? А вот Firefox 3.6 не видит плагин  (Прочитано 1239 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Denis Russkih

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
Всем привет! Возникла такая проблема...

Предыстория:
Я установил на ноутбук Ubuntu 9.10, там по умолчанию был Firefox 3.5. Естественно, мне захотелось установить более новый Firefox 3.6. Я скачал с официального сайта файл firefox-3.6.tar.bz2 и распаковал его в ~/.firefox-3.6, после чего вручную добавил ссылку на браузер в главное меню, прописал хоткей на запуск браузера в xbindkeys и полагал, что установил программу как надо...

Сама история:
Я захотел поиграться с Grappa - это такой Java-апплет, позволяющий рисовать красивые геометрические фигуры:
http://www.eigelb.at/HP/Links/SpecialEffects/Grappa/GrappaWH_White/index.html
Однако обнаружил, что этот апплет не запускается в браузере! Оказывается, нужен специальный плагин для Firefox.
Поиск в Google вроде бы решил проблему:
http://ubuntu-tutorials.com/2006/11/20/how-to-install-java-runtime-environment-jre-with-firefox-plugin-ubuntu-6061-610/
Я выполнил
sudo aptitude install sun-java6-jre sun-java6-plugin sun-java6-bin
и - о счастье! - приложение Grappa стало запускаться... Но лишь в том браузере, который был установлен вместе с системой! Новый Firefox 3.6 в упор не видит плагин и, соответственно, отказывается запускать апплеты на странице.

Можно ли как-то исправить это?

Насколько я понимаю, тут всё дело в том, что Firefox 3.5, который по умолчанию, установлен более корректно, поэтому sun-java6-plugin смог увидеть его при установке, подойти и представиться. :) Новый же Firefox 3.6 представляет собой просто файл в папке, без "знакомств", поэтому его элементарно не заметили.


Соответственно, вопросы:

1. Как, блин, правильно устанавливать Firefox из архива tar.bz2, чтобы такие истории впредь не повторялись? README.txt отсылает на сайт Мозиллы, а там только самая общая информация, никакой конкретики.

2. Что сейчас я могу сделать, чтобы познакомить Firefox 3.6 и sun-java6-plugin друг с другом? :)
« Последнее редактирование: 19 Февраль 2010, 20:43:56 от Denis Russkih »
Ubuntu 10.10

Оффлайн SureGOOD

  • Активист
  • *
  • Сообщений: 724
  • suregood.ru
    • Просмотр профиля
    • suregood.ru
это конечно не решение, но чем вам принципиален 3.6?
ps
можно подключить репозитории, где уже есть FF 3.6, думаю это правльней)

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
подключить репозиторий с допиленным под ubuntu FF 3.6 и установить от туда, предварительно вынеся FF 3.5

Оффлайн Alie Alexandross

  • Старожил
  • *
  • Сообщений: 1580
    • Просмотр профиля
(Нажмите, чтобы показать/скрыть)
Подпись автора jillsmitt истинна...

Оффлайн ArcFi

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 15194
    • Просмотр профиля
    • aetera.net

Оффлайн Denis Russkih

  • Автор темы
  • Любитель
  • *
  • Сообщений: 50
    • Просмотр профиля
ArcFi, огромное спасибо! :)

Вот что значит умение правильно задать слова в Google... Я каких только комбинаций не перепробовал, но получал в ответ всякую ерунду... А тут в первых же ссылках - именно то, что нужно!
Ubuntu 10.10

 

Страница сгенерирована за 0.07 секунд. Запросов: 22.