Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: зависимости ошибки  (Прочитано 1571 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн keel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
зависимости ошибки
« : 21 Февраль 2010, 18:42:26 »
При установки любого приложения или любого пакета выходят такие ошибки:
E: postfix: подпроцесс установлен сценарий post-installation возвратил код ошибки 1
E: mailutils: проблемы зависимостей -- оставляем не настроенным
E: postfix-ldap: проблемы зависимостей -- оставляем не настроенным
E: lsb-core: проблемы зависимостей -- оставляем не настроенным
E: lsb-graphics: проблемы зависимостей -- оставляем не настроенным
E: lsb-cxx: проблемы зависимостей -- оставляем не настроенным
E: lsb-desktop: проблемы зависимостей -- оставляем не настроенным
E: lsb: проблемы зависимостей -- оставляем не настроенным


Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #1 : 21 Февраль 2010, 19:05:09 »
Цитировать
При установки любого приложения или любого пакета
Откуда, куда, где, как ..........
xUbuntu 12.04

Оффлайн keel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #2 : 21 Февраль 2010, 20:06:09 »
делаю sudo apt-get install python-mutagen
получаю:
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Уже установлена самая новая версия python-mutagen.
python-mutagen установлен вручную.
Следующие пакеты устанавливались автоматически и больше не требуются:
  libnb-platform10-java libmono-i18n-west1.0-cil kazehakase-gecko
  libcommons-collections3-java libjna-java libswing-layout-java jsvc
  monodoc-base libwildmidi0 junit4 libmono-security1.0-cil apache2-utils
  liboro-java libevent-1.4-2 libmd5-perl gtali glchess libgcj-bc
  libnb-platform-devel-java libmono-sharpzip0.84-cil libgtk2-sexy-perl
  libestraier8 libsoundtouch1c2 libnb-java2-java libcrypt-ssleay-perl
  libarpack2 libqmmp0 twolame libqmmpui0 freemat-help
  libxml-namespacesupport-perl gnobots2 libmono-system-web1.0-cil
  python-pygame junit gnome-mahjongg libmono-peapi2.0-cil
  epiphany-browser-data libfreemarker-java libmono-corlib1.0-cil libopenmpi1.3
  ocaml-base-nox smplayer-translations libregexp-java google-gadgets-common
  libavidemux0 libdb4.6-java kdevelop-data same-gnome libatk1-ruby1.8
  libmono-system-runtime2.0-cil libopenjpeg2 libopenspc0 liblog4j1.2-java
  libqt4-core libgtk2-trayicon-perl libxml-sax-expat-perl libservlet2.4-java
  monodoc-manual liblucene2-java jetty libminpack1 libcrypt-simple-perl
  libnss3-dev gnibbles libslf4j-java ttf-tahoma-replacement python-utidylib
  gcj-4.4-jre-lib slashem-common libgcj10 jruby1.1 ant-optional-gcj libmcrypt4
  libnb-ide11-java valgrind libtidy-0.99-0 libqdbm14 python-mmkeys ant
  avidemux-plugins python-numpy default-jdk libsvn-java fuseiso9660
  libmono-winforms2.0-cil gcj-4.4-base libmono-system1.0-cil libt1-5
  libmono-microsoft-build2.0-cil python-cddb libmono-webbrowser0.5-cil gnotski
  libgcj-common libsdl-ttf2.0-0 libmikmod2 libqmmp-misc gnometris
  libcobertura-java libgluezilla libcrypt-blowfish-perl avidemux-common
  libxml-sax-perl freepats libini4j-java libjetty-java libcommons-net-java
  python-feedparser libggadget-gtk-1.0-0 libdb4.6-java-gcj libasm2-java
  libnspr4-dev libmono-data-tds1.0-cil libglib2-ruby1.8 libcommons-daemon-java
  lesstif2 media-player-info libmono-system-data1.0-cil libclutter-gtk-0.10-0
  gnome-sudoku galeon-common libcairo-ruby1.8 ttf-symbol-replacement
  libcommons-beanutils-java libnb-apisupport1-java libmono-cecil-private-cil
  mono-csharp-shell libdb-je-java fuseiso libmono-dev libkate1 libcdaudio1
  libgdk-pixbuf2-ruby1.8 libmimic0 libxml-simple-perl libsdl-mixer1.2
  libibverbs1 libswingworker-java gnotravex libmono-accessibility2.0-cil
  libcommons-digester-java gnect libumlib0 ocaml-base libmpg123-0 mjpegtools
  libgtk2-ruby1.8 libhamcrest-java libjtidy-java
  libxml-commons-resolver1.1-java libmono-system-runtime1.0-cil
  libappframework-java libdirac0c2a libmono-relaxng1.0-cil libggadget-1.0-0
  celestia-common libmhash2 libemeraldengine0 libgtk2-ruby mono-devel
  libjsch-java libmono-management2.0-cil libimlib2 kdevplatform1-libs
  libsexymm2 libnb-javaparser-java ant-gcj mono-2.0-devel libjpeg-progs
  conkeror-spawn-process-helper freemat-data lame ant-optional
  libjetty-java-doc libemail-mime-encodings-perl libnb-svnclientadapter-java
  libbeansbinding-java lcov libpango1-ruby1.8 libsublime1 libofa0 xpdf-common
  mono-gmcs gnomine libsmpeg0
Для их удаления используйте 'apt-get autoremove'.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 13 пакетов не обновлено.
не установлено до конца или удалено 8 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0B.
Настраивается пакет postfix (2.6.5-3) ...
Добавляется системный пользователь `postfix' (UID 117) ...
Добавляется новый пользователь `postfix' (UID 117) в группу `postfix' ...
useradd: не удалось заблокировать /etc/passwd; попробуйте ещё раз позже.
adduser: `/usr/sbin/useradd -d /var/spool/postfix -g postfix -s /bin/false -u 117 postfix' вернул код ошибки 1. Завершение работы.
dpkg: не удалось обработать параметр postfix (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет mailutils:
 mailutils зависит от exim4 | mail-transport-agent, однако:
  Пакет exim4 не установлен.
  Пакет mail-transport-agent не установлен.
  Пакет postfix, предоставляющий mail-transport-agent, пока не настроен.
dpkg: не удалось обработать параметр mailutils (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет postfix-ldap:
 postfix-ldap зависит от postfix (= 2.6.5-3), однако:
  Пакет postfix пока не настроен.
dpkg: не удалось обработать параметр postfix-ldap (--configure):
 проблемы зависимостей -- оставляем не настроенным
Отчет apport не записан, т.к. сообщение об ошибке указывает на предыдущий сбой
                                                                              Отчет apport не записан, т.к. сообщение об ошибке указывает на предыдущий сбой
                                                                            dpkg: зависимости пакетов не позволяют настроить пакет lsb-core:
 lsb-core зависит от postfix | mail-transport-agent, однако:
  Пакет postfix пока не настроен.
  Пакет mail-transport-agent не установлен.
  Пакет postfix, предоставляющий mail-transport-agent, пока не настроен.
 lsb-core зависит от mailx | mailutils, однако:
  Пакет mailx не установлен.
  Пакет mailutils, предоставляющий mailx, пока не настроен.
  Пакет bsd-mailx, предоставляющий mailx, не установлен.
  Пакет mailutils пока не настроен.
dpkg: не удалось обработать параметр lsb-core (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настр�Отчет apport записан не был, т.к. достигнуто MaxReports.
                     Отчет apport записан не был, т.к. достигнуто MaxReports.
                                                                             Отчет apport записан не был, т.к. достигнуто MaxReports.
                                                     Отчет apport записан не был, т.к. достигнуто MaxReports.
                             Отчет apport записан не был, т.к. достигнуто MaxReports.
     �ить пакет lsb-graphics:
 lsb-graphics зависит от lsb-core, однако:
  Пакет lsb-core пока не настроен.
dpkg: не удалось обработать параметр lsb-graphics (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет lsb-cxx:
 lsb-cxx зависит от lsb-core, однако:
  Пакет lsb-core пока не настроен.
dpkg: не удалось обработать параметр lsb-cxx (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет lsb-desktop:
 lsb-desktop зависит от lsb-graphics, однако:
  Пакет lsb-graphics пока не настроен.
dpkg: не удалось обработать параметр lsb-desktop (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет lsb:
 lsb зависит от lsb-core, однако:
  Пакет lsb-core пока не настроен.
 lsb зависит от lsb-graphics, однако:
  Пакет lsb-graphics пока не настроен.
 lsb зависит от lsb-cxx, однако:
  Пакет lsb-cxx пока не настроен.
 lsb зависит от lsb-desktop, однако:
  Пакет lsb-desktop пока не настроен.
dpkg: не удалось обработать параметр lsb (--configure):
 проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для libc-bin ...
ldconfig deferred processing now taking place
При обработке следующих пакетов произошли ошибки:
 postfix
 mailutils
 postfix-ldap
 lsb-core
 lsb-graphics
 lsb-cxx
 lsb-desktop
 lsb

Оффлайн sash_123

  • Любитель
  • *
  • Сообщений: 64
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #3 : 21 Февраль 2010, 21:37:23 »
Настраивается пакет postfix (2.6.5-3) ...
Добавляется системный пользователь `postfix' (UID 117) ...
Добавляется новый пользователь `postfix' (UID 117) в группу `postfix' ...
useradd: не удалось заблокировать /etc/passwd; попробуйте ещё раз позже.
adduser: `/usr/sbin/useradd -d /var/spool/postfix -g postfix -s /bin/false -u 117 postfix' вернул код ошибки 1. Завершение работы.
dpkg: не удалось обработать параметр postfix (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет mailutils:
 mailutils зависит от exim4 | mail-transport-agent, однако:
  Пакет exim4 не установлен.

и понеслась. Можно сначала руками добавить этого пользователя с нужным UID в группу postfix

Оффлайн keel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #4 : 21 Февраль 2010, 22:37:21 »
Можно сначала руками добавить этого пользователя с нужным UID в группу postfix

Как это сделать?

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #5 : 21 Февраль 2010, 23:00:38 »
Система - > Администрирование -> Пользователи и групы
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Oni-chan

  • Гость
Re: зависимости ошибки
« Ответ #6 : 21 Февраль 2010, 23:01:42 »
sudo adduser username postfix

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #7 : 21 Февраль 2010, 23:14:27 »
sudo adduser username postfix
тогда уж
sudo adduser --system --uid 117 --group postfix postfix
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн keel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #8 : 21 Февраль 2010, 23:55:34 »
 sudo adduser --system --uid 117 --group postfix postfix
adduser: Только одно имя можно указать в этом режиме.

И?

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #9 : 22 Февраль 2010, 00:19:44 »
хм, интиресно, попробуй тогда
sudo adduser --system --uid 117 postfix
sudo  addgroup postfix
sudo adduser postfix postfix

а потом поставь пакет exim4 или mail-transport-agent(что тебе больше нравится).
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн keel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #10 : 22 Февраль 2010, 00:40:49 »
sudo adduser --system --uid 117 postfix
результат:
Добавляется системный пользователь `postfix' (UID 117) ...
Добавляется новый пользователь `postfix' (UID 117) в группу `nogroup' ...
useradd: не удалось заблокировать /etc/passwd; попробуйте ещё раз позже.
adduser: `/usr/sbin/useradd -d /home/postfix -g nogroup -s /bin/false -u 117 postfix' вернул код ошибки 1. Завершение работы.

Что не так?

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #11 : 22 Февраль 2010, 07:23:44 »
так, Система - > Администрирование -> Пользователи и группы
посмотри есть ли там пользователь postfix.
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн keel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #12 : 22 Февраль 2010, 09:13:57 »
Посмотрел.Нету.

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #13 : 22 Февраль 2010, 11:01:42 »
Нука, клянька в /etc, есть такие файлы как passwd.lock и shadow.lock?
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн keel

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: зависимости ошибки
« Ответ #14 : 22 Февраль 2010, 12:28:56 »
есть

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.