Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Нет ответа на PPP Lcp echo-request  (Прочитано 8527 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ruPaladin

  • Автор темы
  • Участник
  • *
  • Сообщений: 107
    • Просмотр профиля
Нет ответа на PPP Lcp echo-request
« : 23 Февраль 2010, 13:31:54 »
Возникла проблема при подключении к Интернет через pppoe (через LAN). После подключения проходит 90 секунд и происходит обрыв связи. Чтение логов показало, что при запросе ppp lcp echo-request с моего компьютера не приходит ответ в виде ppp lcp echo-reply. В /etc/NetworkManager/system-connections/мое_подключение поменял параметры:
lcp-echo-failure=0
lcp-echo-interval=0
На:
lcp-echo-failure=3
lcp-echo-interval=90

И увидел, что ответ приходит приблизительно через 90 секунд (wireshark помог). И сейчас вроде проблема решена.
До этого момента все работало нормально. Так вот и возникает вопрос, что это за пакеты такие ppp lcp echo-request и, собственно, кто должен их посылать: мой ПК или модем/сервер? Так как при аналогичном запросе от модема/сервера к моему ПК ответ от моего ПК поступает мгновенно. Может это проблема моих кривых рук, хотя при загрузке с live cd возникает таже проблема (раньше все было нормально). При подключении из Windows никаких обрывов не происходит.

P. S. Может меня взломали? :-\
P. P. S. Подключение выглядит так: ПК->свитч->модем на лестничной пощадке.

Оффлайн yuristep

  • Участник
  • *
  • Сообщений: 248
    • Просмотр профиля
Re: Нет ответа на PPP Lcp echo-request
« Ответ #1 : 23 Февраль 2010, 13:57:52 »
Перевожу на родной язак Вашу текущую настройку:
- каждые 90 сек. посылать на удаленный сервер паке-запрос - на самом деле это просто проверка наличия/работоспособности канала
- при 3 неполученных ответах - считать канал "упавшим"

lcp echo-request посылает сервер провайдера, это ответ на запрос с Вашей стороны нп "наличие канала" ...
Может PPPoE сервер провайдера тупить начал. может еще чего-нибудь с физикой канала ...
Осторожно! - Злой админ!

Оффлайн ruPaladin

  • Автор темы
  • Участник
  • *
  • Сообщений: 107
    • Просмотр профиля
Re: Нет ответа на PPP Lcp echo-request
« Ответ #2 : 23 Февраль 2010, 14:57:19 »
Спасибо, так оно и звучит :) . Может ли быть в этом вина моего провайдера? И можно ли октлючить это, если закомментировать строчки в /etc/ppp/options:
# If this option is given, pppd will send an LCP echo-request frame to the
# peer every n seconds. Normally the peer should respond to the echo-request
# by sending an echo-reply. This option can be used with the
# lcp-echo-failure option to detect that the peer is no longer connected.
lcp-echo-interval 30

# If this option is given, pppd will presume the peer to be dead if n
# LCP echo-requests are sent without receiving a valid LCP echo-reply.
# If this happens, pppd will terminate the connection.  Use of this
# option requires a non-zero value for the lcp-echo-interval parameter.
# This option can be used to enable pppd to terminate after the physical
# connection has been broken (e.g., the modem has hung up) in
# situations where no hardware modem control lines are available.
lcp-echo-failure 3

Не повлияет ли это на безопасность системы?
« Последнее редактирование: 23 Февраль 2010, 14:59:52 от ruPaladin »

Гарри Кашпировский

  • Гость
Re: Нет ответа на PPP Lcp echo-request
« Ответ #3 : 23 Февраль 2010, 15:24:46 »
По сабжу, с pptp+pppd проблему так и не решил, отваливается все одно, хоть делай lcp-echo-interval 90 хоть lcp-echo-failure 8. Такие дела. Если кто знает решение, подскажите.
« Последнее редактирование: 23 Февраль 2010, 15:45:17 от Agafonov »

Оффлайн yuristep

  • Участник
  • *
  • Сообщений: 248
    • Просмотр профиля
Re: Нет ответа на PPP Lcp echo-request
« Ответ #4 : 23 Февраль 2010, 16:05:39 »
Спасибо, так оно и звучит :) . Может ли быть в этом вина моего провайдера? И можно ли октлючить это, если закомментировать строчки в /etc/ppp/options:
лияет ли это на безопасность системы?
....................................................................
... а что, дефолтные настройки кто-то отменял?...
Это с вероятностью в 90%% именно и есть вина Вашего провайдера - либо перегруженный сервер авторизации/PPPoE, либо проблемы с физикой .... Ну заккомнтируете Вы эти строки - чем поможет? Если Ваша железяка периодически говорит о том, что не может дождаться ответа на пинг в течении ДЕВЯНОСТА секунд? - задумайтесь, наверное как-то хреново канал работает ;)
Осторожно! - Злой админ!

Оффлайн ruPaladin

  • Автор темы
  • Участник
  • *
  • Сообщений: 107
    • Просмотр профиля
Re: Нет ответа на PPP Lcp echo-request
« Ответ #5 : 23 Февраль 2010, 16:31:25 »
По сабжу, с pptp+pppd проблему так и не решил, отваливается все одно, хоть делай lcp-echo-interval 90 хоть lcp-echo-failure 8. Такие дела. Если кто знает решение, подскажите.

Вы, случайно, не пользуетесь NetworkManager'ом? Правка файла /etc/ppp/options не давала результатов, а вот правка /etc/NetworkManager/system-connections/мое_подключение помогла

yuristep, спасибо большое, буду тогда провайдера "долбить" ;)
P. S. Тормозов при загрузке страниц нет, через 90 сек просто происходит разрыв без видимых причин. Вот как-то так, но, думаю, звонок провайдеру прояснит проблему, жалко, что сегодня у них выходной.
« Последнее редактирование: 23 Февраль 2010, 16:38:21 от ruPaladin »

Гарри Кашпировский

  • Гость
Re: Нет ответа на PPP Lcp echo-request
« Ответ #6 : 23 Февраль 2010, 16:45:52 »
Случайно не пользуюсь :) У меня роутер/шлюз-NAS. Поэтому всякие Нетворк менеджеры - лишнее.
Пока решил это костылём
!/bin/sh
while:;do
date=`/bin/date '+%d-%m-%Y %H:%M'`
logfile=/home/user/logs/netlog.log
checkip=`ping -c 3 93.158.134.8 |grep icmp_seq |wc -l`

if [ ! $checkip = 3 ]; then
  /etc/init.d/vpn restart
  echo "=============================" >>$logfile
  echo "Link failed at [ $date ] . Reconnect link.">>$logfile
fi
sleep 30
done
Да похоже видно что проблема в провайдере, отвалы учащаються ближе к вечеру в ЧНН...

 

Страница сгенерирована за 0.059 секунд. Запросов: 22.