Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: настройка Ati x1600 в Ubuntu 9.10  (Прочитано 3168 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DjUm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
настройка Ati x1600 в Ubuntu 9.10
« : 24 Февраль 2010, 14:20:39 »
В общем у меня стоит видеокарта Ati x1600. Проблема в том что она не поддерживается. Поискав по форумам конкретного решения я так и не нашел :-\ Вот если подскажите будет хорошо. НЕ а если нет  :idiot2: поеду на ubuntu 8.04 :'(

Оффлайн s†ranger

  • Активист
  • *
  • Сообщений: 319
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #1 : 24 Февраль 2010, 14:51:17 »
Если с ней не работают проприетарные драйвера ATI, то должны неплохо работать свободные. Сразу после установки. Дополнительно устанавливать ничего не нужно.

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #2 : 24 Февраль 2010, 14:54:36 »
Цитировать
В общем у меня стоит видеокарта Ati x1600. Проблема в том что она не поддерживается.
Открытыми драйверами поддерживается.
Цитировать
Поискав по форумам конкретного решения я так и не нашел
А что искал-то?
Цитировать
Вот если подскажите будет хорошо.
Ты не написал чего ты хочеш.
xUbuntu 12.04

Оффлайн DjUm

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #3 : 24 Февраль 2010, 15:28:40 »
Если с ней не работают проприетарные драйвера ATI, то должны неплохо работать свободные. Сразу после установки. Дополнительно устанавливать ничего не нужно.

да нет проприетарных(  В 8.04 были, а здесь нет. В игру зайдешь лагает, эфекты не ставяться >:(

Пользователь решил продолжить мысль 25 Февраль 2010, 18:41:15:
:( тут есть кто вообще? :idiot2:
« Последнее редактирование: 25 Февраль 2010, 18:41:15 от DjUm »

Оффлайн VNarkom

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #4 : 06 Апрель 2010, 13:01:05 »
Если с ней не работают проприетарные драйвера ATI, то должны неплохо работать свободные. Сразу после установки. Дополнительно устанавливать ничего не нужно.

да нет проприетарных(  В 8.04 были, а здесь нет. В игру зайдешь лагает, эфекты не ставяться >:(

Пользователь решил продолжить мысль 25 Февраль 2010, 16:41:15:
:( тут есть кто вообще? :idiot2:


Прости что поздно сообщаю я просто редко нахожусь сдесь. НО последний инсталлер прориеритарных драйверов для X1600 который я качал сказал что сможет поставиться только на Ubuntu 9,04, чуть порыскав я нашел а Синаптике radeonhd установил но так покачто и не дошел до установки игр :), как только поставлю то обязательно отпишусь, если ты этого не сделаеш раньше, либо если ты уже ненашел этого решения, но если нашел решение Ubuntu 9.10 + x1600 то я с удовольствием его выслушаю.

добавлюсь при скачке, обратил внимание что дрова идут на xorg 7.04.

Если я неошибаюсь то скорее всего попробывать перелесть с Х11 на Х7.04.
p.s. помоему задача геморойная но, цель поставлена надо попробывать :)
« Последнее редактирование: 10 Апрель 2010, 18:57:47 от VNarkom »

Оффлайн temayef

  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
    • Я на Фишап
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #5 : 06 Апрель 2010, 13:28:05 »
Телепаты подсказывают, что автору темы не хватает поддержки OpenGL. Происходит сие потому, что проприетарные драйвера, поддерживающие OpenGL, не поддерживают X1600, а свободные драйвера, поддерживающие X1600, не поддерживают OpenGL.

Автору: тема была перетерта до однородной безволокнистой кашицы множество раз на форуме, поиск лишил бы Вас необходимости поторапливать других членов сообщества с ответом для Вас. Ко всему прочему, пакеты в репозиториях (это то самое место, где Вы можете найти свободные драйвера), да и установщики проприетарных драйверов имеют описание, где написано множество полезных вещей.
Нетбук: Windows XP Pro @ Asus Eee 900SD
Ноутбук: Ubuntu 10.04 LTS @ LG S1-P555R / Windows Vista @ Packard Bell Horus G
Смартфон: Windows Mobile 6.1 @ Sitronics SDC-106

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #6 : 06 Апрель 2010, 13:31:36 »
Цитировать
а свободные драйвера, поддерживающие X1600, не поддерживают OpenGL.
Не правда.
xUbuntu 12.04

Оффлайн temayef

  • Любитель
  • *
  • Сообщений: 74
    • Просмотр профиля
    • Я на Фишап
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #7 : 08 Апрель 2010, 13:16:30 »
Цитировать
а свободные драйвера, поддерживающие X1600, не поддерживают OpenGL.
Не правда.
Ну по крайней мере 3D.
Нетбук: Windows XP Pro @ Asus Eee 900SD
Ноутбук: Ubuntu 10.04 LTS @ LG S1-P555R / Windows Vista @ Packard Bell Horus G
Смартфон: Windows Mobile 6.1 @ Sitronics SDC-106

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #8 : 08 Апрель 2010, 14:41:44 »
Цитировать
а свободные драйвера, поддерживающие X1600, не поддерживают OpenGL.
Не правда.
Ну по крайней мере 3D.
https://forum.ubuntu.ru/index.php?topic=70977.msg543767#msg543767
xUbuntu 12.04

Оффлайн digitaltripper

  • Новичок
  • *
  • Сообщений: 2
  • Всегда онлайн!
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #9 : 08 Апрель 2010, 22:13:14 »
у меня тоже x1600

проблема решилась сама следующим образом:
изначально устанавливал систему на файловую систему ext4 Ubuntu не хотела работать правильно с видеокартой
затем переустановил систему на файловую систему ext3 и о чудо! видюха распозналась корректно, вдобавок ко всему и дополнительный экран... теперь радуюсь нармальным разрешениям 1280х800 и 1360х768 :) и игрухи не тупят
Mess with the best - die like the rest!

Оффлайн Упс

  • Старожил
  • *
  • Сообщений: 3231
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #10 : 08 Апрель 2010, 22:26:44 »
у меня тоже x1600

проблема решилась сама следующим образом:
изначально устанавливал систему на файловую систему ext4 Ubuntu не хотела работать правильно с видеокартой
затем переустановил систему на файловую систему ext3 и о чудо! видюха распозналась корректно, вдобавок ко всему и дополнительный экран... теперь радуюсь нармальным разрешениям 1280х800 и 1360х768 :) и игрухи не тупят
Возможно это совпадение, в прошлом году эксперементировал с radeon 9600 и 32 битной Ubuntu, загружал с liveCD с разными настройками, иногда видеокарта распознавалась иногда нет. Так и не понял в чём проблема, на 64 битной проблем вообще не было. Наверное фазы луны или расположение звёзд.. :)
xUbuntu 12.04

Оффлайн VNarkom

  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #11 : 11 Апрель 2010, 13:28:20 »
Сам долго парился и вот нарыл:
Статья -
---------------------------------------------------------------------------------------------
На Ubuntu 9.04 Старый драйвер ATI (до версии 9.3 включительно) не будет работать, так как не поддерживает xorg-xserver 1.6. Новый драйвер откажется работать, так как не поддерживает саму видеокарту. Единственный способ использования старых драйверов – это «даунгрейд» X-сервера. Сделать это не сложно:

Внимание! Потребуется соединение с Интернетом!

Для начала сделаем backup “sources.list”:

sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak

Теперь открываем оригинальный “sources.list” и меняем все репозитории jaunty на репозитории intrepid. Это легко сделать с помощью Gedit.

sudo gedit /etc/apt/sources.list

С помощью Gedit заменяем все имеющиеся слова jaunty на intrepid.

Далее в терминале пишем:

sudo apt-get update

Удаляем Х-сервер:

sudo apt-get autoremove xserver-xorg

Теперь можно приступать к переустановке X-сервера и установке ATI драйвера:

sudo apt-get install xserver-xorg fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx libdrm2=2.3.1-0build1

Когда установка закончится, откройте Менеджер пакетов Synaptic и заблокируйте (Пакет > Заблокировать версию) текущие версии пакетов (все пакеты можно найти поиском), чтобы они больше не обновлялись:

xserver-xorg*, fglrx*, xorg-driver-fglrx, libdrm2

Убедитесь, что заблокированы все пакеты. Их 45.

Следующий, заключительный шаг, замена “sources.list” на оригинальный:

sudo cp /etc/apt/sources.list.bak /etc/apt/sources.list

Перезагружаемся.

После перезагрузки убедитесь, что новый драйвер задействован (Администрирование > Драйверы устройств). Если драйвер не активен, задействуйте его и снова перезагружаемся.

Всё!
Тестировалось на видеокарте ATI Radeo 9600.
-----------------------------------------------------------------------------------

от себя могу добавить проверил на ATI Radeo Х1600. Все работает!. :)

С 9,10 еще не пробывал но может прокатить.
А Сама проблема скорее всего в том что гдето в этом диапозоне выпуска видеокарт фирма Ati перестала быть независимой фирмой, и стала AMD.ATI, а обновлять дорова для железа которое не AMD.ATI а прото ATI фирма наверное сочла ненужной задачей.
« Последнее редактирование: 11 Апрель 2010, 13:33:00 от VNarkom »

Оффлайн Кунни

  • Активист
  • *
  • Сообщений: 418
  • мил и пушист
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #12 : 11 Апрель 2010, 13:56:12 »
Господа, ждём Ubuntu 10.04 - там должна быть поддержка со стороны ядра, модуль kms.
З.Ы. У меня Х1950
Пытаюсь отучить людей использовать фразу "не суть важно" (вместо "не суть", "не важно" или "не столь важно")

Оффлайн Chupik

  • Новичок
  • *
  • Сообщений: 43
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #13 : 11 Апрель 2010, 18:56:10 »
Господа, ждём Ubuntu 10.04 - там должна быть поддержка со стороны ядра, модуль kms.
З.Ы. У меня Х1950
А вот с этого места по-подробней  :) Поддержка чего? Каких видеокарт (у меня древний radeon 9550)?

Оффлайн Кунни

  • Активист
  • *
  • Сообщений: 418
  • мил и пушист
    • Просмотр профиля
Re: настройка Ati x1600 в Ubuntu 9.10
« Ответ #14 : 11 Апрель 2010, 22:28:43 »
А вот с этого места по-подробней  :) Поддержка чего? Каких видеокарт (у меня древний radeon 9550)?
Ну я если честно не очень в этом разбираюсь, но как я понял, 32-ая ветка ядер содержит модуль kms, который улучшает работу со старыми радеоновскими карточками. Появляется более вменяемое три-дэ.
Но я не теоретик, я практик ) Что я пробовал:
1. Врубил этот модуль на текущем ядре (https://forum.ubuntu.ru/index.php?topic=13952.msg593964#msg593964)
В итоге улучшились эффекты компиза (я о них и не подозревал), в частности водичка.
ПРЕДУПРЕЖДЕНИЕ: проверялось на карте Х1950 (хотя в случае неудачи все изменения откатываются в одну команду)

2. Скачивал ядра из ветки 32 и даже 33 - поиграл в контру (опенГЛ), опять же эффекты компиза, на текущем ядре контра не идет (идет, но очень тормозит)

По приведенной выше ссылке почитайте, там я вроде что-то более внятное о кмс писал.
Пытаюсь отучить людей использовать фразу "не суть важно" (вместо "не суть", "не важно" или "не столь важно")

 

Страница сгенерирована за 0.061 секунд. Запросов: 22.