Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Wi-Fi на нетбуке Lenova S10-2  (Прочитано 2968 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн adidas

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
    • Просмотр профиля
Wi-Fi на нетбуке Lenova S10-2
« : 26 Февраль 2010, 11:54:34 »
Всем доброго времени суток
проблема в следующем
Ubuntu 9.10 - Karmic Koala
есть нетбук Lenova S10-2 на 1кнопке забита функция вайфая и саблезуба (функция +ф5)
так вот
установил сначало нетбук ремикс  - ни вайфай ни бутуз не заработали (не горел индикатор ни того ни другого)а потом переустановил на 9.10 - ситуация такаяже
сетевка вайфай BCV-43XX
вроде и дрова стоят норм но сеть не находит - пробовал руками создать и подключиться - бесполезно
у кого может такой же нетбук - как у вас все работает?
жду помощи - т.к. дома тока вайфай можно юзать

при запуске драйвера устройсв пишет что есть такое
These package contains Broadcom 802.11 Linux STA wireless driverfor use with Broadcom's BCM4311-, BCM4312-, BCM4321-, andBCM4322-based hardware.
и ниже
этот драйвер активирован но не испльзуется в настоящее время

хелпм ми народ - вайфай очень нужен


и еще добился этого  - теперь видно что работает вайфай - носаму сеть - точку доступа не видит
мдя... за целый день так ни кто и не ответил в данный топик

Пользователь решил продолжить мысль 27 Февраль 2010, 06:41:57:
максимум что я смог добиться так вот это
root@ubuntu:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any 
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Bit Rate:54 Mb/s   Tx-Power:32 dBm   
          RTS thr:2347 B   Fragment thr:2346 B   
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sudo iwlist wlan0 scan
wlan0     No scan results


root@ubuntu:~# modprobe b43
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.

root@ubuntu:~# lsmod|grep b43
b43                   229640  0
ssb                    49476  1 b43
pcmcia                 36808  2 b43,ssb
mac80211              229740  1 b43
cfg80211              146984  2 b43,mac80211
led_class               4096  1 b43
compat_firmware_class     8804  1 b43


lsmod|grep b43
b43                   229640  0
ssb                    49476  1 b43
pcmcia                 36808  2 b43,ssb
mac80211              229740  1 b43
cfg80211              146984  2 b43,mac80211
led_class               4096  1 b43
compat_firmware_class     8804  1 b43
root@ubuntu:~# modprobe -l|grep 43 && modprobe -l|grep ndis
kernel/fs/nls/nls_cp437.ko
kernel/drivers/video/backlight/vgg2432a4.ko
kernel/drivers/media/video/tda7432.ko
kernel/drivers/staging/comedi/drivers/adl_pci7432.ko
kernel/drivers/w1/slaves/w1_ds2431.ko
kernel/drivers/w1/slaves/w1_ds2433.ko
updates/drivers/net/wireless/b43/b43.ko
updates/drivers/net/wireless/b43legacy/b43legacy.ko
kernel/ubuntu/ndiswrapper/ndiswrapper.ko
updates/drivers/net/wireless/rndis_wlan.ko
updates/drivers/net/usb/rndis_host.ko


lspci -vvnn | grep 14e4
02:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g [14e4:4315] (rev 01)
   Subsystem: Broadcom Corporation Device [14e4:04b5]




Пользователь решил продолжить мысль 27 Февраль 2010, 11:24:19:
root@ubuntu:/etc/network# sudo lshw -C network
  *-network               
       description: Wireless interface
       product: BCM4312 802.11b/g
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:26:82:01:71:b6
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.55+Broadcom,09/10/2008, 5.10.3 latency=0 link=no multicast=yes wireless=IEEE 802.11g
       resources: irq:17 memory:56100000-56103fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 02
       serial: 00:26:22:03:61:68
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.0.62 latency=0 link=yes multicast=yes port=MII speed=100MB/s
       resources: irq:29 ioport:2000(size=256) memory:52010000-52010fff(prefetchable) memory:52000000-5200ffff(prefetchable) memory:52020000-5203ffff(prefetchable)
« Последнее редактирование: 27 Февраль 2010, 11:24:20 от adidas »

Оффлайн adidas

  • Автор темы
  • Новичок
  • *
  • Сообщений: 29
    • Просмотр профиля
Re: Wi-Fi на нетбуке Lenova S10-2
« Ответ #1 : 02 Март 2010, 08:51:48 »
Ну  вот, хочу теперь поделиться своим опытом с танцами с бубном на счет Wi-Fi  на своем нетбуке.
суть заклюалось в том то после установки системы и обновлении и активации всех проприетарных драйверов ни как не могла сетевая найти точку доступа - и вроде конфиге показывает что она присутствует а все же ни как. Потом заметил что индикатор вай-фая не горит и все мои попытки включить индикатор ни к чему не привели - стал копать в ту сторону  чтобы активировать индикатор (соответственно при загоревшей лампочке должна была подняться сеть)
на это ушло у меня 2дня, на дню замучивал Ubuntu по3-5 раз. доводил до полного зависания и отказа грузиться, ставил сного и мучал (т.к. я всего лишь новичок и все курил маны и откатываться плохо умею - мне проще было заного все поставить). И вот в одну тихую ночь затрахало меня все я выключил свой нетбук и вспомнил что есть у меня на яндекс почте срочное письмо, грузиться не хотел в систему ни какую (Ubuntu и ХР по умолчанию стояло)и у видев на панельке клавишу  QS (квик старт) решил попробовать что за ерунда  - ткнул - запустилась панелька с експлоером, аськой, скайпом, чем то еще - смотрю есть правее настройки сети  - и вай-фай мой опять не горить и не пашет - жму Функция + моя кланвиша фай-фай - -ОПА - загорелся индикатор (кстати этот квик старт не грузит операционки ни какие а работает под своей оболочкой) - Опа и вай-фай поднялся - И ТУТ ЗАКРАЛОСЬ В МОЮ ДУШОНКУ ТАКАЯ ВЕСЧЬ, а что если счас тыкнуть кнопку выйти в операционку и выбрать Ubuntu - делаю - и опа !!! я в убунте с поднятым вайфаем!!!все работает! лампочка горит - сеть найдена все работает! - делаю контроьные 100 раз ребуты! о ЧУДО! счас тливый выключаю небук и иду спать.
утром врубаю бук, Ubuntu -ЧЕРТ! нет вай-фая! делаю -QS-выходв в Ubuntu - РАБОТАЕТ!
ВЫВОД: после входа в QS  и выхода в Ubuntu можно заребутиться до смерти все работает, Но как выключил бук - все - повтор входа иначе не работает вай-фай.

хоть я и нашел такой способ входа  - зато работает, если кто и подскажет как теперь кнопкой активировать без такого геморойдного входа - буду рад!

всем удачи

Оффлайн SGB

  • Участник
  • *
  • Сообщений: 129
    • Просмотр профиля
    • Компьютерные записки
Re: Wi-Fi на нетбуке Lenova S10-2
« Ответ #2 : 02 Март 2010, 12:31:23 »
Оригинально :coolsmiley:
Поздравляю. Есть еще один способ - эксперементировать с лайф сд. На него тоже моно ставить покеты, забыл тебе тогда сказать
Все вопросы сюда :
Skype: sgb.82;  icq: 77338044 - тут редко; jabber: Gleb.Sorokin[собака]gmail.com | sorokinlinux[собака]ya.ru
blog: http://comnote.blogspot.com/

Оффлайн SergeySA4ok

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
Re: Wi-Fi на нетбуке Lenova S10-2
« Ответ #3 : 06 Апрель 2010, 19:48:47 »
у меня на таком ж ноуте после установки дров все нормально заработало. дрова оно мне само предложило установить. правда я еще дня 2 думал что не помогло т.к. в убунте не шарю.. врубил через неоторое время защелку, и при клике на сеть выдало на пару строчек больше чем раньше. вот пашет пару месяцев без проблем. с s10-2 через wifi сейчас это и пишу.

 

Страница сгенерирована за 0.12 секунд. Запросов: 22.