Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Установка Apache 1.3 в UBUNTU 9.10  (Прочитано 3348 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Arlevnar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • marlevnar.ru
Установка Apache 1.3 в UBUNTU 9.10
« : 01 Март 2010, 11:35:31 »
Доброго времени суток.

 Помогите пожалуйста в установке Apache 1.3.42, понимаете при попытке установить
 по manual http://httpd.apache.org/docs/1.3/install.html#apaci система выдаёт мне
 такую информацию:
   onfiguring for Apache, Version 1.3.42
 + Warning: Your 'echo' command is slightly broken.
 + It interprets escape sequences per default. We already
 + tried 'echo -E' but had no real success. If errors occur
 + please set the SEO variable in 'configure' manually to
 + the required 'echo' options, i.e. those which force your
 + 'echo' to not interpret escape sequences per default.

 + NOTE: You may also need to edit the shell invoked by
 +       'configure'. Some shells (e.g. dash) have a
 +       faulty echo builtin.
 + using installation path layout: Apache (config.layout)
configure:Error: invalid option '--prefix'
 

 Логически, система должна создать файл makefile c помощью которого
 далее идёт обращение к утилите make. Но в итоге при обращении к:
 make install
 
 Система мне выдаёт сообщение:
 
Цитировать
make: *** Нет правила для сборки цели `install'.  Останов.
Мой вывод что Makefile формируется не корректно.
 
  ЧТО ДЕЛАТЬ ???  HELP  ME  PLEASE !!!

 p.s.
    Огромная просьба не напоминать в лишний раз что установить
    Apache можно подругому без головной боли при помощи Центра приложений UBUNTU
    или при помощи SYNAPTIC. И тот и другой вариант мне не подходит.    :coolsmiley:

Спасибо.
Закрой глаза. Ты видишь что нибудь? Нет ? Тогда тебе не понять квадрат Малевича...

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #1 : 01 Март 2010, 11:57:36 »
configure:Error: invalid option '--prefix'
Говорит о том, что не правильно вызываешь ./configure

Оффлайн Arlevnar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • marlevnar.ru
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #2 : 01 Март 2010, 12:06:45 »
А как же его вызывать то тогда делаю всё по инстркции(
Каталог apache у меня находится в opt/apache

Как мне эту команду набрать?
Закрой глаза. Ты видишь что нибудь? Нет ? Тогда тебе не понять квадрат Малевича...

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #3 : 01 Март 2010, 12:28:57 »
Скрипт глючит. Поменяй в его заголовке #!/bin/sh на #!/bin/bash

Оффлайн Arlevnar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • marlevnar.ru
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #4 : 01 Март 2010, 12:44:21 »
Думаешь поможет?
Закрой глаза. Ты видишь что нибудь? Нет ? Тогда тебе не понять квадрат Малевича...

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #5 : 01 Март 2010, 12:50:58 »
Я не с потолка взял это. Сам попробовлал.

Оффлайн Arlevnar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • marlevnar.ru
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #6 : 01 Март 2010, 12:57:24 »
Мужик ты мой герой)))  :D
Слушай а если можно поведай что обозначает bash?
Я только с WINDOWS свалился)
Закрой глаза. Ты видишь что нибудь? Нет ? Тогда тебе не понять квадрат Малевича...

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #7 : 01 Март 2010, 12:58:53 »
Интерпретатор комманд. http://ru.wikipedia.org/wiki/Bash

Оффлайн Arlevnar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • marlevnar.ru
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #8 : 01 Март 2010, 13:25:51 »
Извини Бога ради но дальше когда я набираю:
 make install
Мне выдаёт вот это вот сообщение:
  god@arlevnar:/opt/apache$ sudo make install
make[1]: Вход в каталог `/opt/apache'
===> src
make[2]: Вход в каталог `/opt/apache'
make[3]: Вход в каталог `/opt/apache/src'
===> src/regex
make[4]: Цель `all' не требует выполнения команд.
<=== src/regex
===> src/os/unix
make[4]: Цель `all' не требует выполнения команд.
<=== src/os/unix
===> src/ap
make[4]: Цель `all' не требует выполнения команд.
<=== src/ap
===> src/main
make[4]: Цель `all' не требует выполнения команд.
<=== src/main
===> src/lib
===> src/lib/expat-lite
make[5]: Цель `all' не требует выполнения команд.
<=== src/lib/expat-lite
<=== src/lib
===> src/modules
===> src/modules/standard
make[5]: Цель `all' не требует выполнения команд.
<=== src/modules/standard
<=== src/modules
gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DUSE_HSREGEX -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci` modules.c
gcc -c  -I./os/unix -I./include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DUSE_HSREGEX -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci` buildmark.c
gcc  -DLINUX=22 -DHAVE_SET_DUMPABLE -DUSE_HSREGEX -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci`    \
      -o httpd buildmark.o modules.o modules/standard/libstandard.a main/libmain.a ./os/unix/libos.a ap/libap.a regex/libregex.a lib/expat-lite/libexpat.a   -lm -lcrypt
 make[3]: Выход из каталога `/opt/apache/src'
 make[2]: Выход из каталога `/opt/apache'
 make[2]: Вход в каталог `/opt/apache'
 ===> src/support
 make[3]: Вход в каталог `/opt/apache/src/support'
 gcc -c  -I../os/unix -I../include   -DLINUX=22 -DHAVE_SET_DUMPABLE -DUSE_HSREGEX -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED  `../apaci` htpasswd.c
 htpasswd.c:101: error: conflicting types for ‘getline’
 /usr/include/stdio.h:651: note: previous declaration of ‘getline’ was here
 make[3]: *** [htpasswd.o] Ошибка 1
 make[3]: Выход из каталога `/opt/apache/src/support'
 make[2]: *** [build-support] Ошибка 1
 make[2]: Выход из каталога `/opt/apache'
 make[1]: *** [build] Ошибка 2
 make[1]: Выход из каталога `/opt/apache'
 make: *** [install-all] Ошибка 2

Система установки не может найти каких ей необходимых файлов, для дальнейшей установки?
Или я неправ? Извини за назойливость...
« Последнее редактирование: 01 Март 2010, 13:31:28 от Arlevnar »
Закрой глаза. Ты видишь что нибудь? Нет ? Тогда тебе не понять квадрат Малевича...

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #9 : 01 Март 2010, 13:47:02 »
Это еще не установка. Пока сборка из исходников идёт.

А ошибка из за несовместимости. Сделай for file in src/support/*.c; do sed -i s/getline/mygetline/ $file; done  из корневого каталога сырцов апача, там, где configure. Это заменит имя конфликтующей функции getline() на mygetline()

Оффлайн Arlevnar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • marlevnar.ru
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #10 : 01 Март 2010, 14:06:10 »
Извини но я нечего не понял) Можно для тугих...?)  :-[
Закрой глаза. Ты видишь что нибудь? Нет ? Тогда тебе не понять квадрат Малевича...

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #11 : 01 Март 2010, 14:23:55 »
Команду дай эту:
for file in /opt/apache/src/support/*.c; do sed -i s/getline/mygetline/ $file; done

Оффлайн Arlevnar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • marlevnar.ru
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #12 : 01 Март 2010, 14:25:37 »
Опять выдал ошибку:
bash: ошибка синтаксиса около неожиданной лексемы `do'
Закрой глаза. Ты видишь что нибудь? Нет ? Тогда тебе не понять квадрат Малевича...

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #13 : 01 Март 2010, 14:47:17 »
Скопировал её копипастой в терминал или ручками вводил? У меня работает.

Если не получится, то меняй ручками во всех файлах .c, которые в /opt/apache/src/support имя функции getline на mygetline.

Оффлайн Arlevnar

  • Автор темы
  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
    • marlevnar.ru
Re: Установка Apache 1.3 в UBUNTU 9.10
« Ответ #14 : 01 Март 2010, 14:55:28 »
Когда ввожу строку которую ты мне дал он не даёт изменить из группы доступа:

god@arlevnar:/opt/apache$ for file in /opt/apache/src/support/*.c; do sed -i s/getline/mygetline/ $file; done
sed: невозможно открыть временный файл /opt/apache/src/support/sedznYEXr: Permission denied
sed: невозможно открыть временный файл /opt/apache/src/support/sedcZZPis: Permission denied
sed: невозможно открыть временный файл /opt/apache/src/support/sedJNvjes: Permission denied
sed: невозможно открыть временный файл /opt/apache/src/support/sedEa7m6p: Permission denied
sed: невозможно открыть временный файл /opt/apache/src/support/seddchgBq: Permission denied
sed: невозможно открыть временный файл /opt/apache/src/support/sed0AHLQq: Permission denied
sed: невозможно открыть временный файл /opt/apache/src/support/sedBj5RMq: Permission denied


А когда так под root;
god@arlevnar:/opt/apache$ sudo for file in /opt/apache/src/support/*.c; do sed -i s/getline/mygetline/ $file; done
bash: ошибка синтаксиса около неожиданной лексемы `do'
« Последнее редактирование: 01 Март 2010, 14:58:14 от Arlevnar »
Закрой глаза. Ты видишь что нибудь? Нет ? Тогда тебе не понять квадрат Малевича...

 

Страница сгенерирована за 0.06 секунд. Запросов: 23.