Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: отвалился gimp 2.7  (Прочитано 1430 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Xiber

  • Автор темы
  • Любитель
  • *
  • Сообщений: 94
  • maemo4 user
    • Просмотр профиля
отвалился gimp 2.7
« : 03 Март 2010, 16:15:55 »
как я понял, недавнее обновление всё поломало

$gimp
gimp: symbol lookup error: /usr/local/lib/libgegl-0.1.so.0: undefined symbol: babl_total_usecs

пробовал всё сносить, включая babl и gegl
и ставить по новой - не помогло

пакеты из ppa

Настраивается пакет libgimp2.0 (2.7.3-2010022601~kk) ...

Настраивается пакет gimp-data (2.7.3-2010022601~kk) ...
Настраивается пакет libbabl-0.0-0 (0.1.3-2010020905~kk) ...

Настраивается пакет libgegl-0.0-0 (0.1.2.3-2010022603~kk) ...

Настраивается пакет gimp (2.7.3-2010022601~kk) ...

Оффлайн nick87720z

  • Участник
  • *
  • Сообщений: 167
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #1 : 03 Март 2010, 16:37:44 »
Вы gegl из сорцов компилировали? и babl и gimp?
Выполните sudo ldconfig
Если не поможет, удалите сорцовый и ставьте из репов. В ubuntu-tweak можно включить репу на этот gimp.

Оффлайн Xiber

  • Автор темы
  • Любитель
  • *
  • Сообщений: 94
  • maemo4 user
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #2 : 03 Март 2010, 18:45:48 »
из того самого репозитория пакеты

откатился пока на 2.6
полёт нормальный
но без mdi интерфейса с вкладками уже не так уютно (((

Оффлайн nick87720z

  • Участник
  • *
  • Сообщений: 167
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #3 : 03 Март 2010, 21:03:26 »
Нет, вы точно что-то компилили. Удалите накомпиленное.
Если сорцы gegl не сохранились, можно просто удалить файл и выполнить ldconfig.
Только что проверял в карме, все нормально.

Оффлайн Xiber

  • Автор темы
  • Любитель
  • *
  • Сообщений: 94
  • maemo4 user
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #4 : 03 Март 2010, 22:33:52 »
Вы оказались правы, в /usr/local/lib/ было неприлично много разных libgegl

Оффлайн svp

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #5 : 06 Март 2010, 16:52:04 »
не стал создавать новую тему, у меня вот такая проблема, решил поставить gimp 2.7 удалил 2.6 после чего скачал пакеты и установил, но он не заработал, решил откатиться на 2.6 установил, запускаю в терминале пишет gimp-2.6: error while loading shared libraries: libgegl-0.0.so.0: cannot open shared object file: No such file or directory что делать и где взять?
libgegl-0.0-0 установлен, но толку ноль
« Последнее редактирование: 06 Март 2010, 17:01:11 от svp »
ubuntu 9.10 asus x50n

Оффлайн pipe

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5546
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #6 : 06 Март 2010, 17:06:23 »
эм попробуйте его даунгрейдить чтоль  :-\

Оффлайн svp

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #7 : 06 Март 2010, 17:14:10 »
В смысле обновить!? Дак и это делал
ubuntu 9.10 asus x50n

Оффлайн pipe

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5546
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #8 : 06 Март 2010, 17:19:04 »
в смысле запустить синаптик поиском найти libgegl-0.0-0 пкм по нему, свойства-версии- и выбрать другую
при обновлении гимпа она наверное обновилась  :-\

Оффлайн svp

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #9 : 06 Март 2010, 17:24:57 »
в смысле запустить синаптик поиском найти libgegl-0.0-0 пкм по нему, свойства-версии- и выбрать другую
при обновлении гимпа она наверное обновилась  :-\
да нет, все то стоит, я когда откат делал все удалил от новой версии, а может это быть из за гимпшопа?
ubuntu 9.10 asus x50n

Оффлайн pipe

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5546
    • Просмотр профиля
Re: отвалился gimp 2.7
« Ответ #10 : 06 Март 2010, 17:26:15 »
врятли он материться на отсутствие либы  :-

Пользователь решил продолжить мысль 06 Март 2010, 17:27:26:
https://bugs.launchpad.net/ubuntu/+source/gimp/+bug/510405

 

Страница сгенерирована за 0.056 секунд. Запросов: 22.