Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: проблеммы с QGRUBEditor  (Прочитано 1349 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Звонкий

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
проблеммы с QGRUBEditor
« : 06 Март 2010, 06:57:53 »
2 дня назад поставил ubuntu. Полет нормальный, При загрузке появляется много записей, хотел подкорректировать, поставил QGRUBEditor из deb архива, вроде установилась, но при загрузке появляется окно:

Warning
QGRUBEditor was unable to have read/write access to one of the following files:

/boot/grub/menu.lst
/boot/grub/device.map
/etc/mtab

This happened either because you haven't granted QGRUBEditor root permissions or because these files don't exist (maybe you accidentally deleted them?) QGRUBEditor will now try to automatically start the application with root permissions but it is not guaranteed that it will be successful. If it fails, you should try to manually run it with root permission using one of the following commands:

kdesu /usr/bin/qgrubeditor (if you use KDE)
gksu /usr/bin/qgrubeditor (if you use GNOME)
sudo /usr/bin/qgrubeditor (if you use any other Desktop Enviroment).

Что дальше делать не представляю. ПОМОГИТЕ!!!!

Оффлайн pipe

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5546
    • Просмотр профиля
Re: проблеммы с QGRUBEditor
« Ответ #1 : 06 Март 2010, 07:33:12 »

Оффлайн Звонкий

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: проблеммы с QGRUBEditor
« Ответ #2 : 06 Март 2010, 13:43:44 »
Специально для pipe:

QGRUBEditor не смог добиться на чтение / запись доступ к одной из следующих файлов:

/ BOOT / GRUB / menu.lst
/ BOOT / GRUB / device.map
/ ETC / mtab

Это происходит либо потому, что вы еще не выданные разрешения QGRUBEditor корня или потому, что эти файлы не существуют (возможно, вы случайно удалили их?) QGRUBEditor теперь будет пытаться автоматически запускать приложение с корнем разрешения, но это не гарантирует, что оно будет успешным . Если это не удается, попробуйте вручную запустить его с корнем разрешения с помощью одного из следующих команд:

kdesu / USR / BIN / qgrubeditor (если вы используете KDE)
gksu / USR / BIN / qgrubeditor (если вы используете GNOME)
Суда / USR / BIN / qgrubeditor (если вы используете любой другой Desktop Environment)

gksu / USR / BIN / qgrubeditor (если вы используете GNOME)- запускал, не помогло


Оффлайн pipe

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5546
    • Просмотр профиля
Re: проблеммы с QGRUBEditor
« Ответ #3 : 06 Март 2010, 14:11:09 »
запусти с терминала
sudo qgrubeditorесли матюкнется что неизвестная команда то так:
sudo /usr/bin/qgrubeditor
если опять выскачет это окошко ошибка или что там, скопируй все что будет в терминале сюда.

И да если я не ошибаюсь он со вторым грабом не дружит, а если у тебя ubuntu 9.10 то у тебя второй граб.

Оффлайн Звонкий

  • Автор темы
  • Новичок
  • *
  • Сообщений: 17
    • Просмотр профиля
Re: проблеммы с QGRUBEditor
« Ответ #4 : 06 Март 2010, 14:43:17 »
у меня 9.10. Не дружит. Спасибо за помощь. Есть такая же программа для граба 2. А то я с командами через терминал не очень дружен.

Оффлайн pipe

  • СуперМодератор
  • Старожил
  • *
  • Сообщений: 5546
    • Просмотр профиля
Re: проблеммы с QGRUBEditor
« Ответ #5 : 06 Март 2010, 14:46:48 »
Да не за что.
К сожалению я с грабом 2-ым мало знаком, но описания таких програм не встречал, на крайний случай граб всегда можно даунгрейдить, только задайся вопросом а оно тебе надо ?
Все настройки граба 2-ого описаны в этой теме: https://forum.ubuntu.ru/index.php?topic=74165.0

 

Страница сгенерирована за 0.058 секунд. Запросов: 24.