Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Пытался собрать Rhythmbox 0.12.7  (Прочитано 625 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DoublePain

  • Автор темы
  • Активист
  • *
  • Сообщений: 574
    • Просмотр профиля
Пытался собрать Rhythmbox 0.12.7
« : 22 Март 2010, 21:20:46 »
./configure
checking for RHYTHMBOX... configure: error: Package requirements (   gtk+-2.0 >= 2.16.0   glib-2.0 >= 2.18.0   gio-2.0 >= 2.18.0   gio-unix-2.0 >= 2.18.0  gnome-media-profiles >= 2.8   libsoup-2.4 >= 2.26.0   libsoup-gnome-2.4 >= 2.26.0) were not met:

No package 'gnome-media-profiles' found
No package 'libsoup-2.4' found
No package 'libsoup-gnome-2.4' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables RHYTHMBOX_CFLAGS
and RHYTHMBOX_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
По всей видимости не хватает библиотек, НО, gnome-media установлен, а другие либы фз откуда брать.
pain projection
Athlon II 620 x4 2.66GHz,4gb,Radeon HD4670 + Ubuntu 12.04 x64
Получено 2 845 kБ за 4с (666 kБ/c)

Оффлайн Motors

  • Активист
  • *
  • Сообщений: 682
  • снова ubuntu, уже нет
    • Просмотр профиля
    • motors
Re: Пытался собрать Rhythmbox 0.12.7
« Ответ #1 : 22 Март 2010, 21:22:00 »
а это?
gtk+-2.0 >= 2.16.0

Оффлайн DoublePain

  • Автор темы
  • Активист
  • *
  • Сообщений: 574
    • Просмотр профиля
Re: Пытался собрать Rhythmbox 0.12.7
« Ответ #2 : 22 Март 2010, 21:25:58 »
Ну мне не предлагает обновить gtk, в каком репозитории находится?
pain projection
Athlon II 620 x4 2.66GHz,4gb,Radeon HD4670 + Ubuntu 12.04 x64
Получено 2 845 kБ за 4с (666 kБ/c)

Оффлайн Motors

  • Активист
  • *
  • Сообщений: 682
  • снова ubuntu, уже нет
    • Просмотр профиля
    • motors
Re: Пытался собрать Rhythmbox 0.12.7
« Ответ #3 : 22 Март 2010, 21:30:15 »
а блин туплю, все нормально))

дык вот же они
http://packages.ubuntu.com/karmic/libsoup-gnome2.4-dev
http://packages.ubuntu.com/karmic/libsoup2.4-dev

Оффлайн DoublePain

  • Автор темы
  • Активист
  • *
  • Сообщений: 574
    • Просмотр профиля
Re: Пытался собрать Rhythmbox 0.12.7
« Ответ #4 : 22 Март 2010, 21:36:52 »
А вот теперь gnome-media-profiles найти не может, даже в packages.ubuntu.com %)
pain projection
Athlon II 620 x4 2.66GHz,4gb,Radeon HD4670 + Ubuntu 12.04 x64
Получено 2 845 kБ за 4с (666 kБ/c)

Оффлайн aliftin

  • Старожил
  • *
  • Сообщений: 1398
    • Просмотр профиля
Re: Пытался собрать Rhythmbox 0.12.7
« Ответ #5 : 22 Март 2010, 23:53:34 »
Кажется эти пакеты нужны:
libgnome-media-dev libsoup2.4-dev libsoup-gnome2.4-dev
Вообще на кой черт его собирать, есть же на launchpad-е.
Если мы не можем до чего то дотянуться, мы виним в этом не свой рост, не отсутствие табуретки, а свою цель.

 

Страница сгенерирована за 0.053 секунд. Запросов: 22.