Форум русскоязычного сообщества Ubuntu


Автор Тема: VPN. Идёт пинг, но сайты не открываются[РЕШЕНО].  (Прочитано 9110 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн uka17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Постараюсь придерживаясь рекомендаций изложить проблему:
У меня стоит Ubuntu 9.10, в наличие подключение в сеть, по dhcp автоматом поднимается сеть.
Перелазил весь гугл по настрйке VPN - везде копипаст одной и той же инструкции с незначительными изменениями.
Пытался настроить VPN по следующей схеме:
1) Поставил пакеты pptp-linux network-manager-pptp
2) Настроил соединение в соответствии с требования провайдера (если это можно назвать требованиями):
Выберите из списка «Point-to-Point Tunneling Protocol (PPTP)» и нажмите кнопку «Create».     
Connection Name — имя подключения.
Gateway — адрес VPN-сервера (vpn.zzzing.ru).
Username — номер счета.
Password — пароль.
Введите реквизиты подключения и нажмите кнопку «OK».

Т.е. ни о каких опциях и параметрах речи не шло - все галочки оставил как было.
Пробую коннектиться - соединение устанавливается без проблем, но сайты не открываются. Хотя (!) пинг до любого узла ходит на ура. Сначала подозрение пало на то, что что-то с DNS не то, но потом выяснилось вот что.
3) Ставлю kvpnc, настраиваю по подобию инструкции, с небольшими изменениями. А именно: в секции routes ставлю replace default routes и метод авторизации ставлю CHAP.  Конект - всё работает, сайты открываются, пинги ходят. Думаю, дело как раз в  replace default routes. При его отключении kvpnc перестаёт выдавать интернет.
4) Почему не оставить всё как есть? а) хочется разобраться до конца, б) kvpnc жутко неудобная штука по сравнению с тем же NM на мой взгляд.
Собственно вопрос - в чём может быть проблема?
« Последнее редактирование: 28 Март 2010, 09:24:12 от uka17 »

Оффлайн Sam Stone

  • Старожил
  • *
  • Сообщений: 1124
    • Просмотр профиля
Re: VPN. Идёт пинг, но сайты не открываются.
« Ответ #1 : 27 Март 2010, 11:24:21 »
Цитировать
Ставлю kvpnc, настраиваю по подобию инструкции, с небольшими изменениями. А именно: в секции routes ставлю replace default routes и метод авторизации ставлю CHAP
ты не поверишь, но нм тоже так может
16.04.1 4.4.0-59-generic x86_64 GNU/Linux

Оффлайн uka17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: VPN. Идёт пинг, но сайты не открываются.
« Ответ #2 : 27 Март 2010, 11:32:55 »
ты не поверишь, но нм тоже так может
в том то и дело, что выставляю для него те же опции: снимаю галочки со всех методов аутификации кроме CHAP и ставлю галочку "игнорировать маршруты, полученные автоматически". В итоге - пинг есть, сайтов нет.

Оффлайн sht0rm

  • Старожил
  • *
  • Сообщений: 3397
    • Просмотр профиля
Re: VPN. Идёт пинг, но сайты не открываются.
« Ответ #3 : 27 Март 2010, 11:37:20 »
в том то и дело, что выставляю для него те же опции: снимаю галочки со всех методов аутификации кроме CHAP и ставлю галочку "игнорировать маршруты, полученные автоматически". В итоге - пинг есть, сайтов нет.
А зачем игнорировать маршруты?

Оффлайн gjchancel

  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: VPN. Идёт пинг, но сайты не открываются.
« Ответ #4 : 27 Март 2010, 12:09:09 »
У меня была точно такая же проблема...я ее не решил так как во встроеном ВПН все таки где БАГ есть (мое мнение)...поключается нормально без ошибка(впн с коробки) но страничек не грузит - лажа это!! :(...А счет Kvpnc, не могу ничего плохого сказать уже 2 года пользуюсь...нормальная программа...но хотелось бы без него ....

Оффлайн Ivanivanoff

  • Участник
  • *
  • Сообщений: 118
    • Просмотр профиля
Re: VPN. Идёт пинг, но сайты не открываются.
« Ответ #5 : 27 Март 2010, 19:56:35 »
Тож такое было по умолчанию в VPN стояло MTU 1460 в других городах может оно и проходит а в Красноярске нет по совету с форума поставил MTU 576 у меня билайн

Гарри Кашпировский

  • Гость
Re: VPN. Идёт пинг, но сайты не открываются.
« Ответ #6 : 27 Март 2010, 20:24:37 »
Понижайте MTU до того, что бы странички могли открываться. Начните с 1460 :)

Оффлайн Sam Stone

  • Старожил
  • *
  • Сообщений: 1124
    • Просмотр профиля
Re: VPN. Идёт пинг, но сайты не открываются.
« Ответ #7 : 27 Март 2010, 21:31:26 »
uka17, в квпнц ты ставишь галочку ЗАМЕНИТЬ дефолтные маршруты, а в нм - ИГНОРИРОВАТЬ маршруты. Разницу чувствуешь?..
16.04.1 4.4.0-59-generic x86_64 GNU/Linux

Оффлайн uka17

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: VPN. Идёт пинг, но сайты не открываются.
« Ответ #8 : 28 Март 2010, 09:23:17 »
проблема решена понижением mtu до 1200.
спасибо Гарри Кашпировскому!

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.