Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: проблема с Apt-build  (Прочитано 4102 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ad_ward

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
проблема с Apt-build
« : 27 Март 2010, 21:04:14 »
   Делаю:
 sudo apt-build install aptoncd
   Выдает:
Вы должны заполнить sources.list, поместив туда URI источников пакетов
Unable to find source information for aptoncd at /usr/bin/apt-build line 482.

    В  /etc/apt/sources.list      содержится:
deb http://packages.linuxmint.com/ helena main upstream import
deb http://archive.ubuntu.com/ubuntu/ karmic main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ karmic-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ karmic-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ karmic partner
deb http://packages.medibuntu.org/ karmic free non-free
deb http://www.geekconnection.org/remastersys/repository karmic/
    Это по умолчанию (я здесь ничего не менял). Пробовал сделать:

 sudo dpkg --get-selections | awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list               Выдает:
bash: /etc/apt/apt-build.list: Permission denied
   Такого файла (apt-build.list)  в  /etc/apt  нет. Создал.Повторяю
  sudo dpkg --get-selections | awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list 
результат -тот же   -   bash: /etc/apt/apt-build.list: Permission denied
Помогите запустить   apt-build   (please)!

Оффлайн Protopopulus

  • Старожил
  • *
  • Сообщений: 1686
  • ちのう の きょうかん
    • Просмотр профиля
Re: проблема с Apt-build
« Ответ #1 : 27 Март 2010, 21:05:09 »
sudo apt-build update
Не? ???
Если ты владеешь знаниями, то и знания владеют тобой. (с) Protopopulus

Оффлайн Ad_ward

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: проблема с Apt-build
« Ответ #2 : 27 Март 2010, 22:12:53 »
sudo apt-build update
Не? ???
Неее...

Пользователь решил продолжить мысль 27 Март 2010, 22:26:25:
Что, у всех, кто ставил этот пакет не было таких проблем? Почему не срабатывает
sudo dpkg --get-selections | awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list     ?
« Последнее редактирование: 27 Март 2010, 22:26:25 от Ad_ward »

Оффлайн Protopopulus

  • Старожил
  • *
  • Сообщений: 1686
  • ちのう の きょうかん
    • Просмотр профиля
Re: проблема с Apt-build
« Ответ #3 : 27 Март 2010, 23:01:13 »
sudo dpkg --get-selections | awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list
sudo dpkg --get-selections | sudo awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list

Тоже не?
Если ты владеешь знаниями, то и знания владеют тобой. (с) Protopopulus

Оффлайн Ad_ward

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: проблема с Apt-build
« Ответ #4 : 27 Март 2010, 23:22:46 »

sudo dpkg --get-selections | sudo awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list

Тоже не?
Protopopulus salut! Ввел, результат:

bash: /etc/apt/apt-build.list: Permission denied
[sudo] password for adward:

ввел пароль, - никаких сообщений. Пробую
 sudo apt-build install opera                   результат-
opera will not be built because it doesn't have a source package.
Missing source package name for source_by_source().

Оффлайн фирэфохэ

  • Старожил
  • *
  • Сообщений: 2169
  • straightedge
    • Просмотр профиля
Re: проблема с Apt-build
« Ответ #5 : 28 Март 2010, 00:37:42 »
sudo dpkg --get-selections | sudo awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list
есть ещё ">" поэтому:
$ sudo su
# dpkg --get-selections | awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list
http://i18.ЗАПРЕЩЁННЫЙ РЕСУРС/big/2011/0325/6d/19eaa72dd24048a6fb0587832c4b096d.gif КДЕ - УГ. Дебиан - недоось.

Оффлайн Protopopulus

  • Старожил
  • *
  • Сообщений: 1686
  • ちのう の きょうかん
    • Просмотр профиля
Re: проблема с Apt-build
« Ответ #6 : 28 Март 2010, 01:56:19 »

sudo dpkg --get-selections | sudo awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list

Тоже не?
Protopopulus salut! Ввел, результат:

bash: /etc/apt/apt-build.list: Permission denied
[sudo] password for adward:

ввел пароль, - никаких сообщений. Пробую
 sudo apt-build install opera                   результат-
opera will not be built because it doesn't have a source package.
Missing source package name for source_by_source().

Ох лол... :2funny: Давно ли опера исходники раздает направо-налево?
Если ты владеешь знаниями, то и знания владеют тобой. (с) Protopopulus

Оффлайн Ad_ward

  • Автор темы
  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Re: проблема с Apt-build
« Ответ #7 : 28 Март 2010, 22:14:29 »
Ввел для пробы Оперу (что на ум пришло). Я понял , что ему нужны сырцы. Просто я думал,что apt-build устанавливает пакеты  типа apt-get , только на лету пересобирает их под свой проц (или пересобирает установленные).

Я в Linux ламер (удивляюсь,почему раньше не начал осваивать). 3 дня пытаюсь запустить apt-build - уже наворочал здесь ...
И голова пухнет. Пока отставлю. Если кто подскажет пошагово для чайника - буду очень благодарен.

Пользователь решил продолжить мысль 28 Март 2010, 22:24:11:
sudo dpkg --get-selections | sudo awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list
есть ещё ">" поэтому:
$ sudo su
# dpkg --get-selections | awk '{if ($2=="install") print $1}' > /etc/apt/apt-build.list
Спасибо - помогло. apt-build.list заполнен. Но временно перерыв ...
« Последнее редактирование: 28 Март 2010, 22:24:11 от Ad_ward »

Оффлайн gantellus

  • Старожил
  • *
  • Сообщений: 1276
    • Просмотр профиля
Re: проблема с Apt-build
« Ответ #8 : 28 Март 2010, 23:44:32 »
не понятно, зачем тебе apt-build, если есть apt-get

маловато у тебя опыта будет разобраться

подсказываю - оно умеет собирать из только тех исходников, которые есть в наличии

опера - закрытый продукт, исходных кодов в свободном доступе нет.
Придумайте ещё более дружественный интерфейс, и мир породит ещё более тупого юзера (с)
С2Duo 2.4 Ghz, Geforce 8800, Maya 44 PCI

Оффлайн dimas000

  • Старожил
  • *
  • Сообщений: 1437
  • Ubuntu 9.10 @ 2.6.34
    • Просмотр профиля
Re: проблема с Apt-build
« Ответ #9 : 29 Март 2010, 03:29:48 »
мб, надо репы типа "deb-src", коли уж речь о сборке?
ЗЫ. это как предположение, тапками не кидайтесь))
лучше на "ты"

 

Страница сгенерирована за 0.061 секунд. Запросов: 23.