Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Неправильно запускается из скрипта  (Прочитано 241 раз)

0 Пользователей и 1 Гость просматривают эту тему.

nigametianov

  • Автор темы
  • Гость
Не знаю куда писать, поэтому здесь
такой скрипт
(Нажмите, чтобы показать/скрыть)
при запуске из терминала все ОК, (веб морда открывается на порту 9092)
если добавляю его в автозапуск, то как будто выполнил такой скрипт
(Нажмите, чтобы показать/скрыть)
(веб морда открывается на порту 9091, и не прокатывают логин-пароль)

Подскажите в чем причина :idiot2:

Оффлайн ende_neu

  • Старожил
  • *
  • Сообщений: 2473
    • Просмотр профиля
Re: Неправильно запускается из скрипта
« Ответ #1 : 29 Март 2010, 19:09:21 »
Куда в "автозапуск"?Наверное тильду не надо ставить, а указывать полный путь.

nigametianov

  • Автор темы
  • Гость
Re: Неправильно запускается из скрипта
« Ответ #2 : 29 Март 2010, 19:13:56 »
 :idiot2: :idiot2: :idiot2: :idiot2:
Все разобрался, надо СОХРАНИТЬ нажимать ....  :2funny:
Сначала в запускаемые приложения добавил transmission-daemon  --config-dir ~/.config/transmission
оно не работало, потом написал сей скрипт и отредактировал автозапуск и, видимо, сохранить не нажал
Цитировать
Наверное тильду не надо ставить, а указывать полный путь.
А тильда - удобно, когда не нужна жесткая привязка к имени пользователя  (на компе неск-ко юзверей)
или скрипт пишешь для кого-нить, чтоб не уточнять путь папки юзера
« Последнее редактирование: 29 Март 2010, 19:16:35 от nick.mega »

Оффлайн dimas000

  • Старожил
  • *
  • Сообщений: 1437
  • Ubuntu 9.10 @ 2.6.34
    • Просмотр профиля
Re: Неправильно запускается из скрипта
« Ответ #3 : 29 Март 2010, 19:35:58 »
на будущее: если тильду кто-нибудь не понимает, можно переменную $HOME юзать
лучше на "ты"

 

Страница сгенерирована за 0.053 секунд. Запросов: 22.