Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Парни, помогите с VPN, буду оч признателен  (Прочитано 480 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rom@n

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Всем привет.
Диспозиция:
-установил сервер ubuntu 9.10
-сконфигурировал PPTP севрер по нехитрому мануалу http://www.ylsoftware.com/news/407
- соединение с Ubuntu desktop проходит вроде как нормально(визуально) НО:
и тут две проблемы)) (возможно одна от другой зависит) :

1-- при присоединении с клиента создается интерфейс ppp0,  но из нормальной таблицы маршрутизации которая ранее выглядела так:
Destination Gateway Genmask Flags Metric Ref Use Iface
gw              *               255.255.255.255 UH    0      0        0 vboxnet0
192.168.56.0    gw              255.255.255.0   UG    0      0        0 vboxnet0
192.168.56.0    *               255.255.255.0   U     0      0        0 vboxnet0
79.164.208.0    *               255.255.240.0   U     1      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 eth0
default         host-79-164-208 0.0.0.0         UG    0      0        0 eth0

происходит ужас:
Destination Gateway Genmask Flags Metric Ref Use Iface
gw              79.164.208.1    255.255.255.255 UGH   0      0        0 eth0
gw              *               255.255.255.255 UH    0      0        0 vboxnet0
192.168.222.1   *               255.255.255.255 UH    0      0        0 ppp0
192.168.56.0    gw              255.255.255.0   UG    0      0        0 vboxnet0
192.168.56.0    *               255.255.255.0   U     0      0        0 vboxnet0
79.164.208.0    *               255.255.240.0   U     1      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 eth0

и интернет пропадает савсем. т.е. шлюз загажен, хотя вроде прописано в конфиге сервера параметр nodefaultroute, который гооврит не заменять дефолтовы шлюз (

2 -- никаких пакетов непроходит по ppp0 соединению и поэтому сервер закрывает соединение
в логах:
Mar 30 04:19:12 gw pppd[1301]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
Mar 30 04:19:12 gw pppd[1301]: pppd 2.4.5 started by root, uid 0
Mar 30 04:19:12 gw pppd[1301]: Using interface ppp0
Mar 30 04:19:12 gw pppd[1301]: Connect: ppp0 <--> /dev/pts/2
Mar 30 04:19:12 gw pppd[1301]: MPPE 128-bit stateless compression enabled
Mar 30 04:19:12 gw pppd[1301]: found interface eth1 for proxy arp
Mar 30 04:19:12 gw pppd[1301]: local  IP address 192.168.222.1
Mar 30 04:19:12 gw pppd[1301]: remote IP address 192.168.222.110
Mar 30 04:21:12 gw pppd[1301]: Modem hangup
Mar 30 04:21:12 gw pppd[1301]: Connect time 2.0 minutes.
Mar 30 04:21:12 gw pppd[1301]: Sent 336 bytes, received 0 bytes.
Mar 30 04:21:12 gw pppd[1301]: Connection terminated.
Mar 30 04:21:12 gw pppd[1301]: Exit.

Заранее большое спасибо, всем кто откликнется.


« Последнее редактирование: 30 Март 2010, 08:37:13 от Rom@n »

Оффлайн saber

  • Участник
  • *
  • Сообщений: 224
    • Просмотр профиля
    • Блог админа
Вот мой мануал
http://www.odmin4eg.ru/?p=54)
Может поможет
odmin4eg.ru - Мои шпаргалки по ubuntu

Оффлайн Sn@ke

  • Любитель
  • *
  • Сообщений: 81
    • Просмотр профиля
    • Блог
В офтопике, в созданном VPN подключении идем в свойства - сеть - свойства TCP/IP -  дополнительно - снимаем галку "Использовать основной шлюз в удаленной сети"

Оффлайн Rom@n

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
В офтопике, в созданном VPN подключении идем в свойства - сеть - свойства TCP/IP -  дополнительно - снимаем галку "Использовать основной шлюз в удаленной сети"

дада))) я так и исправил )

Пользователь решил продолжить мысль 30 Март 2010, 12:52:47:
все бы ладно... но, после установления соединения (значит всеже сервер запущен нормально и аутентификация проходит, ИП адреса назначаются как и положено, создается интерфейс ррр0) .!!!!! А простая команда ping не проходит никак! я не пойму в чем проблема... в route говорит что по такому то ИП смотреть такой то интерфейс- все верно.. но никто по этому соединению не отвечает , ни сервер, ни клиент.
Мож я чего не понимаю?

Пользователь решил продолжить мысль 30 Март 2010, 14:54:32:
теме АП!
« Последнее редактирование: 30 Март 2010, 14:54:32 от Rom@n »

Оффлайн saber

  • Участник
  • *
  • Сообщений: 224
    • Просмотр профиля
    • Блог админа
Таблицу маршрутизации после поднятия впн ещё раз
odmin4eg.ru - Мои шпаргалки по ubuntu

 

Страница сгенерирована за 0.054 секунд. Запросов: 23.