Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: DNS Сервер не работает  (Прочитано 2677 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Elaugaste

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
DNS Сервер не работает
« : 30 Март 2010, 09:33:59 »
Собственно есть Ubuntu 9.10 имеет подключение к интернету, установлен dnsmasq
нужно чтобы виндузные компы, когда вписывали в DNS адрес убунты ходили в интернет...

в интернет ходить ходят, но DNS Ubuntu не дает ...
(при попытке пинга не привязываются IP адреса к доменным именам)

где это настроить не пойму ...
на убунте инет есть
иптаблесы все разрешают

resolv.conf - прописан DNS сервера в интернете
interfaces - прописан DNS сервера в интернете

« Последнее редактирование: 30 Март 2010, 09:43:10 от Elaugaste »

Оффлайн RedBeard

  • Активист
  • *
  • Сообщений: 740
    • Просмотр профиля
Re: DNS Сервер не работает
« Ответ #1 : 30 Март 2010, 09:42:49 »
Не понял. Если ты хочешь свою Ubuntu для виндовозов DNS-серваком сделать, то подними на убунте BIND.

Оффлайн Elaugaste

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: DNS Сервер не работает
« Ответ #2 : 30 Март 2010, 09:43:54 »
dnsmasq
же стоит

Оффлайн RedBeard

  • Активист
  • *
  • Сообщений: 740
    • Просмотр профиля
Re: DNS Сервер не работает
« Ответ #3 : 30 Март 2010, 10:03:32 »
Пардон, не заметил. А тогда зачем в interfaces DNS прописывать?

Оффлайн Elaugaste

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: DNS Сервер не работает
« Ответ #4 : 30 Март 2010, 10:10:57 »
честно ? понятия не имею)
в линуксах новенький

стер разницы не ощутил

поставил бинд ...

 настроил
/etc/bind/named.conf.options


       forwarders {
195.46.116.1
         };

        listen-on {
                192.168.0.0/24;
                127.0.0.1;
         };
=======================================
Перезагрузил ...
больше не включаеться

походу ток переусановка ..... :(
бред

Значит в интерфейсы прописывать не надо было ?
« Последнее редактирование: 30 Март 2010, 10:30:31 от Elaugaste »

Оффлайн RedBeard

  • Активист
  • *
  • Сообщений: 740
    • Просмотр профиля
Re: DNS Сервер не работает
« Ответ #5 : 30 Март 2010, 10:53:40 »
Не надо конфиг BINDа ковырять, там уже все есть для простого кеша! И не надо прописывать DNS в interfaces для локальной сетки. Верни конфиг бинда на место, и убери DNS в раздаче локалки. А в локалке все должно по DHCP раздаваться. А если не будет, то руками им там пропиши в качестве DNS твой внутренний адрес. Да, и попробуй бинд вообще убрать. Тогда у тебя DNS маскарадингом должен через DHCP раздаваться. Несколько путано получается  :( ... В общем - или бинд с адресами в локалке на себя любимого, или маскарадинг по dnsmasq, но тогда бинд не нужен. Но в обоих случаях в интерфейсах жестко DNS прописывать не надо.

Пользователь решил продолжить мысль 30 Март 2010, 09:07:09:
Вот пример, как я делал раздачу по Wi-Fi с установленным по умолчанию BINDом (кусок из interfaces):
auto ath0
iface ath0 inet static
address 192.168.0.1
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
pre-up wlanconfig ath0 destroy
pre-up wlanconfig ath0 create wlandev wifi0 wlanmode ap
pre-up iwconfig ath0 essid ***** enc s:*****
А на рабстанциях прописал в качестве неймсервера 192.168.0.1
« Последнее редактирование: 30 Март 2010, 11:08:29 от RedBeard »

Оффлайн Elaugaste

  • Автор темы
  • Новичок
  • *
  • Сообщений: 35
    • Просмотр профиля
Re: DNS Сервер не работает
« Ответ #6 : 31 Март 2010, 03:31:15 »
DHCP эт конечно хорошо )
но тут удобнее иметь статичные IP :)

хех..
странно что все навернулось ...
загрузка прекращается после показа общего количества файлов и папок ... (или както так)

после переустановки сначала бинд поставлю ....
потом прокси
потом надо мыло сервак...

кстати может быть посоветуешь альтернативу Офис маил серверу ?
или тут только Postfix + еще куча всего сверху

 

Страница сгенерирована за 0.053 секунд. Запросов: 22.