Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: звук в ноуте  (Прочитано 5392 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sem

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
звук в ноуте
« : 27 Май 2007, 09:18:19 »
Добрый день всем.

Есть ноут. в нем есть звучка. все робатает, если воткнуть наушники звук в них появляется, но и остается в встроиных динамиках....
Как с этим бороться???? спасибо!

Оффлайн Noe

  • Участник
  • *
  • Сообщений: 214
    • Просмотр профиля
    • Ubunterra - земля Убунту.
Re: звук в ноуте
« Ответ #1 : 27 Май 2007, 22:12:08 »
мастерская по ремонту? читать документацию?

PS. назвать модель ноутбука вслух тоже иногда помагает
http://ubunterra.blogspot.com  — Ubunterra - земля Ubuntu.

Оффлайн xxxYURAxxx

  • Активист
  • *
  • Сообщений: 537
  • LinuxFormat друг человека...
    • Просмотр профиля
Re: звук в ноуте
« Ответ #2 : 28 Май 2007, 01:38:21 »
еще можно покопаться в Volume Applet
не всегда подхватывается... я знакомому именно через него звук настраивал...

Оффлайн sem

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: звук в ноуте
« Ответ #3 : 28 Май 2007, 12:24:51 »
мастерская по ремонту? читать документацию?

PS. назвать модель ноутбука вслух тоже иногда помагает

не.  под виндами все ок....

Оффлайн sem

  • Автор темы
  • Новичок
  • *
  • Сообщений: 5
    • Просмотр профиля
Re: звук в ноуте
« Ответ #4 : 28 Май 2007, 12:26:21 »
мастерская по ремонту?

не... по виндой все отличненько. А модель Samsung r40

Оффлайн Frutella

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: звук в ноуте
« Ответ #5 : 21 Август 2007, 20:41:33 »
может быть такое, что спайка внутри рушится, тогда вряд ли программами можно помочь, но покупка новой машины обычно проблему решает. дорого, но что поделаешь. есть еще такая штукА, как переносные колонки.. Но, в первую очередь, надо прорыть все настройки звука, это бесспорно.

Оффлайн finansist

  • Любитель
  • *
  • Сообщений: 78
    • Просмотр профиля
Re: звук в ноуте
« Ответ #6 : 23 Октябрь 2007, 01:17:18 »
Обновил ядро UBUNTU 7.04  до 2.6.20-16  и появилась проблема поднятая ТС. Имеено звук льется и из встроенных динамиков и из колонок одновременно. С аппаратурой все нормально и в винде и на старом ядре все работало как часики,т.е при включении внешних колонок внутренние отрубались. И что я только не делал.И дрова переустанавливал ,и весь инет облазил.Единственный совет ,которы на всем инете нашел это добавить в alsa-base строчку  options snd-hda-intel model=laptop , либо в /etc/modprobe.conf  options snd-hda-intel position_fix=1 model=lenovo
НЕПОМОГАЕТ.

Даж не знаю что делать.Откатыватья только на старое ядро ((

выводы
lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

lsmod | grep snd
snd_hda_intel         293664  1
snd_hwdep             10372  1 snd_hda_intel
snd_pcm_oss          42880  0
snd_pcm                 80516  2 snd_hda_intel,snd_pcm_oss
snd_page_alloc        11656  2 snd_hda_intel,snd_pcm
snd_mixer_oss         17792  1 snd_pcm_oss
snd_seq_oss            35200  0
snd_seq_midi_event 8704  1 snd_seq_oss
snd_seq                    54000  4 snd_seq_oss,snd_seq_midi_event
snd_timer                  24324  2 snd_pcm,snd_seq
snd_seq_device          9612  2 snd_seq_oss,snd_seq
snd                            56452  11 snd_hda_intel,snd_hwdep,snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_seq,snd_timer,snd_seq_device
soundcore               8672  1 snd

И еще прикол.Вытаскиваю штекер колонок- звук пропадает и во встроенных динамиках.Ваще засада.
« Последнее редактирование: 23 Октябрь 2007, 01:46:28 от finansist »

is_a

  • Гость
Re: звук в ноуте
« Ответ #7 : 23 Октябрь 2007, 02:36:35 »
Обновил ядро UBUNTU 7.04  до 2.6.20-16  и появилась проблема поднятая ТС. Имеено звук льется и из встроенных динамиков и из колонок одновременно. С аппаратурой все нормально и в винде и на старом ядре все работало как часики,т.е при включении внешних колонок внутренние отрубались. И что я только не делал.И дрова переустанавливал ,и весь инет облазил.Единственный совет ,которы на всем инете нашел это добавить в alsa-base строчку  options snd-hda-intel model=laptop , либо в /etc/modprobe.conf  options snd-hda-intel position_fix=1 model=lenovo
НЕПОМОГАЕТ.

Даж не знаю что делать.Откатыватья только на старое ядро ((

выводы
lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

lsmod | grep snd
snd_hda_intel         293664  1
snd_hwdep             10372  1 snd_hda_intel
snd_pcm_oss          42880  0
snd_pcm                 80516  2 snd_hda_intel,snd_pcm_oss
snd_page_alloc        11656  2 snd_hda_intel,snd_pcm
snd_mixer_oss         17792  1 snd_pcm_oss
snd_seq_oss            35200  0
snd_seq_midi_event 8704  1 snd_seq_oss
snd_seq                    54000  4 snd_seq_oss,snd_seq_midi_event
snd_timer                  24324  2 snd_pcm,snd_seq
snd_seq_device          9612  2 snd_seq_oss,snd_seq
snd                            56452  11 snd_hda_intel,snd_hwdep,snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_seq,snd_timer,snd_seq_device
soundcore               8672  1 snd

И еще прикол.Вытаскиваю штекер колонок- звук пропадает и во встроенных динамиках.Ваще засада.

Цитировать
Настройка ALSA для работы со встроенной звуковой картой HDA-Intel:
Цитировать
sudo gedit /etc/modprobe.d/alsa-base

options snd-hda-intel model=3stack
https://wiki.ubuntu.com/RussianDocumentation/AlsaHda-intel

Звука по прежнему нет. Решение: В пункте 7 вместо '3stack' попробуйте поставить '5stack', '6stack', 'laptop' или 'laptop-eapd'. Так же иногда нужно использовать значение 'erf'. Данная проблема связана с различными производителями.
« Последнее редактирование: 23 Октябрь 2007, 02:38:13 от is_a »

Оффлайн finansist

  • Любитель
  • *
  • Сообщений: 78
    • Просмотр профиля
Re: звук в ноуте
« Ответ #8 : 23 Октябрь 2007, 12:28:48 »


Цитировать
Настройка ALSA для работы со встроенной звуковой картой HDA-Intel:
Цитировать
sudo gedit /etc/modprobe.d/alsa-base

options snd-hda-intel model=3stack
https://wiki.ubuntu.com/RussianDocumentation/AlsaHda-intel

Звука по прежнему нет. Решение: В пункте 7 вместо '3stack' попробуйте поставить '5stack', '6stack', 'laptop' или 'laptop-eapd'. Так же иногда нужно использовать значение 'erf'. Данная проблема связана с различными производителями.

Вот именно так и пробовал вчера. Не помогает. Звук идет и из встроенных динамиков и из колонок,а если штекер колонок вытащить,то пропадает напрочь (((

Оффлайн finansist

  • Любитель
  • *
  • Сообщений: 78
    • Просмотр профиля
Re: звук в ноуте
« Ответ #9 : 23 Октябрь 2007, 23:08:56 »
Никаких предложений?
мне тут на мандриву уже предлагают пересаживаться...нехочется (

Оффлайн Johnny D.

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: звук в ноуте
« Ответ #10 : 24 Октябрь 2007, 12:19:32 »
Тоже есть ноут Toshiba L30-10x.
после установки звука не было вообще, затем установил обновления системы, появился звук(но только во встроенных динамик, в наушниках нет) установил последний OSS, ситуация не изменилать, поставил ALSA 1.0.15, ситуация поменялась коренным образом, т.е. теперь нет звука в динамиках, зато есть в наушниках.
Попробовал сделать вот это:

sudo gedit /etc/modprobe.d/alsa-base

options snd-hda-intel model=3stack

появляется звук в динамиках, появляется перехлючатель Headphones  во вкладке переключатели алсамиксера, но звука в наушниках нет, при подключении наушников звук в динамиках пропадает, а в наушниках не появляется.
Пробовал менять 3stack на  '5stack', '6stack', 'laptop', 'laptop-eapd', 'erf', 'auto', 'toshiba', во всех вариантах кроме 3stack звук только в наушниках.
Помогите плиз решить проблему, уже 3 дня с бубном пляшу.

Оффлайн Johnny D.

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: звук в ноуте
« Ответ #11 : 24 Октябрь 2007, 20:12:53 »
Выяснилось, что звук в наушниках есть, но очень-очень тихий, а в alsamixer,e громкость наушников не настраивается. Может есть какой-то другой способ повысить уровень громкости в наушниках?

Оффлайн Akkerman

  • Новичок
  • *
  • Сообщений: 10
    • Просмотр профиля
    • sinfed.ru
Re: звук в ноуте
« Ответ #12 : 11 Ноябрь 2007, 19:35:57 »
Попробуй внести строчку options snd-hda-intel model=auto в файл /etc/modprobe.d/alsa-base.

Оффлайн Johnny D.

  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
Re: звук в ноуте
« Ответ #13 : 20 Ноябрь 2007, 15:37:42 »
Попробуй внести строчку options snd-hda-intel model=auto в файл /etc/modprobe.d/alsa-base.
Пробовал, звук только в наушниках.

Оффлайн yobser

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: звук в ноуте
« Ответ #14 : 23 Декабрь 2007, 15:47:30 »
Здравствуйте, уважаемые коллеги.

Позавчера поставил ubuntu 7.10 на ноут с santarosa.
Звук snd-hda-intel, Realtek ALC268.

Звука не было вообще. Понял, что alsa старая. Поставил новую как написано. Звука нет.
Прочитал о всяких разных дополнениях к конфигурационным файлам /etc/modules и alsa-base. Добавил везде всё что было написано (а было понаписано много). Звука нет.
В результате начал изучать доку к alsa 1.0.15 (её-то я и ставил). И понял, что нужно писать для моего кодека. Результат был таким:
3stack - звука нет нигде (считаю вообще этот пункт нелогичным - в ноуте два гнезда - наушники и микрофон)
toshiba - звук есть в наушниках при любых танцах, ритмах и бубнах (я считаю себя знатоком)
acer - звук есть в динамиках и в наушниках при любых манипуляциях и занятости гнёзд
auto - звука нет нигде - неожиданно бесполезный параметр

При выполнении танца "подбор главного канала" замечено следующее - когда выбран Master правильно отрабатывают клавиши управления звуком, с одним недостатком, большая клавиша Mute не подсвечивается, когда "Mute on". А должна. Может кто знает как подсветить?

Ну и основной ворос так и остался открытым, как заставить звук работать правильно? То есть при включённых наушниках не играть на динамики.

 

Страница сгенерирована за 0.061 секунд. Запросов: 22.