Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Непонятная проблема с отваливанием сети...  (Прочитано 1306 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WizardOz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Всем здравствуйте, уважаемые!
Начну с того, что я в Линуксе чайник и признаю это... Это мой первый опыт установки сервака... Но начинать-то когда-то надо?
Теперь о проблеме:
Выделил машину, установил на нее Ubuntu 9.10. На ней крутится только веб-сервак(пока)...
Один сетевой интерфейс смотрит в локалку 192.168.х.х
Второй в мир...
Все IP статические... все маски, шлюзы, днсы прописаны...
И все крутится и вертится...(как мне казалось)!!!
Вот тут-то и началась эта проблема...
Повторюсь... все работает(для меня) да и для других пользователей локалки...
По внутреннему интерфейсу все замечательно, да и по внешнему тоже чудесно...
дело в том, что шлюз в инет у меня для локалки это другая машина и если я через нее выхожу в инет и обращаюсь с внешнего адреса на Ubuntu всетоже работает
РАБОТАЕТ ВСЕГДА!!!
IP шлюза и IP веб-сервака - в одной подсети
Блин! А внешние пользователи могут войти на мой веб-сервак не всегда... Сетевуха отваливается... Блин ну, как отваливается? Я то ее вижу!!!
Так вот с внешнего мира сервер доступен не всегда...
Несколько часов работает и замирает... Помогает ему проснутся только кнопка "применить конфигурацию" в разделе Webmin настройка сети...
Да, да... в Webmine работаю... (чайник же)... не постиг я еще...
После этого сеть опять поднимается и пользователи из внешнего мира рвутся ко мне на сервак...

Помогайте, уважаемые гуру...
Третий день парюсь с этой проблемой...

Заранее спасибо
P.S. Звиняйте, что много написал... ???

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25931
    • Просмотр профиля
Re: Непонятная проблема с отваливанием сети...
« Ответ #1 : 02 Апрель 2010, 15:20:38 »
В логах что в это время?
syslog, лог апача.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн WizardOz

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Непонятная проблема с отваливанием сети...
« Ответ #2 : 02 Апрель 2010, 16:38:03 »
Да криминала там по-моему нет...
Но на всякий случай фрагмент лога...
Непосредственно перед "применить конфигурацию"
(Нажмите, чтобы показать/скрыть)

Оффлайн Matrasa

  • Новичок
  • *
  • Сообщений: 32
    • Просмотр профиля
Re: Непонятная проблема с отваливанием сети...
« Ответ #3 : 03 Апрель 2010, 17:19:08 »
Всем привет, в линуксе новичок (уба стоит ок 3 месяцев) есть проблема с интернет сетью.

Я подключаюсь к интернету через провайдера который запоминает мой МАС, подключен к инету ноутбук. Я установил на свой домашний комп ubuntu 9.10, чтобы подключаться на ту же линию приходится менять мак, делаю это так:

sudo ifconfig eth0 down
sudo ifconfig eth0 hw ether нужный_мас
sudo ifconfig eth0 up
sudo pon dsl-provider eth0
(инет настаивал через pppoeconf)

неудобно каждый раз так делать, написал скрипт на перл, работает, но каждый второй (или третий раз) запуск скрипта валит систему в kernel panic.  :'(

Плюс еще проблема - интернет обрывается, странички не догружаются, останавливается видео, не идет закачка (останавливается хз почему) приходится каждый раз открывать консоль и по новой вбивать sudo pon dsl-provider eth0. Так почти каждые десять минут.

Почитал вот эту статью http://habrahabr.ru/blogs/ubuntu/74588/, все настроил все заработало, создал eth соединение и dsl. Исчезли обрывы, подключаться стало через меню (левой кнопкой по имени подключения и все работает) круто что мак можно сменить, есть поле для него, в общем все стало отлично.

Но после перезагрузки все пропало :tickedoff: Исчезли мои пункты меню (хотя сами подключения в настройках nmanager'a остались), вместо их появился какой-то auto ethernet, который один и хочет подключаться, опять сижу с кривого pppoeconf.

Помогите кто может! Как настроить нормально через network manager? Почему сбросилось? На обоих подключениях стоит галочка 'подключать автоматически' но ничего не работает!!!
Lenovo s110, Ubuntu 12.10, 3.5.0

 

Страница сгенерирована за 0.057 секунд. Запросов: 22.