Форум русскоязычного сообщества Ubuntu


Автор Тема: Ubuntu 7.04 и sata винт  (Прочитано 1904 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Oxpa

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Ubuntu 7.04 и sata винт
« : 28 Май 2007, 22:17:45 »
Заранее поясню, что Ubuntu поставил только вчера.  Установил, всё сделал "как доктор прописал" (про настройку адсл модема молчим, второй комп в квартире - необходимость, а не роскошь).

 Соответственно когда ставил включен был 1 сата диск и 1 иде диск. Однако появилась забавная проблема: подключаем второй сата диск и получаем проблемы с irq. Если точнее:

чипсет - интел 865 vm
мать - Асус Р4Р800 vm
Винты - сигейт сата 2 по 320 гигов каждый, плюс висит старинный 20 гиговый на иде.

С 1 сата и 1 иде - грузится идеально.
Добавляем ещё 1 сата винт, получаем сообщение, что устройство не хочет получать irq 16( иногда, при перезагрузке, номер меняется на 17 или 18). Далее говорят, что собственно нам на irq плевать делаем irq poll старт. однако после этого система виснет выведя ещё пару сообщений ( на память не скажу, будет надо - выпишу =) )
Если бутаться в режиме восстановления ситемы с 2мя винтами, то загрузка проходит с той же ошибкой, но значительно дальше и виснет на потере dma запроса О_О лог до этого момента как выложить не знаю. если подскажите (вроде бы ядро пишет логи...) - тоже выложу)

Ну и собственно вопрос:
Что бы мне такого сделать, чтобы грузиться с 2мя сата винтами сразу?
Если нужны какие-либо логи - где их искать?
Почему руки из жопы, а сижу прямо?

UPD вышеописанная проблема в ядре 2.6.20-16. в 2.6.20.15 винт показывается в устройствах, но монтироваться отказывается, ссылаясь на то, что файловая система неправильная (на винте основной раздел нтфс). 15ое ядро соответственно грузится, как-будто второго винта просто не существует
« Последнее редактирование: 29 Май 2007, 13:39:03 от Oxpa »
всё, конечно, хорошо. Но есть нюанс

Оффлайн Oxpa

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Ubuntu 7.04 и sata винт
« Ответ #1 : 30 Май 2007, 19:12:35 »
всё решалось как обычно... почитал список совместимого оборудования, я думаю все найдут.

https://wiki.ubuntu.com/Asus_P4P800

это моя мать, там сказано, что "You need to use F6 at the boot screen to add these command line options: noapic nolapic irqpoll All three of them. Then it works."

Основной проблемы это не решает, второго sata винта не видно, зато можно прогнать загрузку до конца и вытащить нормальные логи.. кому интересно:

UPD дело оказалось в прерываниях. при прописывании ноапик всё грузится, но винт не видно. где-то в инете народ грешит на кривой биос... однако же в винда вроде всё работает)
  Inspecting /boot/System.map-2.6.20-16-generic
  Loaded 24976 symbols from /boot/System.map-2.6.20-16-generic.
  Symbols match kernel version 2.6.20.
  No module symbols loaded - kernel modules not enabled.
   0.000000] Linux version 2.6.20-16-generic (root@terranova) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2 SMP Wed May 23 01:46:23 UTC 2007 (Ubuntu 2.6.20-16.28-generic)
   0.000000] BIOS-provided physical RAM map:
   0.000000] sanitize start
   0.000000] sanitize end
   0.000000] copy_e820_map() start: 0000000000000000 size: 000000000009fc00 end: 000000000009fc00 type: 1
   0.000000] copy_e820_map() type is E820_RAM
   0.000000] copy_e820_map() start: 000000000009fc00 size: 0000000000000400 end: 00000000000a0000 type: 2
   0.000000] copy_e820_map() start: 00000000000e8000 size: 0000000000018000 end: 0000000000100000 type: 2
   0.000000] copy_e820_map() start: 0000000000100000 size: 000000004fe30000 end: 000000004ff30000 type: 1
   0.000000] copy_e820_map() type is E820_RAM
   0.000000] copy_e820_map() start: 000000004ff30000 size: 0000000000010000 end: 000000004ff40000 type: 3
   0.000000] copy_e820_map() start: 000000004ff40000 size: 00000000000b0000 end: 000000004fff0000 type: 4
   0.000000] copy_e820_map() start: 000000004fff0000 size: 0000000000010000 end: 0000000050000000 type: 2
   0.000000] copy_e820_map() start: 00000000ffb80000 size: 0000000000480000 end: 0000000100000000 type: 2
   0.000000]  BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
   0.000000]  BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
   0.000000]  BIOS-e820: 00000000000e8000 - 0000000000100000 (reserved)
   0.000000]  BIOS-e820: 0000000000100000 - 000000004ff30000 (usable)
   0.000000]  BIOS-e820: 000000004ff30000 - 000000004ff40000 (ACPI data)
   0.000000]  BIOS-e820: 000000004ff40000 - 000000004fff0000 (ACPI NVS)
   0.000000]  BIOS-e820: 000000004fff0000 - 0000000050000000 (reserved)
   0.000000]  BIOS-e820: 00000000ffb80000 - 0000000100000000 (reserved)
   0.000000] 383MB HIGHMEM available.
   0.000000] 896MB LOWMEM available.
   0.000000] found SMP MP-table at 000ff780
   0.000000] Entering add_active_range(0, 0, 327472) 0 entries of 256 used
   0.000000] Zone PFN ranges:
   0.000000]   DMA             0 ->     4096
   0.000000]   Normal       4096 ->   229376
   0.000000]   HighMem    229376 ->   327472
   0.000000] early_node_map[1] active PFN ranges
   0.000000]     0:        0 ->   327472
   0.000000] On node 0 totalpages: 327472
   0.000000]   DMA zone: 32 pages used for memmap
   0.000000]   DMA zone: 0 pages reserved
   0.000000]   DMA zone: 4064 pages, LIFO batch:0
   0.000000]   Normal zone: 1760 pages used for memmap
   0.000000]   Normal zone: 223520 pages, LIFO batch:31
   0.000000]   HighMem zone: 766 pages used for memmap
   0.000000]   HighMem zone: 97330 pages, LIFO batch:31
   0.000000] DMI 2.3 present.
   0.000000] ACPI: RSDP (v000 ACPIAM                                ) @ 0x000f9f70
   0.000000] ACPI: RSDT (v001 A M I  OEMRSDT  0x06000312 MSFT 0x00000097) @ 0x4ff30000
   0.000000] ACPI: FADT (v001 A M I  OEMFACP  0x06000312 MSFT 0x00000097) @ 0x4ff30200
   0.000000] ACPI: MADT (v001 A M I  OEMAPIC  0x06000312 MSFT 0x00000097) @ 0x4ff30390
   0.000000] ACPI: OEMB (v001 A M I  OEMBIOS  0x06000312 MSFT 0x00000097) @ 0x4ff40040
   0.000000] ACPI: DSDT (v001  PPVM1 PPVM1606 0x00000606 INTL 0x02002026) @ 0x00000000
   0.000000] ACPI: PM-Timer IO Port: 0x808
   0.000000] Intel MultiProcessor Specification v1.4
   0.000000]     Virtual Wire compatibility mode.
   0.000000] OEM ID: ASUSTek  Product ID: P4P800-VM    APIC at: 0xFEE00000
   0.000000] Processor #0 15:2 APIC version 20
   0.000000] I/O APIC #2 Version 32 at 0xFEC00000.
   0.000000] Enabling APIC mode:  Flat.  Using 1 I/O APICs
   0.000000] Processors: 1
   0.000000] Allocating PCI resources starting at 60000000 (gap: 50000000:afb80000)
   0.000000] Detected 2394.217 MHz processor.
  65.350755] Built 1 zonelists.  Total pages: 324914
  65.350759] Kernel command line: root=UUID=e751593c-be17-4d51-8ac2-62c9a73c4a83 noapic nolapic irqpoll
  65.350789] Misrouted IRQ fixup and polling support enabled
  65.350791] This may significantly impact system performance
  65.350942] mapped APIC to ffffd000 (fee00000)
  65.350945] mapped IOAPIC to ffffc000 (fec00000)
  65.350948] Enabling fast FPU save and restore... done.
  65.350952] Enabling unmasked SIMD FPU exception support... done.
  65.350961] Initializing CPU#0
  65.351032] PID hash table entries: 4096 (order: 12, 16384 bytes)
  65.352320] Console: colour VGA+ 80x25
  65.355312] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
  65.355834] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
  65.403524] Memory: 1287132k/1309888k available (1992k kernel code, 21512k reserved, 896k data, 328k init, 392384k highmem)
  65.403602] virtual kernel memory layout:
  65.403603]     fixmap  : 0xfff4e000 - 0xfffff000   ( 708 kB)
  65.403605]     pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
  65.403606]     vmalloc : 0xf8800000 - 0xff7fe000   ( 111 MB)
  65.403607]     lowmem  : 0xc0000000 - 0xf8000000   ( 896 MB)
  65.403608]       .init : 0xc03d9000 - 0xc042b000   ( 328 kB)
  65.403609]       .data : 0xc02f2354 - 0xc03d26d4   ( 896 kB)
  65.403610]       .text : 0xc0100000 - 0xc02f2354   (1992 kB)
  65.404003] Checking if this processor honours the WP bit even in supervisor mode... Ok.
  65.482879] Calibrating delay using timer specific routine.. 4828.82 BogoMIPS (lpj=9657651)
  65.483026] Security Framework v1.0.0 initialized
  65.483084] SELinux:  Disabled at boot.
  65.483360] Mount-cache hash table entries: 512
  65.483577] CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 00004400 00000000 00000000
  65.483591] CPU: Trace cache: 12K uops, L1 D cache: 8K
  65.483677] CPU: L2 cache: 512K
  65.483726] CPU: Physical Processor ID: 0
  65.483776] CPU: After all inits, caps: bfebfbff 00000000 00000000 00003080 00004400 00000000 00000000
  65.483788] Compat vDSO mapped to ffffe000.
  65.483840] Remapping vsyscall page to ffffe000
  65.483902] Checking 'hlt' instruction... OK.
  65.499003] SMP alternatives: switching to UP code
  65.499252] Freeing SMP alternatives: 11k freed
  65.499515] Early unpacking initramfs... done
  65.821956] ACPI: Core revision 20060707
  65.822186] ACPI: Looking for DSDT in initramfs... file /DSDT.aml not found, using machine DSDT.
  65.824117] ACPI: setting ELCR to 0200 (from 0c20)
  65.824321] CPU0: Intel(R) Pentium(R) 4 CPU 2.40GHz stepping 09
  65.824484] Total of 1 processors activated (4828.82 BogoMIPS).
  65.930153] Brought up 1 CPUs
  65.930455] Booting paravirtualized kernel on bare hardware
  65.930578] Time: 18:28:33  Date: 04/30/107
  65.930657] NET: Registered protocol family 16
  65.930800] EISA bus registered
  65.930852] ACPI: bus type pci registered
  65.930973] PCI: PCI BIOS revision 2.10 entry at 0xf0031, last bus=2
  65.931025] PCI: Using configuration type 1
  65.931074] Setting up standard PCI resources
  65.945805] ACPI: Interpreter enabled
  65.945859] ACPI: Using PIC for interrupt routing
  65.947259] ACPI: PCI Root Bridge [PCI0] (0000:00)
  65.947319] PCI: Probing PCI hardware (bus 00)
  65.947920] PCI quirk: region 0800-087f claimed by ICH4 ACPI/GPIO/TCO
  65.947975] PCI quirk: region 0480-04bf claimed by ICH4 GPIO
  65.948296] Boot video device is 0000:01:00.0
  65.948394] PCI: Firmware left 0000:02:08.0 e100 interrupts enabled, disabling
  65.948569] PCI: Transparent bridge - 0000:00:1e.0
  65.948644] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
  65.958742] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P4._PRT]
  65.966134] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 *11 12 14 15)
  65.966855] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 *5 6 7 10 11 12 14 15)
  65.967565] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 *5 6 7 10 11 12 14 15)
  65.968275] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 *10 11 12 14 15)
  65.968984] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 *5 6 7 10 11 12 14 15)
  65.969695] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 *5 6 7 10 11 12 14 15)
  65.970461] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
  65.971254] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 *10 11 12 14 15)
  65.971818] Linux Plug and Play Support v0.97 (c) Adam Belay
  65.971879] pnp: PnP ACPI init
  65.977238] pnp: PnP ACPI: found 14 devices
  65.977292] PnPBIOS: Disabled by ACPI PNP
  65.977397] PCI: Using ACPI for IRQ routing
  65.977448] PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
  65.981554] NET: Registered protocol family 8
  65.981604] NET: Registered protocol family 20
  65.982451] pnp: 00:0a: ioport range 0x680-0x6ff has been reserved
  65.982504] pnp: 00:0a: ioport range 0x290-0x297 has been reserved
  65.982909] PCI: Bridge: 0000:00:01.0
  65.982959]   IO window: disabled.
  65.983011]   MEM window: fc900000-fe9fffff
  65.983063]   PREFETCH window: d7f00000-f7efffff
  65.983116] PCI: Bridge: 0000:00:1e.0
  65.983167]   IO window: d000-dfff
  65.983219]   MEM window: fea00000-feafffff
  65.983271]   PREFETCH window: disabled.
  65.983335] PCI: Setting latency timer of device 0000:00:1e.0 to 64
  65.983362] NET: Registered protocol family 2
  66.022033] IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
  66.022245] TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
  66.023065] TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
  66.023425] TCP: Hash tables configured (established 131072 bind 65536)
  66.023482] TCP reno registered
  66.034098] checking if image is initramfs... it is
  66.672959] Freeing initrd memory: 6764k freed
  66.673425] audit: initializing netlink socket (disabled)
  66.673487] audit(1180549713.404:1): initialized
  66.673630] highmem bounce pool size: 64 pages
  66.673740] VFS: Disk quotas dquot_6.5.1
  66.673809] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
  66.673907] io scheduler noop registered
  66.673992] io scheduler anticipatory registered
  66.674076] io scheduler deadline registered
  66.674168] io scheduler cfq registered (default)
  74.659735] 0000:00:1d.7 EHCI: BIOS handoff failed (BIOS bug ?) 01010001
  74.660141] isapnp: Scanning for PnP cards...
  75.016444] isapnp: No Plug & Play device found
  75.048811] Real Time Clock Driver v1.12ac
  75.048915] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
  75.049090] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
  75.049339] serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
  75.050114] 00:06: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
  75.050487] 00:07: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
  75.050822] mice: PS/2 mouse device common for all mice
  75.051629] RAMDISK driver initialized: 16 RAM disks of 65536K size 1024 blocksize
  75.051943] input: Macintosh mouse button emulation as /class/input/input0
  75.052040] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
  75.052094] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
  75.052393] PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
  75.052445] PNP: PS/2 controller doesn't have AUX irq; using default 12
  75.055814] serio: i8042 KBD port at 0x60,0x64 irq 1
  75.055870] serio: i8042 AUX port at 0x60,0x64 irq 12
  75.056080] EISA: Probing bus 0 at eisa.0
  75.056164] EISA: Detected 0 cards.
  75.086266] TCP cubic registered
  75.086319] NET: Registered protocol family 1
  75.086390] Using IPI No-Shortcut mode
  75.086504] ACPI: (supports S0 S1 S3 S4 S5)
  75.086807]   Magic number: 7:85:495
  75.086860] Time: tsc clocksource has been installed.
  75.087372] Freeing unused kernel memory: 328k freed
  75.125206] input: AT Translated Set 2 keyboard as /class/input/input1
  75.313175] Capability LSM initialized
  75.362862] ACPI Exception (acpi_processor-0677): AE_NOT_FOUND, Processor Device is not present [20060707]
  75.929712] usbcore: registered new interface driver usbfs
  75.929788] usbcore: registered new interface driver hub
  75.929864] usbcore: registered new device driver usb
  75.930854] USB Universal Host Controller Interface driver v3.0
  75.931146] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
  75.931199] PCI: setting IRQ 11 as level-triggered
  75.931203] ACPI: PCI Interrupt 0000:00:1d.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
  75.931344] PCI: Setting latency timer of device 0000:00:1d.0 to 64
  75.931348] uhci_hcd 0000:00:1d.0: UHCI Host Controller
  75.931514] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
  75.931599] uhci_hcd 0000:00:1d.0: irq 11, io base 0x0000ef00
  75.931765] usb usb1: configuration #1 chosen from 1 choice
  75.931848] hub 1-0:1.0: USB hub found
  75.931904] hub 1-0:1.0: 2 ports detected
  76.033839] ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 10
  76.033896] PCI: setting IRQ 10 as level-triggered
  76.033900] ACPI: PCI Interrupt 0000:00:1d.1[B] -> Link [LNKD] -> GSI 10 (level, low) -> IRQ 10
  76.034041] PCI: Setting latency timer of device 0000:00:1d.1 to 64
  76.034045] uhci_hcd 0000:00:1d.1: UHCI Host Controller
  76.034120] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
  76.034204] uhci_hcd 0000:00:1d.1: irq 10, io base 0x0000ef20
  76.034346] usb usb2: configuration #1 chosen from 1 choice
  76.034426] hub 2-0:1.0: USB hub found
  76.034481] hub 2-0:1.0: 2 ports detected
  76.046519] e100: Intel(R) PRO/100 Network Driver, 3.5.17-k2-NAPI
  76.046575] e100: Copyright(c) 1999-2006 Intel Corporation
  76.137629] ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
  76.137686] PCI: setting IRQ 5 as level-triggered
  76.137691] ACPI: PCI Interrupt 0000:00:1d.2[C] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
  76.137832] PCI: Setting latency timer of device 0000:00:1d.2 to 64
  76.137836] uhci_hcd 0000:00:1d.2: UHCI Host Controller
  76.137913] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
  76.137997] uhci_hcd 0000:00:1d.2: irq 5, io base 0x0000ef40
  76.138142] usb usb3: configuration #1 chosen from 1 choice
  76.138224] hub 3-0:1.0: USB hub found
  76.138279] hub 3-0:1.0: 2 ports detected
  76.152620] Floppy drive(s): fd0 is 1.44M
  76.207239] FDC 0 is a post-1991 82077
  76.241283] ACPI: PCI Interrupt 0000:00:1d.3[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
  76.241429] PCI: Setting latency timer of device 0000:00:1d.3 to 64
  76.241434] uhci_hcd 0000:00:1d.3: UHCI Host Controller
  76.241507] uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4
  76.241590] uhci_hcd 0000:00:1d.3: irq 11, io base 0x0000ef80
  76.241739] usb usb4: configuration #1 chosen from 1 choice
  76.241818] hub 4-0:1.0: USB hub found
  76.241873] hub 4-0:1.0: 2 ports detected
  76.273091] usb 1-2: new full speed USB device using uhci_hcd and address 2
  76.347166] ACPI: PCI Interrupt Link [LNKH] enabled at IRQ 10
  76.347223] ACPI: PCI Interrupt 0000:00:1d.7[D] -> Link [LNKH] -> GSI 10 (level, low) -> IRQ 10
  76.347367] PCI: Setting latency timer of device 0000:00:1d.7 to 64
  76.347372] ehci_hcd 0000:00:1d.7: EHCI Host Controller
  76.347460] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 5
  76.347554] ehci_hcd 0000:00:1d.7: debug port 1
  76.347609] PCI: cache line size of 128 is not supported by device 0000:00:1d.7
  76.347617] ehci_hcd 0000:00:1d.7: irq 10, io mem 0xfebffc00
  76.351555] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
  76.351707] usb usb5: configuration #1 chosen from 1 choice
  76.351786] hub 5-0:1.0: USB hub found
  76.351841] hub 5-0:1.0: 8 ports detected
  76.452979] ICH5: IDE controller at PCI slot 0000:00:1f.1
  76.453040] PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
  76.453096] ACPI: PCI Interrupt 0000:00:1f.1[A] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
  76.453237] ICH5: chipset revision 2
  76.453286] ICH5: not 100%% native mode: will probe irqs later
  76.453345]     ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hda:DMA, hdb:pio
  76.453488]     ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdc:DMA, hdd:pio
  76.453625] Probing IDE interface ide0...
  76.740462] hda: QUANTUM FIREBALLP AS20.5, ATA DISK drive
  76.804210] usb 1-2: device not accepting address 2, error -71
  77.411443] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
  77.417278] Probing IDE interface ide1...
  77.598910] usb 1-2: new full speed USB device using uhci_hcd and address 4
  77.781270] usb 1-2: configuration #1 chosen from 1 choice
  78.022212] usb 2-2: new low speed USB device using uhci_hcd and address 2
  78.150144] hdc: ASUS CRW-5224A, ATAPI CD/DVD-ROM drive
  78.197277] usb 2-2: configuration #1 chosen from 1 choice
  78.213162] usbcore: registered new interface driver hiddev
  78.226381] input: KYE Genius USB Wheel Mouse as /class/input/input2
  78.226554] input: USB HID v1.00 Mouse [KYE Genius USB Wheel Mouse] on usb-0000:00:1d.1-2
  78.226702] usbcore: registered new interface driver usbhid
  78.226755] drivers/usb/input/hid-core.c: v2.6:USB HID core driver
  78.485602] ide1 at 0x170-0x177,0x376 on irq 15
  78.486038] ICH5-SATA: IDE controller at PCI slot 0000:00:1f.2
  78.486097] ACPI: PCI Interrupt 0000:00:1f.2[A] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
  78.486238] ICH5-SATA: chipset revision 2
  78.486290] ICH5-SATA: 100%% native mode on irq 5
  78.486344]     ide2: BM-DMA at 0xef60-0xef67, BIOS settings: hde:DMA, hdf:pio
  78.486485]     ide3: BM-DMA at 0xef68-0xef6f, BIOS settings: hdg:DMA, hdh:pio
  78.486623] Probing IDE interface ide2...
  78.773122] hde: ST3320620AS, ATA DISK drive
  79.444139] ide2 at 0xefe0-0xefe7,0xefae on irq 5
  79.444453] Probing IDE interface ide3...
  79.731547] hdg: ST3320620AS, ATA DISK drive
  80.066849] hdh: probing with STATUS(0x00) instead of ALTSTATUS(0x50)
  80.234575] hdh: probing with STATUS(0x00) instead of ALTSTATUS(0x50)
  80.402570] ide3 at 0xefa0-0xefa7,0xefaa on irq 5
  80.411683] SCSI subsystem initialized
  80.418882] libata version 2.20 loaded.
  80.421499] ACPI: PCI Interrupt Link [LNKE] enabled at IRQ 5
  80.421555] ACPI: PCI Interrupt 0000:02:08.0[A] -> Link [LNKE] -> GSI 5 (level, low) -> IRQ 5
  80.444491] e100: eth0: e100_probe: addr 0xfeaff000, irq 5, MAC addr 00:0C:6E:78:00:EE
  80.464090] hda: max request size: 128KiB
  80.482235] hda: 40132503 sectors (20547 MB) w/1902KiB Cache, CHS=39813/16/63, UDMA(100)
  80.482444] hda: cache flushes not supported
  80.482538]  hda: hda1
  80.486112] hde: max request size: 512KiB
  86.334384] irq 5: nobody cared (try booting with the "irqpoll" option)
  86.334444]  [__report_bad_irq+36/128] __report_bad_irq+0x24/0x80
  86.334536]  [note_interrupt+606/656] note_interrupt+0x25e/0x290
  86.334626]  [handle_level_irq+235/288] handle_level_irq+0xeb/0x120
  86.334715]  [do_IRQ+64/128] do_IRQ+0x40/0x80
  86.334804]  [common_interrupt+35/48] common_interrupt+0x23/0x30
  86.334893]  [__do_softirq+91/256] __do_softirq+0x5b/0x100
  86.334984]  [do_softirq+85/96] do_softirq+0x55/0x60
  86.335071]  [smp_apic_timer_interrupt+117/128] smp_apic_timer_interrupt+0x75/0x80
  86.335161]  [apic_timer_interrupt+40/48] apic_timer_interrupt+0x28/0x30
  86.335248]  [default_idle+0/96] default_idle+0x0/0x60
  86.335337]  [native_safe_halt+2/16] native_safe_halt+0x2/0x10
  86.335426]  [default_idle+61/96] default_idle+0x3d/0x60
  86.335513]  [cpu_idle+73/208] cpu_idle+0x49/0xd0
  86.335599]  [start_kernel+869/1056] start_kernel+0x365/0x420
  86.335689]  [unknown_bootoption+0/608] unknown_bootoption+0x0/0x260
  86.335778]  =======================
  86.335827] handlers:
  86.335874] [<f887ef10>] (usb_hcd_irq+0x0/0x60 [usbcore])
  86.336010] [ide_intr+0/496] (ide_intr+0x0/0x1f0)
  86.336131] [ide_intr+0/496] (ide_intr+0x0/0x1f0)
  86.336252] Disabling IRQ #5
  86.337594] hde: 625142448 sectors (320072 MB) w/16384KiB Cache, CHS=38913/255/63, UDMA(100)
  86.338150] hdc: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
  86.338447] Uniform CD-ROM driver Revision: 3.20
  86.340140] hde: cache flushes supported
  86.340218]  hde: unknown partition table
  86.372251] hdg: max request size: 512KiB
  86.427981] hdg: 625142448 sectors (320072 MB) w/16384KiB Cache, CHS=38913/255/63, UDMA(100)
  86.451943] hdg: cache flushes supported
  86.452037]  hdg: hdg1 hdg2 < hdg5 >
  86.972720] Attempting manual resume
  86.972772] swsusp: Resume From Partition 34:5
  86.972774] PM: Checking swsusp image.
  86.975083] PM: Resume from disk failed.
  87.126850] kjournald starting.  Commit interval 5 seconds
  87.126914] EXT3-fs: mounted filesystem with ordered data mode.
  87.709841] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  88.321591] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  88.344806] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.072381] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.073258] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.096207] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.100200] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.100345] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.104194] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.104336] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.104483] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.108187] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.112186] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.112345] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.116173] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.120166] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.124160] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.128153] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.132146] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.132313] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.136140] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.140139] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.140300] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  91.144126] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
  95.219482] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 101.055495] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 101.064124] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 101.350677] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 101.419869] e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
 101.457374] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 101.511919] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 101.623109] NET: Registered protocol family 10
 101.623258] lo: Disabled Privacy Extensions
 103.236385] intel_rng: FWH not detected
 103.268318] iTCO_vendor_support: vendor-support=0
 103.272512] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.01 (11-Nov-2006)
 103.272658] iTCO_wdt: Found a ICH5 or ICH5R TCO device (Version=1, TCOBASE=0x0860)
 103.272767] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
 103.421832] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
 103.599037] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
 103.629356] Linux agpgart interface v0.102 (c) Dave Jones
 103.632456] agpgart: Detected an Intel 865 Chipset.
 103.635204] agpgart: AGP aperture is 64M @ 0xf8000000
 104.043078] input: PC Speaker as /class/input/input3
 104.355452] parport: PnPBIOS parport detected.
 104.355598] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,EPP,ECP,DMA]
 104.550725] usbcore: registered new interface driver cxacru
 104.803392] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
 104.803449] ACPI: PCI Interrupt 0000:00:1f.5[B] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
 104.803604] PCI: Setting latency timer of device 0000:00:1f.5 to 64
 105.161608] AC'97 0 analog subsections not ready
 105.229499] intel8x0_measure_ac97_clock: measured 56015 usecs
 105.229551] intel8x0: clocking to 48000
 105.250794] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 105.254224] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 105.269497] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 105.270757] EXT3-fs warning (device hdg1): dx_probe: Unrecognised inode hash code 232
 105.432198] fuse init (API version 7.8)
 105.461777] lp0: using parport0 (interrupt-driven).
 105.542976] Adding 3791300k swap on /dev/disk/by-uuid/c9008828-bd78-4bc7-983c-ac35ad2c5f2d.  Priority:-1 extents:1 across:3791300k

и дальше в логах куча сообщений про инод. В общем я в лёгкой растерянности. я не думал, что 865й чипсет на асусовской матери может вызвать подобные проблемы ...
« Последнее редактирование: 31 Май 2007, 02:01:13 от Oxpa »
всё, конечно, хорошо. Но есть нюанс

Оффлайн Stargazer

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 7.04 и sata винт
« Ответ #2 : 05 Июнь 2007, 17:53:52 »
Всем привет!

Ставлю Ubuntu 7.04 beta desktop 386, загружается с CD нормально, а при попытке произвести инсталляцию, не могу увидеть разделы моего винта. То есть, Ubuntu мой винт не видит вообще! Винт подключен к мамке через контроллер ST_Lab, который якобы совместим с линуксом (так в его доке написано).
Люди добрые, подскажите новичку, куда рыть и что делать?

Заранее спасибо.

Оффлайн Oxpa

  • Автор темы
  • Новичок
  • *
  • Сообщений: 4
    • Просмотр профиля
Re: Ubuntu 7.04 и sata винт
« Ответ #3 : 05 Июнь 2007, 23:21:08 »
 а я вот начинаю подозревать что всё таки я мартышка) динамические разделы линукс не понимает, а у меня винт именно с динамическим разделом... во время установки мб тоже самое, но винт он должен бы видеть...
всё, конечно, хорошо. Но есть нюанс

Оффлайн Stargazer

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 7.04 и sata винт
« Ответ #4 : 06 Июнь 2007, 10:25:55 »
а я вот начинаю подозревать что всё таки я мартышка) динамические разделы линукс не понимает, а у меня винт именно с динамическим разделом... во время установки мб тоже самое, но винт он должен бы видеть...

Да, винт-то должен увидать, пусть даже без разделов...
Я где-то натыкался на такое шаманство, что можно инсталлятор Убунты перевести в текстовый режим и он увидит винт, но я не умею это делать. И увидеть сам процесс загрузки тоже не умею. Может, кто подскажет?

Оффлайн Stargazer

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 7.04 и sata винт
« Ответ #5 : 07 Июнь 2007, 00:41:13 »
а я вот начинаю подозревать что всё таки я мартышка) динамические разделы линукс не понимает, а у меня винт именно с динамическим разделом... во время установки мб тоже самое, но винт он должен бы видеть...

Да, винт-то должен увидать, пусть даже без разделов...
Я где-то натыкался на такое шаманство, что можно инсталлятор Убунты перевести в текстовый режим и он увидит винт, но я не умею это делать. И увидеть сам процесс загрузки тоже не умею. Может, кто подскажет?

Нашёл драйвер для Убунты 7.04, на сайте VIA под свой контроллер SATA VIA 64xx! Только что с ним делать теперь, не знаю :)  Люди добрые, намекните пожалуйста, как энтот драйвер подставить инсталлятору?

Оффлайн Stargazer

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 7.04 и sata винт
« Ответ #6 : 07 Июнь 2007, 12:33:51 »
Цитата: Stargazer
Нашёл драйвер для Убунты 7.04, на сайте VIA под свой контроллер SATA VIA 64xx! Только что с ним делать теперь, не знаю :)  Люди добрые, намекните пожалуйста, как энтот драйвер подставить инсталлятору?

Сам себе же и отвечаю. К драйверу прилагалась инструкция по установке. Записал образ на флоппи-диск, загрузил Ubuntu и, двигаясь по инструкции, прошёл путь:
#sudo modprobe sata_via -r
#sudo modprobe ahci -r
#sudo modprobe ext2
#sudo mount /dev/fd0 /mnt
#sudo cp /mnt/* /tmp -rf
#sudo umount /mnt
#sudo modprobe libata
#sudo insmod /tmp/x86/2.6.20-15-generic/sata_via.ko

И вот тут-то накрыло медным тазом! Команда #insmod выдаёт, что в модуле .ko неверный символ!
Блин, полдня потрачено впустую. Вот вам и линукс.
Конечно, с виндой тоже возни было, но на порядок меньше — записал драйвер на дискетку, подсунул при инсталляции и все дела.

Оффлайн Stargazer

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: Ubuntu 7.04 и sata винт
« Ответ #7 : 09 Июнь 2007, 21:31:00 »
Проблема решена.
Наблюдение за процессом загрузки показало, что убунтовый sata-драйвер не хочет грузиться и выдаёт ошибку "SATA не совместим с master/slave".
На контроллере была выдернута соответствующая перемычка и Ubuntu смогла увидеть диск. Установка ОС прошла гладко, всё работает.

 

Страница сгенерирована за 0.066 секунд. Запросов: 22.