Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Не могу установить некоторые .deb  (Прочитано 1589 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн izzik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Не могу установить некоторые .deb
« : 08 Апрель 2010, 13:42:06 »
Добрый день. Возникла проблема с установкой некоторых .deb пакетов.
Выдаёт вот такую ошибку


Все что можно закрывал.
Проблема замечена с установочными пакетами скайпа и дропбокса.
Как исправить? Help.

Оффлайн БТР

  • Заслуженный пользователь
  • Модератор форума
  • Старожил
  • *
  • Сообщений: 5115
    • Просмотр профиля
Re: Не могу установить некоторые .deb
« Ответ #1 : 08 Апрель 2010, 13:45:05 »
Видимо некорректно закончилась предыдущая установка пакетов, и база осталась заблокированной.
Запустите установку из терминала командой
sudo dpkg -i *.debи посмотрите, на что ругается вывод.

Оффлайн peydj

  • Новичок
  • *
  • Сообщений: 15
    • Просмотр профиля
Re: Не могу установить некоторые .deb
« Ответ #2 : 08 Апрель 2010, 14:06:44 »
Видимо некорректно закончилась предыдущая установка пакетов, и база осталась заблокированной.
Запустите установку из терминала командой
sudo dpkg -i *.debи посмотрите, на что ругается вывод.

А я пока в этих выводах ничерта не понимаю, так что предлагаю их седа выложить, что бы знающие лди посмотрели и подсказали, если будет такая возможность...
Лучше семь раз подумать, чем один раз не правильно спросить.

Оффлайн izzik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Не могу установить некоторые .deb
« Ответ #3 : 08 Апрель 2010, 14:09:24 »
Dropbox установился, а скайп выдал

(Чтение базы данных ... на данный момент установлено 128346 файлов и каталогов.)
Распаковывается пакет skype (из файла .../skype-ubuntu-intrepid_2.1.0.81-1_i386.deb)...
dpkg: зависимости пакетов не позволяют настроить пакет skype:
 skype зависит от libqt4-dbus (>= 4.4.3), однако:
  Пакет libqt4-dbus не установлен.
 skype зависит от libqt4-network (>= 4.4.3), однако:
  Пакет libqt4-network не установлен.
 skype зависит от libqtcore4 (>= 4.4.3), однако:
  Пакет libqtcore4 не установлен.
 skype зависит от libqtgui4 (>= 4.4.3), однако:
  Пакет libqtgui4 не установлен.
dpkg: не удалось обработать параметр skype (--install):
 проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils ...
При обработке следующих пакетов произошли ошибки:
 skype

дальше попробовал установить libqtgui4

 sudo apt-get install libqtgui4
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
  libqtgui4: Зависит: libqtcore4 (= 4.5.3really4.5.2-0ubuntu1) но он не будет установлен
  skype: Зависит: libqt4-dbus (>= 4.4.3) но он не будет установлен
         Зависит: libqt4-network (>= 4.4.3) но он не будет установлен
         Зависит: libqtcore4 (>= 4.4.3) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).
naira@naira-laptop:~$ sudo apt-get -f install libqtgui4
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
  libqtgui4: Зависит: libqtcore4 (= 4.5.3really4.5.2-0ubuntu1) но он не будет установлен
  skype: Зависит: libqt4-dbus (>= 4.4.3) но он не будет установлен
         Зависит: libqt4-network (>= 4.4.3) но он не будет установлен
         Зависит: libqtcore4 (>= 4.4.3) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).

« Последнее редактирование: 08 Апрель 2010, 14:19:52 от izzik »

Оффлайн dimas000

  • Старожил
  • *
  • Сообщений: 1437
  • Ubuntu 9.10 @ 2.6.34
    • Просмотр профиля
Re: Не могу установить некоторые .deb
« Ответ #4 : 08 Апрель 2010, 14:29:30 »
sudo dpkg -P skype
после чего sudo aptitude update
после чего ставь тот же деб через gdebi (гуевый установщик), он сам зависимости стянет нужные.
перед всем этим делом ребутнись
лучше на "ты"

Оффлайн izzik

  • Автор темы
  • Новичок
  • *
  • Сообщений: 13
    • Просмотр профиля
Re: Не могу установить некоторые .deb
« Ответ #5 : 08 Апрель 2010, 15:59:39 »
Спасибо!

 

Страница сгенерирована за 0.057 секунд. Запросов: 23.