Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Несовместимость архитектуры.  (Прочитано 487 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cyberpunk49

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Несовместимость архитектуры.
« : 08 Апрель 2010, 13:48:14 »
Критически важный для меня пакет при установке ругается о несовместимости архитектуры.
Архитектура пакета - i386, архитектура системы - amd64.
Процессор у меня Core 2 Duo T6570.
версия Ubuntu - 9.10.
можно ли переустановить эту же ubuntu чтобы она работала в 32-битном режиме?
или необходимо поменять ОС ?
или есть какие-нибудь ещё варианты?.
Пакет на 64-битную архитектуру найти невозможно.. :-\

Оффлайн stmc

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1713
  • Arch Linux
    • Просмотр профиля
    • Моя страница на Launchpad
Re: Несовместимость архитектуры.
« Ответ #1 : 08 Апрель 2010, 13:50:53 »
скачай 32 битные libs к этому пакету и форсируй его установку

p/s если немного погуглить можно узнать как это сделать

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Re: Несовместимость архитектуры.
« Ответ #2 : 08 Апрель 2010, 14:01:42 »
заходишь в папку со скачанным пакетом (через терминал)
sudo apt-get dpkg --force-architecture -i *
предварительно поставив пакет ia32-libs
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн kss

  • Любитель
  • *
  • Сообщений: 88
    • Просмотр профиля
Re: Несовместимость архитектуры.
« Ответ #3 : 08 Апрель 2010, 15:37:23 »
предварительно поставив пакет ia32-libs

Их может и не хватит. Для надежности надо бы ещё после этого натравить ldd на бинарники из установленной дебки и посмотреть всех ли библиотек хватает. В случае чего, в ручную доустановить их.


Оффлайн cyberpunk49

  • Автор темы
  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Re: Несовместимость архитектуры.
« Ответ #4 : 10 Апрель 2010, 16:08:16 »
Установил ia32-libs, потом установил с опцией --force-architecture.
Всё работает, спасибо за помощь!

 

Страница сгенерирована за 0.054 секунд. Запросов: 22.