Форум русскоязычного сообщества Ubuntu


Следите за новостями русскоязычного сообщества Ubuntu в Twitter-ленте @ubuntu_ru_loco

Автор Тема: Network Manager не видит eth0 (проводной интерфейс)  (Прочитано 3157 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Metmor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Здравствуйте

Проблема следующая. В NM не отображается ничего для проводного интерфейса, хотя кабель подключён и системой распознаётся. /etc/network/interfaces выглядит так:
auto lo
iface lo inet loopback

Если добавить строчки
auto eth0
iface eth0 inet dhcp
то сеть при перезапуске поднимается, но NM даже не хочет включаться.
Содержание nm-system-settings.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

NM версии 0.8 (обновлён через http://ppa.launchpad.net/network-manager/trunk/ubuntu).

Оффлайн gorven

  • Активист
  • *
  • Сообщений: 463
  • Что нас ждет - Linux хранит молчанье
    • Просмотр профиля
Re: Network Manager не видит eth0 (проводной интерфейс)
« Ответ #1 : 15 Апрель 2010, 11:12:45 »
а на фиг вам NM? если в /etc/network/interfaces все прописано и работает - оставте и забудьте про нетворк манагера. Инет при загрузке будет сам включаться.
Эта ваша Ubuntu прикольненькая такая винда (с)

Оффлайн Metmor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Network Manager не видит eth0 (проводной интерфейс)
« Ответ #2 : 15 Апрель 2010, 11:17:35 »
Это ноутбук, нужны и wifi, и adsl, и провод. Первые два типа подключения НМ находит, кстати.
« Последнее редактирование: 15 Апрель 2010, 11:19:55 от Metmor »

ValeryK

  • Гость
Re: Network Manager не видит eth0 (проводной интерфейс)
« Ответ #3 : 15 Апрель 2010, 11:34:22 »
To allow NetworkManager to manage wired interfaces, either:
      Comment the relevant lines in /etc/network/interfaces to restore the behavior experienced in Lenny.
      or
      Set managed=true in nm-system-settings.conf if you want network-manager to handle interfaces that are declared in /etc/network/interfaces (you need to kill nm-system-settings)
Restart network-manager or X is not enough. It seems you must reboot your computer in order to apply your changes.

Оффлайн Metmor

  • Автор темы
  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Network Manager не видит eth0 (проводной интерфейс)
« Ответ #4 : 15 Апрель 2010, 22:16:32 »
To allow NetworkManager to manage wired interfaces, either:
      Comment the relevant lines in /etc/network/interfaces to restore the behavior experienced in Lenny.
      or
      Set managed=true in nm-system-settings.conf if you want network-manager to handle interfaces that are declared in /etc/network/interfaces (you need to kill nm-system-settings)
Restart network-manager or X is not enough. It seems you must reboot your computer in order to apply your changes.
См. выше: если eth0 прописан в /etc/network/interfaces, то НМ просто не запускается при старте системы (апплета нет). Если всё убрать и оставить только
auto lo
iface lo inet loopback
то НМ запускается, но eth0 не видит. Никаких профилей (вроде Auto (eth0)) в списке проводных соединений не появляется. Можно создать профиль вручную, НМ не даёт его запустить (его нет в списке доступных подключений, который открывается по левому клику на апплет).

Пользователь решил продолжить мысль 15 Апрель 2010, 22:56:54:
Проблема решилась - помог второй способ.
Цитировать
Set managed=true in nm-system-settings.conf if you want network-manager to handle interfaces that are declared in /etc/network/interfaces (you need to kill nm-system-settings)
Restart network-manager or X is not enough. It seems you must reboot your computer in order to apply your changes.
После изменения false на true и ребута в НМ появилось подключение lfupdown (eth0), ассоциированное, как я понял, с прописанными в /etw/network/interfaces настройками для eth0. Одновременно стали доступны те профили проводного подключения, которые я создавал вручную.

Спасибо за помощь!
« Последнее редактирование: 15 Апрель 2010, 22:56:54 от Metmor »

 

Страница сгенерирована за 0.056 секунд. Запросов: 22.