Форум русскоязычного сообщества Ubuntu


Получить помощь и пообщаться с другими пользователями Ubuntu можно
на irc канале #ubuntu-ru в сети Freenode
и в Jabber конференции ubuntu@conference.jabber.ru

Автор Тема: Не могу сделать доступным localhost из сети интернет!  (Прочитано 1880 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн coder1994

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
У меня динамический ip. Модем - D-Link. Сервер стоит и работает исправно. Но с других компов он недоступен! Можете пожалуйста описать полный и детальный процесс открытия доступа из сети интернет доступ к локалхосту.

Пользователь решил продолжить мысль 21 Апрель 2010, 17:25:03:
root@UPCoder:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:26:18:50:f0:d2 
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::226:18ff:fe50:f0d2/64 Диапазон:Ссылка
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:268049 errors:0 dropped:0 overruns:0 frame:0
          TX packets:195914 errors:0 dropped:0 overruns:0 carrier:0
          коллизии:0 txqueuelen:1000
          RX bytes:340610604 (340.6 MB)  TX bytes:22417654 (22.4 MB)
          Прервано:28 Base address:0xc000

lo        Link encap:Локальная петля (Loopback) 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Диапазон:Узел
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3775 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3775 errors:0 dropped:0 overruns:0 carrier:0
          коллизии:0 txqueuelen:0
          RX bytes:1476549 (1.4 MB)  TX bytes:1476549 (1.4 MB)
« Последнее редактирование: 21 Апрель 2010, 17:25:03 от coder1994 »

Оффлайн satch

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1561
  • Kubuntu 15.10 amd64
    • Просмотр профиля
веб-сервер? в настройках модема пробросьте 80-ый порт до адреса 192.168.1.2
Наше желание помочь прямопропорционально вашему желанию решить проблему

Оффлайн coder1994

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Вебсервер - Apache 2.2 . Вроде прописал

Пользователь решил продолжить мысль 21 Апрель 2010, 17:43:46:
Вот скрин - http://upwap.ru/837877

Оффлайн lone_wolf

  • Активист
  • *
  • Сообщений: 292
    • Просмотр профиля
Вебсервер - Apache 2.2 . Вроде прописал

Пользователь решил продолжить мысль 21 Апрель 2010, 17:43:46:
Вот скрин - http://upwap.ru/837877

замени 127.0.0.1 на 192.168.1.2 и бедует тебе шастье

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля
Да, замени, как выше советуют. И впредь не путай понятия, локалхост он на то и локалхост, чтоб не был лоступен извне, кроме как локально на системе. http://ru.wikipedia.org/wiki/Localhost

Оффлайн Просто Царь

  • Активист
  • *
  • Сообщений: 936
    • Просмотр профиля
а еще стоит обратить внимание на это
Цитировать
У меня динамический ip.
Так что для начала надо убедиться что твой ip адрес вообще маршрутизируется провайдером, а потом смотреть в сторону dyndns

Оффлайн coder1994

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Так я сменил на 192.168.1.2 ,в динднс я поставил тоже 192.168.1.2

Пользователь решил продолжить мысль 22 Апрель 2010, 07:16:05:
но ничего не вышло.
Sorry, the IP address of codercms.selfip.com is not public. For security reasons, validating resources located at non-public IP addresses has been disabled in this service.

Пользователь решил продолжить мысль 22 Апрель 2010, 09:27:09:
Вот скрин соединение с динднс - http://upwap.ru/838840

Пользователь решил продолжить мысль 22 Апрель 2010, 11:42:06:
Всё народ разобрался! Спасибо!
« Последнее редактирование: 22 Апрель 2010, 11:42:06 от coder1994 »

Оффлайн Tokh

  • Активист
  • *
  • Сообщений: 705
    • Просмотр профиля
А где там на скрине прописанный адрес 192.168.1.2? Не должно там этого быть.
См. что говорит
nslookup доменнное.имя.сервера
Надо настроить Port Mapping (Port Forwarding): все запросы приходящие снаружи в 80 порт передавать в 192.168.1.2:80
Запросы будут приходить на "внешний.адрес.модема:80" и транслироваться модемом на 192.168.1.2:80.
StarDict и Mueller помогут против английского мануала.

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.