Форум русскоязычного сообщества Ubuntu


Считаете, что Ubuntu недостаточно дружелюбна к новичкам?
Помогите создать новое Руководство для новичков!

Автор Тема: Firebird 1.5.6 установка на Ubuntu Server 10.04 устал бороться...  (Прочитано 2045 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dearfear

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
Коллеги, прошу попомщи очень нужен сервер ветки 1.5 но никак не могу установить на Ubuntu server 10.04  (бета но с последними обновлениями)
dmitriy@srv:~$ sudo sh /home/dmitriy/FirebirdSS-1.5.6.5026-0.i686/install.sh
[sudo] password for dmitriy:

Firebird super 1.5.6.5026-0.i686 Installation

Press Enter to start installation or ^C to abort
Extracting install data
/home/dmitriy/FirebirdSS-1.5.6.5026-0.i686/install.sh: 153: ./scripts/preinstall.sh: not found
Install aborted: The command ./scripts/preinstall.sh
                 failed with error code 127
Что за ошибка 127 так и не понял.... :(

Оффлайн Malamut

  • Ubuntu Member
  • Администратор
  • Старожил
  • *
  • Сообщений: 3311
  • Я добрый, честно!
    • Просмотр профиля
    • Моя страница на Launchpad
Ну надо почитать этот самый preinstall.sh на предмет числа 127, если немного разбираетесь в bash, то думаю что-нибудь поймёте.
"Носителем суверенитета и единственным источником власти в Российской Федерации является ее многонациональный народ" Конституция РФ

Оффлайн Mam(O)n

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 5855
    • Просмотр профиля

Ну надо почитать этот самый preinstall.sh
./scripts/preinstall.sh: not found
Думаю, что надо читать install.sh на предмет того, почему он дёргает несуществующий файл.

Пользователь решил продолжить мысль 22 Апрель 2010, 23:41:40:
А firebird 2-ой ветки из репозитория не катит?
« Последнее редактирование: 22 Апрель 2010, 23:41:40 от Mam(O)n »

Оффлайн Malamut

  • Ubuntu Member
  • Администратор
  • Старожил
  • *
  • Сообщений: 3311
  • Я добрый, честно!
    • Просмотр профиля
    • Моя страница на Launchpad
А, ой, и правда install, видно спать я очень хотел :coolsmiley:
"Носителем суверенитета и единственным источником власти в Российской Федерации является ее многонациональный народ" Конституция РФ

Оффлайн dearfear

  • Автор темы
  • Новичок
  • *
  • Сообщений: 22
    • Просмотр профиля
А, ой, и правда install, видно спать я очень хотел :coolsmiley:
Увы БД расчитана только на ветку 1.5 файл preinstall.sh сущестувует :(

Оффлайн fl@nker

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Уважаемый dearfear, насколько мне известно, ничто не мешает использовать базу созданную в fb1.5 на серверах более "свежих" версий ... есть только одно ограничение ... без преобразования матаданных базы в UTF8 (понятно чем это грозит) вам придётся отказаться от бекапа ... что конечно не есть гуд, но жить можно ... Откровенно преобразование метаданных базы вполне безболезненно если компоненты которыми вы пользуетесь поддерживают юникод ...
P.S. Возможно я ошибаюсь, если так было бы полезно узнать почему ... ;-)
« Последнее редактирование: 27 Май 2010, 11:28:27 от fl@nker »

 

Страница сгенерирована за 0.054 секунд. Запросов: 22.