Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: AverTV Cardbus: звука нет, а так полный ажур...  (Прочитано 1113 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Psy[H[]

  • Автор темы
  • Активист
  • *
  • Сообщений: 883
  • Маньяк. Ставлю Линух на все что попадется под руку
    • Просмотр профиля
Смотрю в TVtime, помнится еще чем-то пытался, вроде kdetv... видео идет, каналы находит, все в порядке кроме звука - его нет вообще

При втыке устройства в /dev появляются:
mixer1
audio1
dsp1
radio0
vbi0
video0

В микшере появляется устройство SAA7134 (Alsa mixer) с тремя стереоканалами:
Линейный вход
Линейный вход 2
Video

Визуально первые два работают нормально, а вот Video при попытке, скажем так, изменить громкость, дергается и срывает синхронизацию. Плюс выключение кнопочкой под ним не работает (сразу включает обратно)
В "переключателях" висят соответственно три галки на захват, которые почему-то можно включить одновременно.
Собственно любые манипуляции в микшере никакого эффекта не дают, даже шумов и щелчков.

Вывод dmesg касаемо втыка тюнера прилагается.

Куда бурить?

----
дополнение: пробовал открывать в VLC все эти устройства: видео открывать не хочет, а звук идет убыстренными отрывками, где-то 2,5 отрывка в секунду.

[вложение удалено Администратором]
« Последнее редактирование: 03 Июнь 2007, 21:28:04 от Psy[H[] »
Я знаю только то, что ничего не знаю.
                                     

Оффлайн stan

  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Re: AverTV Cardbus: звука нет, а так полный ажур...
« Ответ #1 : 04 Июнь 2007, 12:27:11 »
а от карты звук идет?
через линейный вход или через PCI?
Kubuntu

Оффлайн Psy[H[]

  • Автор темы
  • Активист
  • *
  • Сообщений: 883
  • Маньяк. Ставлю Линух на все что попадется под руку
    • Просмотр профиля
Re: AverTV Cardbus: звука нет, а так полный ажур...
« Ответ #2 : 04 Июнь 2007, 17:14:32 »
Нет, от карты тоже не идет (в смысле тюнеровский звук),
а так карта рабочая, звук еасть :)
Я знаю только то, что ничего не знаю.
                                     

Оффлайн stan

  • Активист
  • *
  • Сообщений: 291
  • Kubuntu
    • Просмотр профиля
Re: AverTV Cardbus: звука нет, а так полный ажур...
« Ответ #3 : 05 Июнь 2007, 10:02:15 »
Нет, от карты тоже не идет (в смысле тюнеровский звук),
а так карта рабочая, звук еасть :)

наверное неправильно вопрос задал...
как звук идет от тюнера к звуковой карте?
Обычно практикуют 2 варианта:
1. Из аудио выхода тюнера проводом в линейный вход звуковухи. (тогда просто надо в alsamixer включить канал line)
2. Напрямую через PCI шину (работает, если есть нормальная поддержка драйвером ядра, в этом случае скорее всего должны работать SAA7134 alsa-mixer)
Kubuntu

Оффлайн Psy[H[]

  • Автор темы
  • Активист
  • *
  • Сообщений: 883
  • Маньяк. Ставлю Линух на все что попадется под руку
    • Просмотр профиля
Re: AverTV Cardbus: звука нет, а так полный ажур...
« Ответ #4 : 07 Июнь 2007, 17:29:26 »
Тюнер Cardbus'овый. То бишь никаких лишних проводов. Значит через PCI.
SAA7134 alsa-mixer присутствует, но... косяки описаны выше.

Значит надо обратить взор на ядро? Не подскажете с чего начать?

Выходит, устройство, которое выводит звук в системе есть, но чтобы с него выводился звук, нужно или чтобы прога его знала (TVtime не знает, а VLC берет звук криво), или чтобы ядро перенаправляло звук с него на другое устройство - так?

P.S. Смущает кривость, с которой всемогущий VLC берет звук...

----
раскопал кое-что:
sox -c 2 -s -w -r 32000 -t ossdsp /dev/dsp1 -t ossdsp -w -r 32000 /dev/dspРаботает! Но звук кривоват. попробовал поиграть со значениями частот дискретизации. Характер искажения меняется, но в общем звук лажовый. - это в tvtime
В kdetv лучше, но с задержкой.

Возможен ли другой способ?
« Последнее редактирование: 07 Июнь 2007, 17:42:36 от Psy[H[] »
Я знаю только то, что ничего не знаю.
                                     

 

Страница сгенерирована за 0.053 секунд. Запросов: 23.