Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Установка libgtk2.0-dev  (Прочитано 2271 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн IfoR

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Установка libgtk2.0-dev
« : 24 Апрель 2010, 16:40:36 »
Здравствуйте! У меня проблема в версиях пакетов. Мне надо поставить пакет libgtk2.0-dev из репозитория. Он у меня версии 2.18.3-1 и он соответственно требует пакет libgtk2.0-0 =2.18.3-1 но у меня стоит версия 2.18.3-1ubuntu2.2 и ставиться libgtk2.0-dev не желает на отрез. Поменять версию libgtk2.0-0 на 2.18.3-1 нельзя, т.к. от версии 2.18.3-1ubuntu2.2 зависит чуть ли не весь gnome пакеты которой имеют версию только x.x.x*ubuntu*. Раньше у меня была такая же проблема с другим пакетом, но тогда я тупо нашёл и поставил (включая зависимые) в нете пакеты с суффиксом ubuntu и всё заработало.
Вопрос: можно как-то безболезненно поставить этот пакет? :)

Моя ОС Ubuntu 9.10 amd64.

P.S. Я не знаю как составить такой запрос в поисковик.  :-\

Оффлайн Nomadian

  • Участник
  • *
  • Сообщений: 232
    • Просмотр профиля
Re: Установка libgtk2.0-dev
« Ответ #1 : 24 Апрель 2010, 17:21:44 »
Это "игра с огнём", но при разработке иногда помогает...

Качаем, именно качаем, а не ставим, сам *.so файл библиотеки. Для понятности примера, пусть он называется dev-lib.so

Помещаем его некий в каталог, например, /devlibs

В каталоге /etc/ld.so.conf.d делаем файл с расширением .conf, в который просто вписываем адрес каталога с нашими библиотеками, т.е. единственная строка будет:
/devlibs
Говорим системе, пересмотреть каталоги с библиотеками:
sudo ldconfigure
Теперь библиотека доступна всем приложениям. Однако, это небезопасно.
« Последнее редактирование: 24 Апрель 2010, 18:15:39 от Nomadian »

Оффлайн Андрюша

  • Участник
  • *
  • Сообщений: 191
    • Просмотр профиля
Re: Установка libgtk2.0-dev
« Ответ #2 : 24 Апрель 2010, 18:08:49 »
Хм, путано как-то всё. Попробуй сделать
sudo aptitude updateи
sudo aptitude install -R libgtk2.0-devКакую именно ошибку будет показывать при установке?

Оффлайн IfoR

  • Автор темы
  • Новичок
  • *
  • Сообщений: 16
    • Просмотр профиля
Re: Установка libgtk2.0-dev
« Ответ #3 : 25 Апрель 2010, 00:12:00 »
Следующие пакеты имеют неудовлетворённые зависимости:
  libexpat1-dev: Зависит: libexpat1 (= 2.0.1-4ubuntu1) но установлен 2.0.1-4ubuntu1.1.
  libglib2.0-dev: Зависит: libglib2.0-0 (= 2.22.2-0ubuntu1) но установлен 2.22.3-0ubuntu1.
  libcairo2-dev: Зависит: libcairo2 (= 1.8.8-2ubuntu1) но установлен 1.8.8-2ubuntu1.1.
  libgtk2.0-dev: Зависит: libgtk2.0-0 (= 2.18.3-1) но установлен 2.18.3-1ubuntu2.2.
Следующие действия разрешат зависимости:

Удалить следующие пакеты:
libglib2.0-data

Установить более старую версию для следующих пакетов:
gtk2-engines-pixbuf [2.18.3-1ubuntu2.2 (now) -> 2.18.3-1 (karmic)]
libcairo2 [1.8.8-2ubuntu1.1 (now) -> 1.8.8-2ubuntu1 (karmic)]
libexpat1 [2.0.1-4ubuntu1.1 (now) -> 2.0.1-4ubuntu1 (karmic)]
libgail-common [2.18.3-1ubuntu2.2 (now) -> 2.18.3-1 (karmic)]
libgail18 [2.18.3-1ubuntu2.2 (now) -> 2.18.3-1 (karmic)]
libglib2.0-0 [2.22.3-0ubuntu1 (now) -> 2.22.2-0ubuntu1 (karmic)]
libgtk2.0-0 [2.18.3-1ubuntu2.2 (now) -> 2.18.3-1 (karmic)]
libgtk2.0-bin [2.18.3-1ubuntu2.2 (now) -> 2.18.3-1 (karmic)]

Счёт 365

Принять данное решение? [Y/n/q/?]

Можно говорить Y ? :)

Если говорить n, то он спрашивает ещё N-ое количество подобных вопросов с ещё большим количеством пакетов.

Пользователь решил продолжить мысль 25 Апрель 2010, 12:08:41:
Опа. В синаптике после включения всех галок в обновлениях появился пакет версии с окончанием ubuntu2.2 . Щас уже ставлю. :)
« Последнее редактирование: 25 Апрель 2010, 14:10:57 от IfoR »

 

Страница сгенерирована за 0.054 секунд. Запросов: 22.