Форум русскоязычного сообщества Ubuntu


За новостями русскоязычного сообщества и Ubuntu в целом можно следить на нашей страничке в Google+

Автор Тема: Виснет web-сервер  (Прочитано 3538 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн NikolasI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Виснет web-сервер
« : 28 Апрель 2010, 09:27:17 »
Здравствуйте!
У меня web-сервер на ubuntu server крутися.
Столкнулсяс такой проблеммой - при большом наплыве посетителей на сайт сервак повисает (забивается вся оперативка (гиг), из 6 гигов swap забивается 3 гига и к базе не достучатьс, да и с серваком в этот момент сложно общаться - через putty команды понимает и обрабатывает минут через 5 после ввода. Причем сам не отвисает, сайты не грузит (только простые html страницы может, а если сайт на cms - то нет (пишет ошибку mysql - to many connections)
У знакомого на работе web-сервер крутится на FreeBSD, он говорит когда у них много посещений просто обработка запросов к сайту дольше идет и все - сервак не вешается... Настраивал тот сервак не он, в связи с чем по настройке ничего не скажет.
Возмо ли как-то добиться чтобы и у меня ubuntu не вешалась?

Оффлайн borman77

  • Новичок
  • *
  • Сообщений: 9
    • Просмотр профиля
Re: Виснет web-сервер
« Ответ #1 : 28 Апрель 2010, 09:39:31 »
Смотрите настройки apache и mysql, почитайте в интернете про оптимизацию apache и mysql гугл выдает массу ссылок на эту тему. Удачи Вам.


Пользователь решил продолжить мысль 28 Апрель 2010, 09:42:38:
Здравствуйте!
У меня web-сервер на ubuntu server крутися.
Столкнулсяс такой проблеммой - при большом наплыве посетителей на сайт сервак повисает (забивается вся оперативка (гиг), из 6 гигов swap забивается 3 гига и к базе не достучатьс, да и с серваком в этот момент сложно общаться - через putty команды понимает и обрабатывает минут через 5 после ввода. Причем сам не отвисает, сайты не грузит (только простые html страницы может, а если сайт на cms - то нет (пишет ошибку mysql - to many connections)
У знакомого на работе web-сервер крутится на FreeBSD, он говорит когда у них много посещений просто обработка запросов к сайту дольше идет и все - сервак не вешается... Настраивал тот сервак не он, в связи с чем по настройке ничего не скажет.
Возмо ли как-то добиться чтобы и у меня ubuntu не вешалась?

Учитесь пользоваться поиском это не сложно https://forum.ubuntu.ru/index.php?topic=2814.0 Читайте, пробуйте, читайте и задавайте вопросы.
« Последнее редактирование: 28 Апрель 2010, 09:42:38 от borman77 »

Оффлайн uid0

  • Активист
  • *
  • Сообщений: 371
    • Просмотр профиля
    • hitetra.ru
Re: Виснет web-сервер
« Ответ #2 : 28 Апрель 2010, 11:02:20 »
и настройки php бы глянуть  ;)
Be root, be different...

Оффлайн MIxan

  • Активист
  • *
  • Сообщений: 285
  • Кто победил, тот и добро!
    • Просмотр профиля
    • Блог вебмастера
Re: Виснет web-сервер
« Ответ #3 : 28 Апрель 2010, 11:21:32 »
конечно, настройки пхп в студию, а так же апача, и мускула и вывод top на время висюка

Оффлайн uid0

  • Активист
  • *
  • Сообщений: 371
    • Просмотр профиля
    • hitetra.ru
Re: Виснет web-сервер
« Ответ #4 : 28 Апрель 2010, 11:36:04 »
ставлю 50р. на то, Что в топе будет пых драться за ресурсы с мускулем ))))))))
Be root, be different...

Оффлайн crapuchino

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Виснет web-сервер
« Ответ #5 : 28 Апрель 2010, 12:19:01 »
да, тут однозначно борьба за ресурсы.
выставите "потолки" для php и mysql, тогда нагрузка будет плавно обрезаться и распределяться

Оффлайн uid0

  • Активист
  • *
  • Сообщений: 371
    • Просмотр профиля
    • hitetra.ru
Re: Виснет web-сервер
« Ответ #6 : 28 Апрель 2010, 12:41:37 »
Да тут сложнее ситуация ! По всей видимости пхп настроен некорректно ! И выделяет памяти на обработку скрипта много... Автор ! Покажите конфиги httpd.conf php.ini my.cnf
Be root, be different...

Оффлайн NikolasI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: Виснет web-сервер
« Ответ #7 : 28 Апрель 2010, 12:56:10 »
В httpd.conf прописано только ServerName
остальные прикладываю
в настройках php сейчас стоит 128М на лимит памяти, до этого было 64 тоже висло, менее 64 скрипт один ругается что ему мало памяти.

Оффлайн uid0

  • Активист
  • *
  • Сообщений: 371
    • Просмотр профиля
    • hitetra.ru
Re: Виснет web-сервер
« Ответ #8 : 28 Апрель 2010, 13:08:47 »
логи apache на момент зависания посмотреть можно ?

Пользователь решил продолжить мысль 28 Апрель 2010, 13:11:14:
Ах да ! И версии всего этого дела бы посмотреть !

apache -v
php -v
mysql -v
« Последнее редактирование: 28 Апрель 2010, 13:11:14 от dj-patrik »
Be root, be different...

Оффлайн NikolasI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: Виснет web-сервер
« Ответ #9 : 28 Апрель 2010, 18:57:31 »
Версии:
PHP 5.2.10-2ubuntu6.4 with Suhosin-Patch 0.9.7 (cli) (built: Jan  6 2010 22:41:56)
mysql  Ver 14.14 Distrib 5.1.37, for debian-linux-gnu (i486) using  EditLine wrapper
Server version: Apache/2.2.12 (Ubuntu)
Вообше-то mysql -V

логи приложил, название сайта заменено на si_te
завис примерно в 13:50 - 13:55 и до 18:40 в течении этого времени пару раз перезагружали сервак пока не выяснилась причина большого обращения на сайт и она не была устранена.

Оффлайн crapuchino

  • Новичок
  • *
  • Сообщений: 25
    • Просмотр профиля
Re: Виснет web-сервер
« Ответ #10 : 29 Апрель 2010, 00:21:18 »
эм... а вас случайно там не досят? совсем недавно с этой хренью сталкивался

Оффлайн uid0

  • Активист
  • *
  • Сообщений: 371
    • Просмотр профиля
    • hitetra.ru
Re: Виснет web-сервер
« Ответ #11 : 29 Апрель 2010, 09:12:45 »
У Вас проблема в [error] server reached MaxClients setting, consider raising the MaxClients setting... Осталось только с умом конфиг поправить !

Пользователь решил продолжить мысль 29 Апрель 2010, 09:19:50:
Покажите конфиг апача !
/etc/apache2/apache2.conf - вроде так называется, насколько я помню в Ubuntuх
« Последнее редактирование: 29 Апрель 2010, 09:19:50 от dj-patrik »
Be root, be different...

Оффлайн NikolasI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: Виснет web-сервер
« Ответ #12 : 29 Апрель 2010, 13:12:58 »
эм... а вас случайно там не досят? совсем недавно с этой хренью сталкивался
в этот раз точно нет - просто была сделана переадресация любых запросов в интернет с порядка 100 внутрисетевых компов на сайт - вот сервак и не потянул такого количества обращений.
У Вас проблема в [error] server reached MaxClients setting, consider raising the MaxClients setting... Осталось только с умом конфиг поправить !
Покажите конфиг апача !
/etc/apache2/apache2.conf - вроде так называется, насколько я помню в Ubuntuх
Знать бы как :)
Файл приложил :)
Мощности сервака будут скоро (думаю к лету или летом) увеличены путем переноса с железного севера на виртуальный на базе Hyper-V, чувствую с переносом придется помучаться тоже...

Оффлайн uid0

  • Активист
  • *
  • Сообщений: 371
    • Просмотр профиля
    • hitetra.ru
Re: Виснет web-сервер
« Ответ #13 : 29 Апрель 2010, 14:20:10 »
Пробуй заменить
<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

на

<IfModule mpm_prefork_module>
StartServers 15
MinSpareServers 15
MaxSpareServers 20
ServerLimit 150
MaxClients 150
KeepAliveTimeout 3
MaxKeepAliveRequests 100
MaxRequestsPerChild 2000
</IfModule>
Be root, be different...

Оффлайн NikolasI

  • Автор темы
  • Новичок
  • *
  • Сообщений: 41
    • Просмотр профиля
Re: Виснет web-сервер
« Ответ #14 : 29 Апрель 2010, 17:18:46 »
Хорошо, попробую когда буду рядом с сервером (удаленно что-то не охота менять - вдруг подвиснет...)
Вот только боюсь на следущей неделе смогу... приболел :(

 

Страница сгенерирована за 0.057 секунд. Запросов: 23.