Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Проблема с выводом сайта в интернет  (Прочитано 1356 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн LaMort

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
LAMP установлен капля в каплю по мануалу с сайта
ссылка

Все норм на компе с убунтой сайт открывается вопрос как теперь вывести его в локальную сеть и инет сколько не искал ответов в интернете ничего не нашел везде только написано про установку

p.s.
ubuntu 9.10 дектоп

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25936
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #1 : 30 Апрель 2010, 05:04:15 »
Он и так уже в локальной сети, ничего делать не надо. Ответ на вторую часть вопроса невозможен на основе предоставленной информации.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн VolCh

  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #2 : 30 Апрель 2010, 05:13:36 »
Если IP внешний, то сайт уже должен быть и в интернете http://your.I.P.addres/

Оффлайн LaMort

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #3 : 30 Апрель 2010, 05:24:48 »
файлы закинуты в папку (сайта)
но по локальному IP открывается It works!
локальная сеть идет через роутер
« Последнее редактирование: 30 Апрель 2010, 05:32:46 от LaMort »

Оффлайн VolCh

  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #4 : 30 Апрель 2010, 05:43:22 »
ааа... там виртуальный хост? тогда надо, чтоб ServerName (или заменить ServerName на локальный IP, но не уверен) был прописан в /etc/hosts на тех машинах локалки (включая собствеено сервер) откуда пробуешь зайти, ну или в DNS локалки прописать servername

для доступа извне надо пробрасывать порт на роутере и опять-таки чтобы машины снаружи знали ServerName как внешний IP роутера (традиционный путь - регистрация домена обычная)


Оффлайн uid0

  • Активист
  • *
  • Сообщений: 371
    • Просмотр профиля
    • hitetra.ru
Re: Проблема с выводом сайта в интернет
« Ответ #5 : 30 Апрель 2010, 09:53:53 »
как интернет организован в сети ?
Be root, be different...

Оффлайн LaMort

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #6 : 30 Апрель 2010, 10:16:11 »
Машина подключена к роутеру... к роутеру приходит шнур би-лайна с их локальной сетью и интернетом... роутер все это дело раздает. сайт не открывается ни в какой локалке не в локалке роутера (192.168.0.ххх) ни в локалке би лайна (10.210.хх.хх) и задача стоит не править на каждом компе хостс а просто вывести сайт в лан

Оффлайн uid0

  • Активист
  • *
  • Сообщений: 371
    • Просмотр профиля
    • hitetra.ru
Re: Проблема с выводом сайта в интернет
« Ответ #7 : 30 Апрель 2010, 10:34:41 »
по ip, при правильных настройках апача, должен сайт открываться везде ! покажите настройки apache2.conf

Пользователь решил продолжить мысль 30 Апрель 2010, 10:41:44:
Капля в каплю значит ? Получается, что вы создали виртуальный хост с каким нить name.чё_то_там ? всё правильно в таком случае ! если вы хотит, что бы по ip открывался сайт, то и хост нужно сделать с таким именем или править дефолтный хост /etc/apache2/sites-available/ помоему он так и называется default
« Последнее редактирование: 30 Апрель 2010, 10:41:44 от dj-patrik »
Be root, be different...

Оффлайн LaMort

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #8 : 30 Апрель 2010, 10:46:29 »
В ServerName локальный IP?

Пользователь решил продолжить мысль 30 Апрель 2010, 08:54:43:
поменял server name в apache2.conf и в sites-available в файле шаблона теперь нигде сайт не открывается везде открывается страничка It works

Пользователь решил продолжить мысль 30 Апрель 2010, 11:02:10:
Прикладываю apache2.conf
« Последнее редактирование: 30 Апрель 2010, 11:02:25 от LaMort »

Оффлайн uid0

  • Активист
  • *
  • Сообщений: 371
    • Просмотр профиля
    • hitetra.ru
Re: Проблема с выводом сайта в интернет
« Ответ #9 : 30 Апрель 2010, 11:44:39 »
так !!! вообщем вернуть обратно ServerName как был, покажи мне выводы

ls /etc/apache2/sites-available/
cat /etc/apache2/sites-available/default

последний точно не помню как файл называется
Be root, be different...

Оффлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25936
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #10 : 30 Апрель 2010, 15:36:22 »
Так и называется.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн LaMort

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #11 : 11 Май 2010, 16:18:42 »
Давно не был интернета не было(
вот выводы
morty@morty-laptop:~$ ls /etc/apache2/sites-available/
default  default~  default-ssl  template  template~  yaap  yaap~
morty@morty-laptop:~$ cat /etc/apache2/sites-available/default
<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName 192.168.0.133
DocumentRoot /var/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
morty@morty-laptop:~$

Дефаулт я не правил правил темплейт вот вывод
morty@morty-laptop:~$ cat /etc/apache2/sites-available/template
<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName yaap
DirectoryIndex index.php index.html index.htm

DocumentRoot /home/morty/web/www/
<Directory /home/morty/web/www/>
Options FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel notice

CustomLog /var/log/apache2/access.log combined

</VirtualHost>
« Последнее редактирование: 11 Май 2010, 16:20:33 от LaMort »

Оффлайн VolCh

  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #12 : 11 Май 2010, 16:24:47 »
Так ваш сайт лежит в /var/www или ещё где-то? yaap - это не он случайно? Тогда надо cat /etc/apache2/sites-available/yaap

Оффлайн LaMort

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #13 : 11 Май 2010, 16:43:05 »
morty@morty-laptop:~$ cat /etc/apache2/sites-available/yaap
<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName yaap
DirectoryIndex index.php index.html index.htm

DocumentRoot /home/morty/web/www/
<Directory /home/morty/web/www/>
Options FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel notice

CustomLog /var/log/apache2/access.log combined

</VirtualHost>
morty@morty-laptop:~$

Оффлайн VolCh

  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
Re: Проблема с выводом сайта в интернет
« Ответ #14 : 11 Май 2010, 16:54:27 »
Запишите в ServerName для дефолта "localhost" (без кавчек), а в ServerName для yaap - IP сервера

 

Страница сгенерирована за 0.058 секунд. Запросов: 22.