Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: Не применяются настройки языка (Ubuntu 10.04)  (Прочитано 14248 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн adsargon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
После установки и применения русской локализации Ubuntu язык Gnome остался английским, хотя все остальные приложения на русском.
Вывод команды locale

ad@ad-desktop:~$ locale
LANG=ru_RU.utf8
LANGUAGE=en_US:en
LC_CTYPE="ru_RU.utf8"
LC_NUMERIC="ru_RU.utf8"
LC_TIME="ru_RU.utf8"
LC_COLLATE="ru_RU.utf8"
LC_MONETARY="ru_RU.utf8"
LC_MESSAGES="ru_RU.utf8"
LC_PAPER="ru_RU.utf8"
LC_NAME="ru_RU.utf8"
LC_ADDRESS="ru_RU.utf8"
LC_TELEPHONE="ru_RU.utf8"
LC_MEASUREMENT="ru_RU.utf8"
LC_IDENTIFICATION="ru_RU.utf8"
LC_ALL=

Оффлайн volgautc

  • Активист
  • *
  • Сообщений: 537
    • Просмотр профиля
Re: Не применяются настройки языка (Ubuntu 10.04)
« Ответ #1 : 30 Апрель 2010, 14:44:55 »
Перезагружались?

Оффлайн adsargon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Не применяются настройки языка (Ubuntu 10.04)
« Ответ #2 : 30 Апрель 2010, 14:47:05 »
да

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
Re: Не применяются настройки языка (Ubuntu 10.04)
« Ответ #3 : 30 Апрель 2010, 14:50:03 »
простите, а что это за строчка?
LANGUAGE=en_US:en
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн volgautc

  • Активист
  • *
  • Сообщений: 537
    • Просмотр профиля
Re: Не применяются настройки языка (Ubuntu 10.04)
« Ответ #4 : 30 Апрель 2010, 14:56:58 »
Система - Администрирование - Язык системы. Должно быть

Если не так, то жмёте Установка,удаление языков и выбираете русский:

Перезагружаетесь.
Если всё плохо, то проверить репы.

П.С. Кстати мой locale
(Нажмите, чтобы показать/скрыть)
« Последнее редактирование: 30 Апрель 2010, 15:01:50 от volgautc »

Оффлайн adsargon

  • Автор темы
  • Новичок
  • *
  • Сообщений: 3
    • Просмотр профиля
Re: Не применяются настройки языка (Ubuntu 10.04)
« Ответ #5 : 30 Апрель 2010, 15:01:00 »
ок, строку
LANGUAGE="en_US:en"
сменил на
LANGUAGE="ru_RU:ru"
проблема решилась, спасибо

Оффлайн Neo_Andersen

  • Новичок
  • *
  • Сообщений: 2
    • Просмотр профиля
Здравствуйте! Мучаюсь с той же проблемой, в поисках решения зашёл сюда. У меня вот что:
val@val-desktop:~$ locale
LANG=ru_RU.utf8
LANGUAGE=en_DK:en_GB:en
LC_CTYPE="ru_RU.utf8"
LC_NUMERIC="ru_RU.utf8"
LC_TIME="ru_RU.utf8"
LC_COLLATE="ru_RU.utf8"
LC_MONETARY="ru_RU.utf8"
LC_MESSAGES="ru_RU.utf8"
LC_PAPER="ru_RU.utf8"
LC_NAME="ru_RU.utf8"
LC_ADDRESS="ru_RU.utf8"
LC_TELEPHONE="ru_RU.utf8"
LC_MEASUREMENT="ru_RU.utf8"
LC_IDENTIFICATION="ru_RU.utf8"
LC_ALL=
Язык системы-английский, только кое-где встречаются русские слова.
Не знаю, как сменить язык на русский (кроме: Система - Администрирование - Язык системы, что почему-то не работает), поэтому попробовал:
val@val-desktop:~$ LANGUAGE="ru_RU:ru"
Получил:
val@val-desktop:~$ locale
LANG=ru_RU.utf8
LANGUAGE=ru_RU:ru
LC_CTYPE="ru_RU.utf8"
LC_NUMERIC="ru_RU.utf8"
LC_TIME="ru_RU.utf8"
LC_COLLATE="ru_RU.utf8"
LC_MONETARY="ru_RU.utf8"
LC_MESSAGES="ru_RU.utf8"
LC_PAPER="ru_RU.utf8"
LC_NAME="ru_RU.utf8"
LC_ADDRESS="ru_RU.utf8"
LC_TELEPHONE="ru_RU.utf8"
LC_MEASUREMENT="ru_RU.utf8"
LC_IDENTIFICATION="ru_RU.utf8"
LC_ALL=
но смены языка не произошло, а при перезагрузке всё становится, как было раньше.
Помогите пожалуйста!

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
попробуй
export LANGUAGE=ru_RU:ru
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн Andreysen

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Привет. У меня та же проблема. Обновился с 9.10 до 10.04 (через инет) и практически весь интерфейс стал английским. Открываю System-Administration-Language Support, появляется окно "The language support is not installed completely" и предлагает установить language-support-input-ru. Установил, но выбор русского языка неактивен, но настройки Даты и форматов применяются. Удаляю английский язык через Install/Remove Languages, остается только русский. Перезагружаю комп -  интерфейс английский, хотя такого языка в списке нет (только русский).
Когда снова открываю System-Administration-Language Support, то опять же предлагается установить language-support-input-ru. Процесс установки проходит, но этот пакет реально не установлен.
Помогите, пожалуйста, решить проблему или укажите ссылку, где проблема решена (поиск в течении дня не дал результатов). Некоторые сотрудники  не знают английского и не могут толком пользоваться ноутбуком.
Вышеописанную команду применял.

andrey@notik:~$ locale
LANG=ru_UA.utf8
LANGUAGE=en_US:en
LC_CTYPE="ru_UA.utf8"
LC_NUMERIC="ru_UA.utf8"
LC_TIME="ru_UA.utf8"
LC_COLLATE="ru_UA.utf8"
LC_MONETARY="ru_UA.utf8"
LC_MESSAGES="ru_UA.utf8"
LC_PAPER="ru_UA.utf8"
LC_NAME="ru_UA.utf8"
LC_ADDRESS="ru_UA.utf8"
LC_TELEPHONE="ru_UA.utf8"
LC_MEASUREMENT="ru_UA.utf8"
LC_IDENTIFICATION="ru_UA.utf8"
LC_ALL=

« Последнее редактирование: 18 Май 2010, 10:41:19 от Andreysen »

Оффлайн лесной_зонтик

  • Старожил
  • *
  • Сообщений: 2223
  • Просьба на количество сообщений не смотреть.
    • Просмотр профиля
А если разлогиниться, выбрать нужного пользователя и внизу на панели выбрать нужный язык по умолчанию?
Моя мечта поставить на комп Linux, Unix, *BSD, Mac OS X, OpenSolaris, OS/2, Windows.
Не спрашивайте зачем. Сам не знаю ???

Оффлайн Andreysen

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Попробовал выставить по умолчанию русский на панели логина. Меню и некоторые программы все так же на английском. Решения не найдено  :(
« Последнее редактирование: 23 Май 2010, 16:55:25 от Andreysen »

Оффлайн VolCh

  • Активист
  • *
  • Сообщений: 543
    • Просмотр профиля
sudo update-locale LANG=ru_RU.UTF8 может так поможет?

Оффлайн Andreysen

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
sudo update-locale LANG=ru_RU.UTF8 может так поможет?
Команду выполнял. Вывод команды locale в терминале менялся на русский.
Но после перезагрузки компьютера возвращается все назад. Похоже, настройки не сохраняются.

Удалил все языки в меню Langugе support. Перегрузил комп. Потом установил русский язык. Опять английский интерфейс.

Есть подозрение, что не устанавливается пакет language-support-input-ru
В синаптике его нет. В меню Langugе support постоянно предлагается установить этот пакет.

Вот результат команды update-locale LANG=ru_RU.UTF8 после всех этих манипуляций:
andrey@notik:~$ sudo update-locale LANG=ru_RU.UTF8
[sudo] password for andrey:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = "en_US:en",
   LC_ALL = (unset),
   LANG = "en_US.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
*** update-locale: Error: LANGUAGE ("en_US:en") is not compatible with LANG (ru_RU.UTF8)
« Последнее редактирование: 24 Май 2010, 12:47:41 от Andreysen »

Оффлайн vensder

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
    • Linux For Children
У друга была подобная проблема, решили следующим методом:

в терминале набираем:

sudo gedit /etc/default/locale
удаляем в файле все строки и вставляем только одну:

LANG=ru_RU.UTF8
сохраняем, закрываем.

Далее:

sudo gedit /etc/environment
и удаляем строки:

LANGUAGE="en_GB:en"
LANG="en_GB.UTF-8"

вместо них пишем:

LANG="ru_RU.utf8"
сохраняем, закрываем.

Проблема у друга решилась, после логаута и ребута язык интерфейса с английского сменился на русский.
« Последнее редактирование: 25 Май 2010, 15:59:23 от vensder »

Оффлайн Andreysen

  • Новичок
  • *
  • Сообщений: 12
    • Просмотр профиля
Огромное спасибо vensder. С помощью Вашего метода все получилось!!!

 

Страница сгенерирована за 0.09 секунд. Запросов: 22.