Форум русскоязычного сообщества Ubuntu


Увидели сообщение с непонятной ссылкой, спам, непристойность или оскорбление?
Воспользуйтесь ссылкой «Сообщить модератору» рядом с сообщением!

Автор Тема: И снова проблемы с USB 2.0 Ubuntu 7.10  (Прочитано 4728 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Shadow486

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
И снова проблемы с USB 2.0 Ubuntu 7.10
« : 07 Июнь 2007, 15:10:11 »
Добрый день, уважаемые!

Есть ноут RoverBook Nautilus Z550. Как и у всех ноутов с линуксами у него проблема  :(
Итак имеем:
$uname -a
Linux ubuntu 2.6.22-6-generic #1 SMP Fri Jun 1 19:24:12 GMT 2007 i686 GNU/Linux

$lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 04)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 04)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce Go 6600] (rev a2)
06:04.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev f0)
06:06.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
06:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
06:09.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
06:09.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
06:09.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller

$sudo rmmod ehci_hcd  //без этого lsusb вообще виснет, а минут через 5 сообщает, что девайсов нет

$lsusb
Bus 003 Device 001: ID 0000:0000 
Bus 004 Device 001: ID 0000:0000 
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 002: ID 04e8:1623 Samsung Electronics Co., Ltd
Bus 001 Device 001: ID 0000:0000
 
$cat /proc/interrupts
           CPU0       
  0:     423204    XT-PIC-XT        timer
  1:       4169    XT-PIC-XT        i8042
  2:          0    XT-PIC-XT        cascade
  7:          2    XT-PIC-XT        parport0
  8:          2    XT-PIC-XT        rtc
  9:    3713499    XT-PIC-XT        acpi
 10:       2395    XT-PIC-XT        ohci1394, ipw2200, Intel ICH6
 11:     100000    XT-PIC-XT        uhci_hcd:usb1, uhci_hcd:usb2, uhci_hcd:usb3, uhci_hcd:usb4, tifm_7xx1, saa7133[0], saa7133[0], eth2
 12:     116050    XT-PIC-XT        i8042
 14:      32186    XT-PIC-XT        libata
 15:          0    XT-PIC-XT        libata
NMI:          0
LOC:          0
ERR:          0
MIS:          0

$cat /proc/usb/devices

T:  Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.22-6-generic uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:1d.3
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.22-6-generic uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:1d.2
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.22-6-generic uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:1d.1
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.22-6-generic uhci_hcd
S:  Product=UHCI Host Controller
S:  SerialNumber=0000:00:1d.0
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=04e8 ProdID=1623 Rev= 1.00
S:  Manufacturer=Samsung
S:  Product=Mighty Drive   
S:  SerialNumber=07541A900A34
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=200mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=  64 Ivl=1ms



Внимательно читал следующие ссылки на launchpad.net
1. https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.17/+bug/53972
2. https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/24925
3. https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/54273
4. https://launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/94540
5. https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/54419

и пробовал следовать рекомендациям:
1) выгружал модуль ehci_hcd. Результат: помогло, НО СКОРОСТЬ 1.1 НЕ УДОВЛЕТВОРЯЕТ
2) использовать параметры загрузки ядра acpi=off, noapic. Результат: НЕ ПОМОГЛО
В результате добился только того, что USB работает по протоколу 1.1, что меня не устраивает, т.к. к ноуту я подключаю внешний SATA-винт по USB
Здесь выдержки из журналов:
1. модуль ehci_hcd загружен
Jun  7 10:47:37 ubuntu kernel: [ 4058.896000] usb 1-4: new high speed USB device using ehci_hcd and address 2
Jun  7 10:47:42 ubuntu kernel: [ 4063.896000] ehci_hcd 0000:00:1d.7: Unlink after no-IRQ?  Controller is probably using the wrong IRQ.
Jun  7 10:47:53 ubuntu kernel: [ 4074.440000] usb 1-4: device not accepting address 2, error -110
Jun  7 10:47:53 ubuntu kernel: [ 4074.552000] usb 1-4: new high speed USB device using ehci_hcd and address 3
Jun  7 10:48:08 ubuntu kernel: [ 4090.096000] usb 1-4: device not accepting address 3, error -110
Jun  7 10:48:08 ubuntu kernel: [ 4090.208000] usb 1-4: new high speed USB device using ehci_hcd and address 4
Jun  7 10:48:19 ubuntu kernel: [ 4100.632000] usb 1-4: device not accepting address 4, error -110

2. Модуль ehci_hcd выгружен
Jun  7 13:45:25 ubuntu kernel: [ 3762.196000] usbcore: registered new interface driver libusual
Jun  7 13:45:25 ubuntu kernel: [ 3762.288000] Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
Jun  7 13:45:25 ubuntu kernel: [ 3762.292000] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Jun  7 13:45:25 ubuntu kernel: [ 3762.296000] Initializing USB Mass Storage driver...
Jun  7 13:45:25 ubuntu kernel: [ 3762.296000] scsi2 : SCSI emulation for USB Mass Storage devices
Jun  7 13:45:25 ubuntu kernel: [ 3762.300000] usb-storage: device found at 2
Jun  7 13:45:25 ubuntu kernel: [ 3762.300000] usb-storage: waiting for device to settle before scanning
Jun  7 13:45:25 ubuntu kernel: [ 3762.300000] usbcore: registered new interface driver usb-storage
Jun  7 13:45:25 ubuntu kernel: [ 3762.300000] USB Mass Storage support registered.
Jun  7 13:45:26 ubuntu hcid[4884]: Sending read scan enable command failed: Connection timed out (110)
Jun  7 13:45:31 ubuntu kernel: [ 3767.424000] usb-storage: device scan complete

Внимание вопрос: неужели эта проблема в русскоговорящем сообществе только у меня? Давайте попытаемся вмете разобраться с этим багом!

Оффлайн Shadow486

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #1 : 08 Июнь 2007, 08:54:16 »
Неужели никто не сталкиваля? Судя по всему, что я прочитал проблема достаточно распространенная на ноутах.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #2 : 08 Июнь 2007, 14:01:17 »
Видимо, мало камикадзе сидящих на 7.10

Оффлайн Shadow486

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #3 : 08 Июнь 2007, 14:42:52 »
to Kwah : на счет камикадзе вопрос спорный, но на 6.04 была та же фигня.

Оффлайн Kwah

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 1442
  • Ubuntu 17.10
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #4 : 08 Июнь 2007, 15:03:11 »
Хм. На само деле, я догадываюсь, что ты скорее всего пользуешься Ubuntu 7.04 aka Feisty Fawn... Не удержался :coolsmiley:

Оффлайн Shadow486

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #5 : 09 Июнь 2007, 13:46:00 »
Сначала была 7.04, потом поставил 7.10, но это рояля не играет в данной ситуации. Пробовал другие дистры на этом ноуте: Fedora 6 и ASP не помню какой - те же яйца, вид в профиль. Как лечить это железо понятия не имею. На настольном компе такой проблемы нет.

Оффлайн stepanov

  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #6 : 03 Август 2007, 11:33:41 »
Таже самая проблема на Kubuntu 7.04 aka Feisty на десктопе. Low speed USB устройства работают, а вот hight speed (USB хаб и подключенные к нему Kingston флешка, D-link Bluetooth адаптер и вебкамера от D-Link) - нет. Причем один раз при загрузке с apic=off каким-то магическим образом заработало а часа резе два хаб отвалился и теперь загрузка без APIC не помогает совсем. До Kubuntu на этом же компе стояла Fedora Core 1. С ней таких проблем не было.

Буду благодарен за любую помощь в решении этой проблемы. А пока попробую работать без ehci_hcd.

Оффлайн IgorR

  • Новичок
  • *
  • Сообщений: 39
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #7 : 03 Август 2007, 14:29:33 »
Попробуй добавить при загрузке параметр для ядра pci=routeirq, помоему так. Вроде как он заставляет ядро по другому назначать прерывания устройствам.

Оффлайн stepanov

  • Новичок
  • *
  • Сообщений: 20
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #8 : 03 Август 2007, 15:49:05 »
Спасибо, попробую. На крайний случай либо буду пользовать USB 1.1, либо надо откатиться на ядро 2.6.15, где собственно USB 2.0 работали прекрасно, если верить многочисленным баг репортам на Ubuntu.com

Оффлайн Shadow486

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #9 : 14 Август 2007, 23:42:45 »
Попробуй добавить при загрузке параметр для ядра pci=routeirq, помоему так. Вроде как он заставляет ядро по другому назначать прерывания устройствам.
Пробовал не помогает. С apic=off та же история, только хайспид на USB вообще не работал. Откатил на ядро 2.6.12 - работает. Пытаюсь сравнить изменения в модулях хайспид USB, но видимо в этом не силен, т.к. изменения-то нашел, а вот поправить код так, чтобы скомпилилось новое ядро это видимо только для гуру. Может поможет кто?

Оффлайн Denis Konstantinov

  • Активист
  • *
  • Сообщений: 864
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #10 : 15 Август 2007, 10:21:09 »
Если есть возможность скачай ядро с оффсайта и попробуй собрать сам может заработает?
AltYo консоль для Gtk3 в стиле консоли quake https://forum.ubuntu.ru/index.php?topic=198594.0

Оффлайн Shadow486

  • Автор темы
  • Новичок
  • *
  • Сообщений: 18
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #11 : 07 Сентябрь 2007, 23:47:22 »
Друзья! Решение найдено! Ура!

Достаточно было добавь две опции при загрузке ядра в /boot/grub/grub.conf

irqpoll pci=routeirq
и все закрутилось, ура!

ЗЫ: правда саунд так и не заработал, но ведь большая часть проблемы решена!

Оффлайн LBM

  • Новичок
  • *
  • Сообщений: 6
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #12 : 13 Октябрь 2007, 01:32:50 »
Вчера появилась такая же проблема. Неожиданно отключились внешние жёсткий диск и DVD-привод. После повторного подключения они не обнаруживались, в dmesg были ошибки[  125.025217] usb 4-2: new high speed USB device using ehci_hcd and address 2
[  125.137210] usb 4-2: device descriptor read/64, error -32
Точно так же отгрузка модуля ehci_hcd позволила устройства опознать, но с такой скоростью работать с ними невозможно...

Попробовал дописатьirqpoll pci=routeirqНикакого эффекта.
Правда вот у меня Feisty 7.04...

Странный баг, самое смешное, что никто толком не может сказать в чём его причина. Версии разные, и решения тоже.

Смешно, да не очень...

Оффлайн sa-12

  • Новичок
  • *
  • Сообщений: 11
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #13 : 13 Октябрь 2007, 14:37:22 »
Друзья! Решение найдено! Ура!

Достаточно было добавь две опции при загрузке ядра в /boot/grub/grub.conf

irqpoll pci=routeirq
и все закрутилось, ура!

ЗЫ: правда саунд так и не заработал, но ведь большая часть проблемы решена!
У меня нет в этой дерриктории (/boot/grub/) файла grub.conf. В нем же, я так понял, необходимо прописывать irqpoll pci=routeirq. Мне то же эта проблема весь мозг выела.

Оффлайн SeaJey

  • Активист
  • *
  • Сообщений: 770
  • Electronic Knight
    • Просмотр профиля
Re: И снова проблемы с USB 2.0 Ubuntu 7.10
« Ответ #14 : 13 Октябрь 2007, 14:47:16 »
Цитировать
У меня нет в этой дерриктории (/boot/grub/) файла grub.conf.
Попробуй создать и прописать строки (с правами разобраться не забудь)
Или в menu.lst в строке загружаемого ядра допиши.

 

Страница сгенерирована за 0.063 секунд. Запросов: 22.