Форум русскоязычного сообщества Ubuntu


Хотите сделать посильный вклад в развитие Ubuntu и русскоязычного сообщества?
Помогите нам с документацией!

Автор Тема: Браузеры не отправляют сообщения  (Прочитано 1686 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Agita

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
    • Интернета кусок
Всем здрасте.

Несколько дней назад, возможно, после какого либо обновления (они настроены на автоматическую установку) появилась следующая проблема с интернетом: При попытке отправить сообщение на форумах или вконтакте, браузер (любой) долго думает (крутится аяксовый индикатор отправки), после чего вылезает окошко на сохранение *.php файла. Сообщение при этом не отправляется.
При этом не отправляются только длинные сообщения (короткие - из 2-3 слов отправляются без проблем).

Началось это на Ubuntu 9.10. Сегодня поставил 10.04 (соответственно, пробовал на свежеустановленной системе) - такая же проблема.
Пробовал на огнелисе (3.6.3 и 3.6.5pre), опере, хроме, даже из под вайна в огнелисе то же самое.
Гугль подсказал попробовать похимичить с явой. Ставил sun java 6 вместо openjdk, который по умолчанию в десятке. Не помогло. Изменилось только то, что вместо 10-15 минут перед запросом на сохранение браузеры стали думать по 2-3 минуты.

В сетке еще два компа и ноут (winXPsp3 и win7) - со всех отправляется нормально.

Интернет перелопалил как мог, была точно такая-же проблема на каком-то форуме, у ТС была Ubuntu 9.04 на eeepc, но парню так и не ответили.

Помогите, а? Хотя-бы в какую сторону копать?
« Последнее редактирование: 01 Май 2010, 23:08:35 от Agita »

Онлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25965
    • Просмотр профиля
Re: Браузеры не отправляют сообщения
« Ответ #1 : 02 Май 2010, 00:01:16 »
tracepath до проблемного узла для начала.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Agita

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
    • Интернета кусок
Re: Браузеры не отправляют сообщения
« Ответ #2 : 02 Май 2010, 01:13:35 »
1: 192.168.2.3 (192.168.2.3)          0.185ms pmtu 1500
1: no reply
2: no reply
3: no reply
4: no reply
...

Tracert на других машинах тоже выдает "превышен интервал ожидания запроса".
При этом все пинги проходят.

На маршрутизаторе блокировок не стоит, на модеме тоже (оба сбрасывал к заводским настройкам). Фаерволы отключал.

 :'(

Онлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25965
    • Просмотр профиля
Re: Браузеры не отправляют сообщения
« Ответ #3 : 02 Май 2010, 02:31:58 »
Попробуй
sudo iptables -t mangle -I FORWARD -o выходной интерфейс -j TCPMSS --set-mss 1460
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Agita

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
    • Интернета кусок
Re: Браузеры не отправляют сообщения
« Ответ #4 : 02 Май 2010, 02:59:03 »
iptables: Invalid argument. Run 'dmesg' for more information
dmesg:
ip_tables: TCPMSS target: only valid for protocol 6

Онлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25965
    • Просмотр профиля
Re: Браузеры не отправляют сообщения
« Ответ #5 : 02 Май 2010, 03:04:47 »
Ну и прописал бы... "Протокол 6" = tcp
sudo iptables -t mangle -I FORWARD -o выходной интерфейс -p tcp -j TCPMSS --set-mss 1460
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Agita

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
    • Интернета кусок
Re: Браузеры не отправляют сообщения
« Ответ #6 : 02 Май 2010, 03:14:23 »
С iptables не знаком практически :( Да и в целом настолько в матчасть не приходилось раньше углубляться.

dmesg:
xt_TCPMSS: Only works on TCP SYN packets

Онлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25965
    • Просмотр профиля
Re: Браузеры не отправляют сообщения
« Ответ #7 : 02 Май 2010, 03:32:35 »
Надо будет где-нит прилепить это дело... или домашний сервер наконец добить до нормальной работы (там тож придётся прибивать MSS... всё руки не дойдут)

А ещё меня клюнуло, что это ты на локальном компе писать будешь...
Так что...

sudo iptables -t mangle -F FORWARD
sudo iptables -t mangle -I OUTPUT -o выходной интерфейс -p tcp -m tcp --tcp-flags SYN,RST SYN -j TCPMSS --set-mss 1460
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Agita

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
    • Интернета кусок
Re: Браузеры не отправляют сообщения
« Ответ #8 : 02 Май 2010, 03:54:26 »
ДА! Спасибо огромное! Сообщения отправляются!
Просто громаднейшее спасибо! Я уже сутки мучался, начал всю надежду терять.

ЗЫ: Читаю про tcp mss, начинаю догонять, из-за чего всё было...

Онлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25965
    • Просмотр профиля
Re: Браузеры не отправляют сообщения
« Ответ #9 : 02 Май 2010, 04:01:52 »
Тогда
sudo -i
echo -e "#! /sbin/iptables-restore\n`iptables-save`" > /etc/network/if-up.d/iptables.rules
chmod +x /etc/network/if-up.d/iptables.rules

должно сохранить настройки на... надолго.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Agita

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
    • Интернета кусок
Re: Браузеры не отправляют сообщения
« Ответ #10 : 02 Май 2010, 19:30:15 »
Сделал.
Еще раз спасибо за помощь!

Оффлайн Agita

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
    • Интернета кусок
Re: Браузеры не отправляют сообщения
« Ответ #11 : 06 Май 2010, 21:10:35 »
Опять началось то-же самое :(
Запись в /etc/network/if-up.d/iptables.rules осталась.
Пробовал удалить и проделать всё заново - не помогло.

Утром всё нормально работало :(

Онлайн AnrDaemon

  • Заслуженный пользователь
  • Старожил
  • *
  • Сообщений: 25965
    • Просмотр профиля
Re: Браузеры не отправляют сообщения
« Ответ #12 : 06 Май 2010, 23:45:34 »
Тогда полируй мозги провайдеру. Возможно, у него просто напросто канал проседает.
Хотите получить помощь? Потрудитесь представить запрошенную информацию в полном объёме.

Прежде чем [Отправить], нажми [Просмотр] и прочти собственное сообщение. Сам-то понял, что написал?…

Оффлайн Agita

  • Автор темы
  • Новичок
  • *
  • Сообщений: 8
    • Просмотр профиля
    • Интернета кусок
Re: Браузеры не отправляют сообщения
« Ответ #13 : 07 Май 2010, 00:45:09 »
Дыкть, под виндой-то нормально всё...

Оффлайн Роман32

  • Новичок
  • *
  • Сообщений: 1
    • Просмотр профиля
Re: Браузеры не отправляют сообщения
« Ответ #14 : 10 Июль 2010, 15:35:02 »
Таже самая история...только вышеуказанные строки ни какого эфекта не дали__((

Пользователь решил продолжить мысль 11 Июль 2010, 23:06:53:
народ ну что ни кто не занет.? как с этим бороться*
« Последнее редактирование: 11 Июль 2010, 23:06:53 от Роман32 »

 

Страница сгенерирована за 0.056 секунд. Запросов: 23.